Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddc(4) [netbsd man page]

DDC(4)							   BSD Kernel Interfaces Manual 						    DDC(4)

NAME
ddc -- VESA Display Data Channel V2 devices SYNOPSIS
ddc at iic? addr 0x50 DESCRIPTION
The ddc driver provides support for accessing the VESA Display Data Channel Version 2 supported by many video displays. BUGS
This driver does not provide any mechanism for access from user applications. Its only use at this point is to provide a means for frame- buffer device drivers to query monitor description data (EDID) using a specialized in-kernel API. No support for sending control commands to display devices is provided. SEE ALSO
iic(4), ddc(9), edid(9) HISTORY
The ddc device appeared in NetBSD 4.0. AUTHORS
Garrett D'Amore <gdamore@NetBSD.org> BSD
May 11, 2006 BSD

Check Out this Related Man Page

DDC(9)							   BSD Kernel Developer's Manual						    DDC(9)

NAME
ddc -- VESA Display Data Channel V2 SYNOPSIS
#include <dev/i2c/ddcvar.h> int ddc_read_edid(i2c_tag_t tag, uint8_t *dest, size_t len); DESCRIPTION
The ddc_read_edid() reads a VESA Extended Display Identification Data block (EDID) via VESA Display Data Channel (DDCv2). DDCv2 is a proto- col for data exchange between display devices (such as monitors and flat panels) and host machines using an I2C bus. The tag argument is a machine-dependent tag used to specify the I2C bus on which the DDCv2 device is located. The dest argument is a pointer to a buffer where the EDID data will be stored. The len argument is the amount of data to read into the buffer. (The buffer must be large enough.) Typically, this value will be 128, which is the size of a normal EDID data block. Normally the EDID data block will be post-processed with the edid_parse() function. RETURN VALUES
The ddc_read_edid() function returns zero on success, and non-zero otherwise. ENVIRONMENT
The ddc_read_edid() function is part of the ddc(4) driver, and is only included in the kernel if that driver is also included. EXAMPLES
The following code uses ddc_read_edid() to retrieve and print information about a monitor: struct edid_info info; i2c_tag_t tag; char buffer[128]; ... /* initialize i2c tag... */ ... if ((ddc_read_edid(tag, buffer, 128) == 0) && (edid_parse(buffer, &info) == 0)) edid_print(info); ... Note that this must be called before the PCI bus is attached during autoconfiguration. SEE ALSO
ddc(4), edid(9), iic(9) HISTORY
DDCv2 support was added in NetBSD 4.0. AUTHORS
Garrett D'Amore <gdamore@NetBSD.org> BSD
May 11, 2006 BSD
Man Page

2 More Discussions You Might Find Interesting

1. HP-UX

Error upon completion of ddcommand

I'm quite new to HP-UX. I got an SSD which fits physically to my system. However, it just doesn't function as a bootable disk. I can format the drive but I am getting I/O errors when I complete the ddcommand. The error is as follows: I/O Error 1960+1 records in 1961+0 records out Any... (9 Replies)
Discussion started by: sunsear24
9 Replies

2. Solaris

/etc/inet.d/nddconfig file.......

Hiii... Every One..... I want to know about : /etc/init.d/nddconfig file, and all it's entries .And how this file controles parameters of OS Hardening...... If any one have related materials then plz HELP........ (2 Replies)
Discussion started by: prashantshukla
2 Replies