Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ccd(4) [netbsd man page]

CCD(4)							   BSD Kernel Interfaces Manual 						    CCD(4)

NAME
ccd -- Concatenated disk driver SYNOPSIS
pseudo-device ccd [count] DESCRIPTION
The ccd driver provides the capability of combining one or more disks/partitions into one virtual disk. This document assumes that you're familiar with how to generate kernels, how to properly configure disks and pseudo-devices in a kernel con- figuration file, and how to partition disks. Note that the 'raw' partitions of the disks must not be combined. Each component partition should be offset at least one cylinder from the beginning of the component disk. This avoids potential conflicts between the component disk's disklabel and the ccd's disklabel. The kernel will only allow component partitions of type FS_CCD. But for now, it allows partition of all types since some port lacks support of an on- disk BSD disklabel. The partition of FS_UNUSED may be rejected because device driver of component disk will refuse it. In order to compile in support for the ccd, you must add a line similar to the following to your kernel configuration file: pseudo-device ccd 4 # concatenated disk devices The count argument is how many ccds memory is allocated for at boot time. In this example, no more than 4 ccds may be configured. A ccd may be either serially concatenated or interleaved. To serially concatenate the partitions, specify the interleave factor of 0. If a ccd is interleaved correctly, a ``striping'' effect is achieved, which can increase performance. Since the interleave factor is expressed in units of DEV_BSIZE, one must account for sector sizes other than DEV_BSIZE in order to calculate the correct interleave. The kernel will not allow an interleave factor less than the size of the largest component sector divided by DEV_BSIZE. Note that best performance is achieved if all component disks have the same geometry and size. Optimum striping cannot occur with different disk types. Also note that the total size of concatenated disk may vary depending on the interleave factor even if the exact same components are concate- nated. And an old on-disk disklabel may be read after interleave factor change. As a result, the disklabel may contain wrong partition geometry and will cause an error when doing I/O near the end of concatenated disk. There is a run-time utility that is used for configuring ccds. See ccdconfig(8) for more information. WARNINGS
If just one (or more) of the disks in a non-mirrored ccd fails, the entire file system will be lost. FILES
/dev/{,r}ccd* ccd device special files. SEE ALSO
config(1), MAKEDEV(8), ccdconfig(8), fsck(8), mount(8), newfs(8) HISTORY
The concatenated disk driver was originally written at the University of Utah. BSD
March 5, 2004 BSD

Check Out this Related Man Page

disklabel(4)						     Kernel Interfaces Manual						      disklabel(4)

NAME
disklabel - Disk pack label SYNOPSIS
#include <sys/disklabel.h> DESCRIPTION
Each disk or disk pack on a system may contain a disk label which provides detailed information about the geometry of the disk and the par- titions into which the disk is divided. It should be initialized when the disk is formatted, and may be changed later with the disklabel program. This information is used by the system disk driver and by the bootstrap program to determine how to program the drive and where to find the file systems on the disk partitions. Additional information is used by the file system in order to use the disk most effi- ciently and to locate important file system information. The description of each partition contains an identifier for the partition type (standard file system, swap area, etc.). The file system updates the in-core copy of the label if it contains incomplete information about the file system. The label is located in sector number LABELSECTOR of the drive, usually sector 0 (zero) where it may be found without any information about the disk geometry. It is at an offset LABELOFFSET from the beginning of the sector, to allow room for the initial bootstrap. The disk sector containing the label is normally made read-only so that it is not accidentally overwritten by pack-to-pack copies or swap opera- tions; the DIOCWLABEL ioctl, which is done as needed by the disklabel program, allows modification of the label sector. A copy of the in-core label for a disk can be obtained with the DIOCGDINFO ioctl; this works with a file descriptor for a block or charac- ter (raw) device for any partition of the disk. The in-core copy of the label is set by the DIOCSDINFO ioctl. The offset of a partition cannot generally be changed, nor made smaller while it is open. One exception is that any change is allowed if no label was found on the disk, and the driver was able to construct only a skeletal label without partition information. Finally, the DIOCWDINFO ioctl operation sets the in-core label and then updates the on-disk label; there must be an existing label on the disk for this operation to succeed. Thus, the initial label for a disk or disk pack must be installed by writing to the raw disk. All of these operations are normally done using the disklabel program. RELATED INFORMATION
Files: disktab(4) Commands: disklabel(8) delim off disklabel(4)
Man Page