|Linux & Unix Commands - Search Man Pages
ATARAID(4) BSD Kernel Interfaces Manual ATARAID(4)
ataraid -- software BIOS RAID
ld* at ataraid? vendtype ? unit ?
The ataraid driver provides support for BIOS-based software RAID controllers. These are
devices which have some simple support for several basic RAID levels (often RAID 0 and RAID
1), but which require software support to actually perform the RAID function. The BIOS sup-
port is largely just to create and recognize the array so that it may be a boot device.
The driver currently supports RAID formats from:
o Adaptec HostRAID (found in Intel 6300ESB)
o Intel MatrixRAID
o JMicron RAID
o nVidia MediaShield
o Promise FastTrak
o Via V-RAID (found in many VIA-based motherboards)
Status of the logical disk as well as the disks associated with it, can be viewed through
the bioctl(8) utility.
The ataraid driver first appeared in NetBSD 2.0.
The ataraid driver was originally adapted from FreeBSD by Jason Thorpe <thorpej@NetBSD.org>.
Not all features of the software RAID are currently recognized or supported. For example,
the Adaptec support doesn't recognize when a RAID 1 should be in a ``building'' state, and
it does not do the right thing.
At least part of the reason for this is that the publically-available information on these
formats is quite limited.
BSD September 16, 2008 BSD
All times are GMT -4. The time now is 05:04 AM.