ADMTEMP(4) BSD Kernel Interfaces Manual ADMTEMP(4)NAME
admtemp -- Analog Devices ADM1021 temperature sensor
admtemp* at iic? addr 0x18
The admtemp driver provides support for the Analog Devices ADM1021, Analog Devices ADM1023, Analog Devices ADM1032, Genesys Logic GL523SM,
Global Mixed-mode Technology G781, Maxim 1617, and Xeon embedded temperature sensors. The device possesses internal and external temperature
sensors. These values are made available through the envstat(8) interface.
On i386 machines, this driver also supports the Xeon embedded I2C temperature probes. In this case, however, only one temperature value is
SEE ALSO iic(4), intro(4), envstat(8)AUTHORS
The admtemp driver was written by Theo de Raadt <email@example.com>.
BSD October 29, 2008 BSD
Check Out this Related Man Page
APS(4) BSD Kernel Interfaces Manual APS(4)NAME
aps -- ThinkPad Active Protection System accelerometer
aps0 at isa? port 0x1600
The aps driver provides support for several sensors found in some ThinkPad laptops.
The sensors currently exposed via the envsys(4) interface are:
Sensor Units Typical Use
x-acceleration integer X-axis acceleration
y-acceleration integer Y-axis acceleration
x-variable integer Weighted X acceleration?
y-variable integer Weighted Y acceleration?
temperature 1 degC Unknown temperature
temperature 2 degC Unknown temperature
keyboard active boolean Keyboard activity
mouse active boolean Mouse activity
lid open boolean Lid state
SEE ALSO envsys(4), hpacel(4), thinkpad(4), envstat(8)HISTORY
The aps driver first appeared in OpenBSD 3.8 and was then ported to NetBSD 5.0.
The aps driver was written by Jonathan Gray <firstname.lastname@example.org>.
Few issues can be mentioned.
o The aps driver does not maintain state and subsequently does not take evasive action when it thinks the hard drive is in danger. Possi-
ble actions would include spinning down the hard drive in case excessive tremor is detected by the sensors.
o The Y axis on X40 and possibly other models seems to be inverted. It is unknown how to distinguish between different versions of the
accelerometer to compensate for this in the driver at this time.
o The sensor values are refreshed every 0.5 seconds. Because no protection measures are taken, this is unnecessary and may have a negative
effect on battery life.
o As IBM provides no documentation, it is not known what all the available sensors are used for.
BSD July 13, 2011 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)