|Linux & Unix Commands - Search Man Pages
AAC(4) BSD Kernel Interfaces Manual AAC(4)
aac -- Adaptec AdvancedRAID Controller driver
aac* at pci? dev ? function ?
ld* at aac? unit ?
The aac driver provides support for the Adaptec AAC family of SCSI and SATA RAID con-
trollers. These controllers support RAID 0, 1, 5, 10, and volume sets. They have four
channels in the add-in version or 1-2 channels in the motherboard integrated version, and
are most often found rebadged by Dell, Hewlett-Packard or IBM. Supported controllers
o Adaptec AAC-364
o Adaptec SCSI RAID 2120S
o Adaptec SCSI RAID 2200S
o Adaptec SATA RAID 2410SA
o Adaptec SATA RAID 3405
o Adaptec SCSI RAID 5400S
o Dell PERC 2/Si
o Dell PERC 2/QC
o Dell PERC 3/Di
o Dell PERC 3/Si
o Dell PERC 320/DC
o Dell CERC SATA RAID 1.5/6ch
o HP NetRAID 4M
o HP ML110 G2 (Adaptec SATA RAID 2610SA)
o IBM ServeRAID 8k
Access to RAID containers is available via the ld device driver. Individual drives cannot
be accessed unless they are part of a container or volume set, and non-fixed disks cannot be
accessed. Containers can be configured by using the on-board BIOS utility of the card.
The adapter can send status and alert messages asynchronously to the driver. These messages
are printed on the system console.
The aac driver first appeared in NetBSD 1.6, and was based on the FreeBSD driver of the same
This driver is not compatible with controllers that have version 1.x firmware. The firmware
version is the same as the kernel version printed in the BIOS POST and driver attach mes-
BSD February 19, 2011 BSD
All times are GMT -4. The time now is 02:14 AM.