VIPW(8) BSD System Manager's Manual VIPW(8)NAME
vipw -- edit the password file
Vipw edits the password file after setting the appropriate locks, and does any necessary processing after the password file is unlocked. If
the password file is already locked for editing by another user, vipw will ask you to try again later. The default editor for vipw is vi(1).
Vipw performs a number of consistency checks on the password entries, and will not allow a password file with a ``mangled'' entry to be
installed. If vipw rejects the new password file, the user is prompted to re-enter the edit session.
Once the information has been verified, vipw uses pwd_mkdb(8) to update the user database. This is run in the background, and, at very large
sites could take several minutes. Until this update is completed, the password file is unavailable for other updates and the new information
is not available to programs.
If the following environment variable exists it will be utilized by vipw:
EDITOR The editor specified by the string EDITOR will be invoked instead of the default editor vi(1).
SEE ALSO chpass(1), passwd(1), passwd(5), pwd_mkdb(8)HISTORY
The vipw command appeared in 4.0BSD.
4th Berkeley Distribution June 6, 1993 4th Berkeley Distribution
Check Out this Related Man Page
vipw(1B) SunOS/BSD Compatibility Package Commands vipw(1B)NAME
vipw - edit the password file
vipw edits the password file while setting the appropriate locks, and does any necessary processing after the password file is unlocked. If
the password file is already being edited, then you will be told to try again later. The vi(1) editor will be used unless the environment
variable VISUAL or EDITOR indicates an alternate editor.
vipw performs a number of consistency checks on the password entry for root, and will not allow a password file with a "mangled" root entry
to be installed. It also checks the /etc/shells file to verify the login shell for root.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWscpu |
SEE ALSO passwd(1), vi(1), passwd(4), attributes(5)SunOS 5.11 14 Sep 1992 vipw(1B)
Can anybody tell me how can I create an account without having to enter the password after editing the vipw file. I mean the system should automatically take care of the password encryption in the shadow file and I don't to enter the password again and the Account should be ready to go.
... (3 Replies)
Is the following even possible ? by echo $3, I mean enter password when prompted for it. My main issue is that it would deal with a prompted password, which is passed from the command line like this:
./processing serverA user password
I cannot not use expect here, I heard that was very... (1 Reply)
I my Pc the vendor installed linux and windowsXp in my pc now i have forgot my Root password itself.
will anyone please Help me break password or how can i enter into Linux.
I welcowe all for valuable suggestions
gvvr (1 Reply)
I was wondering, how can I echo password using a character such as '*' in unix?
In my machine, password is not echoed, so it is only blank space when I enter any password.
So, when I enter a command such as "lock", how can I set the echo character to "*" or something else for... (4 Replies)
In my script I am calling another script.. in that script I need to enter a password. Problem is that everyone is able to see the password when I enter that. Is there any way that when i enter that password it should not display or may look like *******.
Or if there any other way that I... (1 Reply)
i m trying to set acl using acledit command in AIX box
but wat im gettung is
3002-100 acledit: EDITOR environment variable not set
can anyone help me out how 2 set editor....................
thanks in advance (4 Replies)
I am doing a project which asks me to enter password 4 times in a row. I need to enter the same password 4 times. My target is to enter password once and apply it 4 times.
My friend told me to use "expect" command. Can you please give me a sample code to do so.
sample command :- $ ssh... (1 Reply)
I'm having an issue resetting an Linux user password. As root, I type 'passwd <username>, enter the new password, but the user is still Access Denied. Can someone assist me in figuring this one out?
The box is running "Linux trm62 2.4.21-15.ELsmp #1 SMP Thu Apr 22 00:18:24 EDT 2004... (6 Replies)
Hi I`m newble here.
How I can make "strong" password by dafault?
Variable in /etc/default/passwd set PASSLENGTH=6
I need to make setting password min passlength 8 and include sumbols !@#$%^&*() , digits, ets...
Plz, help me where I must change setting?
P.S. Sorry for my english. (4 Replies)
In the script i am passing a command from script which is called from cron. When this command is called from cron the unix prompt asks for password. Can we automatically enter the password when promted(if the password is hardcoded in script)??
Please let me know how to enter the password... (4 Replies)
I am working with a script to simplyfy some operations where I work, but one of the programs needs me to enter a password.
It will as me "Please enter the administrator password:"
Is there a way to make a bash script to automatically answer the question with the needed password?
I am looking... (3 Replies)
i cant set password for user (jam)
i tried to
enter newpasswd :
after enter it showing
passwd : cannot get default domain:internal yp server or client error
i also check cat /etc/shadow file
user is locked ... and i... (4 Replies)
I have a problem setting the password when I have to create a user and password as detailed below.
username : gaacj01 password : oshopp01
username : gaacj02 password : oshopp02
username : gaacj03 password : oshopp03
username : gaacj04 password : oshopp04
username : gaacj05 ... (17 Replies)