Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

operator(7) [mojave man page]

OPERATOR(7)					       BSD Miscellaneous Information Manual					       OPERATOR(7)

NAME
operator -- C operator precedence and order of evaluation DESCRIPTION
Operator Associativity -------- ------------- () [] -> . left to right ! ~ ++ -- - (type) * & sizeof right to left * / % left to right + - left to right << >> left to right < <= > >= left to right == != left to right & left to right ^ left to right | left to right && left to right || left to right ?: right to left = += -= etc. right to left , left to right FILES
/usr/share/misc/operator BSD
June 9, 1993 BSD

Check Out this Related Man Page

DROP 
OPERATOR(7) PostgreSQL 9.2.7 Documentation DROP OPERATOR(7) NAME
DROP_OPERATOR - remove an operator SYNOPSIS
DROP OPERATOR [ IF EXISTS ] name ( { left_type | NONE } , { right_type | NONE } ) [ CASCADE | RESTRICT ] DESCRIPTION
DROP OPERATOR drops an existing operator from the database system. To execute this command you must be the owner of the operator. PARAMETERS
IF EXISTS Do not throw an error if the operator does not exist. A notice is issued in this case. name The name (optionally schema-qualified) of an existing operator. left_type The data type of the operator's left operand; write NONE if the operator has no left operand. right_type The data type of the operator's right operand; write NONE if the operator has no right operand. CASCADE Automatically drop objects that depend on the operator. RESTRICT Refuse to drop the operator if any objects depend on it. This is the default. EXAMPLES
Remove the power operator a^b for type integer: DROP OPERATOR ^ (integer, integer); Remove the left unary bitwise complement operator ~b for type bit: DROP OPERATOR ~ (none, bit); Remove the right unary factorial operator x! for type bigint: DROP OPERATOR ! (bigint, none); COMPATIBILITY
There is no DROP OPERATOR statement in the SQL standard. SEE ALSO
CREATE OPERATOR (CREATE_OPERATOR(7)), ALTER OPERATOR (ALTER_OPERATOR(7)) PostgreSQL 9.2.7 2014-02-17 DROP OPERATOR(7)
Man Page

12 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

multi-file multi-edit

Good day! I am trying to learn how to use the "sed" editor, to perform multiple edits on multiple files in multiple directories. I have one script that tries to call up each file and process it according to the edits listed in a second script. I am using a small input text to test these, at... (12 Replies)
Discussion started by: kielitaide
12 Replies

2. UNIX for Advanced & Expert Users

bitwise operators

can anybody write a program to divide a number by another number using bitwise operators (9 Replies)
Discussion started by: areef4u
9 Replies

3. Programming

sizeof an array of structure without using 'sizeof' operator

Hi All, is it possible to find out the size of an array of structures ( without using 'sizeof' operator). The condition is we have the array of structure instant but we are not aware of the elements inside the structure. Can someone help me out? Thanks in advance. (18 Replies)
Discussion started by: rvan
18 Replies

4. Shell Programming and Scripting

string comparison operators, what are they??

hi guys im a newbie to shell scripting and would appreciate any help possible. my questions will be very straight forward and relatively trivial to most of you. as the thread title is asking, what are the operators?? i know there's the != and =, but for bourne and c shell, what are the... (12 Replies)
Discussion started by: ballazrus
12 Replies

5. UNIX for Dummies Questions & Answers

How do I search for 2 strings (AND operator) ?

I have a need to search for files containing 2 strings as in (AND operator). No one at my site seems to know if it is possible. There is only documentation for the "or' operator. I know I can do a search, copy all the matched files into a temp directory & do the second search in the temp... (14 Replies)
Discussion started by: Kartheg
14 Replies

6. Shell Programming and Scripting

OR operator syntax question in AWK script

Hi guys, I confused about syntax used in OR script as follow: I have this sample file separated by "|" containing: January|Month No. 1 February|Month No. 2 March|Month No. 3 April|Month No. 4 May|Month No. 5 June|Month No. 6 July|Month No. 7 August|Month No. 8 September|Month No. 9... (11 Replies)
Discussion started by: cgkmal
11 Replies

7. UNIX for Dummies Questions & Answers

[: =: unary operator expected error

Why am I getting this error.... #!/bin/sh # iOS-Ad-Remover # Marshall Ford @ marshallbford@gmail.com # This project is hosted @ http://ios-ad- # remover.sourceforge.net # Under the GNU GPL open source license clear echo if ; then echo "You need to be root to run this script."; exit 0; #... (24 Replies)
Discussion started by: mbf123
24 Replies

8. Shell Programming and Scripting

Help with removal of spaces between operators and operands

Hi I'm trying to remove blank spaces in expressions and function calls.. Consider the following example printf ("Hello"); a = a + b; I'm trying to eliminate space in between the function name and the opening brace. And also eliminate space between operators and operands.. That is, I'm... (19 Replies)
Discussion started by: abk07
19 Replies

9. Shell Programming and Scripting

Grep mutiple patterns with 'AND' operator

Hello, I'm trying for days to do a grep without any success. :wall: I have two patterns being: 1 - Master en Achats 2 - complet $ find /var/www/mysite/uploads/files/*.doc -exec egrep -l --ignore-case "Master en Achats|complet" {} \; The problem is that the grep command is done with an... (15 Replies)
Discussion started by: sjolicoeur
15 Replies

10. Shell Programming and Scripting

File operator command

Hey all, I not able to find it what -n stand operator stands for. ] && print -u2 "ERROR: $*" could you please let me know why we are using -n in the code. (15 Replies)
Discussion started by: arun888
15 Replies

11. Shell Programming and Scripting

Newbie question: modulo operator with negative operand, bug or feature?

Hi, I'm new to the Ash shell so my apologies if this is well known. In normal maths and other shells and languages I've used, the modulo operator always returns a positive remainder. For example see this discussion (first post so I can't hyperlink it): ... (11 Replies)
Discussion started by: FleetFoot
11 Replies

12. Shell Programming and Scripting

BC calculation for floating (invalid arithmetic operator )

Hi, I wish to compare the CPU LOAD 1 min with 5mins and 15mins. If 1 min's CPU LOAd spike 3% compare to 5 mins or 15 mins CPU Load, it is warning. If 1 min's CPU LOAd spike 5% compare to 5 mins or 15 mins CPU Load, it is critical. However I received following code error, I google it and... (10 Replies)
Discussion started by: alvintiow
10 Replies