Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

wtmp(5) [mojave man page]

UTMP(5) 						      BSD File Formats Manual							   UTMP(5)

NAME
utmp, wtmp, lastlog -- login records (DEPRECATED) SYNOPSIS
#include <utmp.h> DESCRIPTION
The interfaces in file <utmp.h> are all DEPRECATED and are only provided for compatibility with previous releases of Mac OS X. See pututxline(3) and utmpx(5) for the supported interfaces. <utmp.h> declares the structures used to record information about current users in the file utmp, logins and logouts in the file wtmp, and last logins in the file lastlog. The time stamps of date changes, shutdowns and reboots are also logged in the wtmp file. These files can grow rapidly on busy systems, daily or weekly rotation is recommended. If any of these files do not exist, it is not cre- ated. These files must be created manually and are normally maintained in either the script /etc/daily or the script /etc/weekly. (See cron(8).) #define _PATH_UTMP "/var/run/utmp" #define _PATH_WTMP "/var/log/wtmp" #define _PATH_LASTLOG "/var/log/lastlog" #define UT_NAMESIZE 8 #define UT_LINESIZE 8 #define UT_HOSTSIZE 16 struct lastlog { time_t ll_time; char ll_line[UT_LINESIZE]; char ll_host[UT_HOSTSIZE]; }; struct utmp { char ut_line[UT_LINESIZE]; char ut_name[UT_NAMESIZE]; char ut_host[UT_HOSTSIZE]; time_t ut_time; }; Each time a user logs in, the login program looks up the user's UID in the file lastlog. If it is found, the timestamp of the last time the user logged in, the terminal line and the hostname are written to the standard output. (Providing the login is not quiet, see login(1).) The login program then records the new login time in the file lastlog. After the new lastlog record is written , the file utmp is opened and the utmp record for the user inserted. This record remains there until the user logs out at which time it is deleted. The utmp file is used by the programs rwho(1), users(1), w(1), and who(1). Next, the login program opens the file wtmp, and appends the user's utmp record. The same utmp record, with an updated time stamp is later appended to the file when the user logs out. (See launchd(8).) The wtmp file is used by the programs last(1) and ac(8). In the event of a date change, a shutdown or reboot, the following items are logged in the wtmp file. reboot shutdown A system reboot or shutdown has been initiated. The character '~' is placed in the field ut_line, and reboot or shutdown in the field ut_name. (See shutdown(8) and reboot(8).) date The system time has been manually or automatically updated. (See date(1).) The command name date is recorded in the field ut_name. In the field ut_line, the character '|' indicates the time prior to the change, and the character '{' indicates the new time. FILES
(These files no longer exist in 10.5 or later.) /var/run/utmp The utmp file. /var/log/wtmp The wtmp file. /var/log/lastlog The lastlog file. SEE ALSO
last(1), login(1), who(1), ac(8), launchd(8) HISTORY
A utmp and wtmp file format appeared in Version 6 AT&T UNIX. The lastlog file format appeared in 3.0BSD. 4th Berkeley Distribution March 17, 1994 4th Berkeley Distribution

Check Out this Related Man Page

LOGIN(3)						     Linux Programmer's Manual							  LOGIN(3)

NAME
login, logout - write utmp and wtmp entries SYNOPSIS
#include <utmp.h> void login(const struct utmp *ut); int logout(const char *ut_line); Link with -lutil. DESCRIPTION
The utmp file records who is currently using the system. The wtmp file records all logins and logouts. See utmp(5). The function login() takes the supplied struct utmp, ut, and writes it to both the utmp and the wtmp file. The function logout() clears the entry in the utmp file again. GNU details More precisely, login() takes the argument ut struct, fills the field ut->ut_type (if there is such a field) with the value USER_PROCESS, and fills the field ut->ut_pid (if there is such a field) with the process ID of the calling process. Then it tries to fill the field ut->ut_line. It takes the first of stdin, stdout, stderr that is a terminal, and stores the corresponding pathname minus a possible lead- ing /dev/ into this field, and then writes the struct to the utmp file. On the other hand, if no terminal name was found, this field is filled with "???" and the struct is not written to the utmp file. After this, the struct is written to the wtmp file. The logout() function searches the utmp file for an entry matching the ut_line argument. If a record is found, it is updated by zeroing out the ut_name and ut_host fields, updating the ut_tv timestamp field and setting ut_type (if there is such a field) to DEAD_PROCESS. RETURN VALUE
The logout() function returns 1 if the entry was successfully written to the database, or 0 if an error occurred. FILES
/var/run/utmp user accounting database, configured through _PATH_UTMP in <paths.h> /var/log/wtmp user accounting log file, configured through _PATH_WTMP in <paths.h> CONFORMING TO
Not in POSIX.1-2001. Present on the BSDs. NOTES
Note that the member ut_user of struct utmp is called ut_name in BSD. Therefore, ut_name is defined as an alias for ut_user in <utmp.h>. SEE ALSO
getutent(3), utmp(5) COLOPHON
This page is part of release 3.53 of the Linux man-pages project. A description of the project, and information about reporting bugs, can be found at http://www.kernel.org/doc/man-pages/. GNU
2004-05-06 LOGIN(3)
Man Page