Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

quntimeout(9f) [hpux man page]

quntimeout(9F)						   Kernel Functions for Drivers 					    quntimeout(9F)

NAME
quntimeout - cancel previous qtimeout function call SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> clock_t quntimeout(queue_t *q, timeout_id_t id); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
q Pointer to a STREAMS queue structure. id Opaque timeout ID a previous qtimeout(9F) call. DESCRIPTION
quntimeout() cancels a pending qtimeout(9F) request. The quntimeout() function is tailored to be used with the enhanced STREAMS framework interface, which is based on the concept of perimeters. (See mt-streams(9F).) quntimeout() returns when the timeout has been cancelled or finished executing. The timeout will be cancelled even if it is blocked at the perimeters associated with the queue. quntimeout() should be executed for all outstanding timeouts before a driver or module close returns. All outstanding timeouts and bufcalls must be cancelled before a driver close routine can block and before the close routine calls qprocsoff(9F). RETURN VALUES
quntimeout() returns -1 if the id is not found. Otherwise, quntimeout() returns a 0 or positive value. CONTEXT
quntimeout() can be called from user or interrupt context. SEE ALSO
mt-streams(9F), qbufcall(9F), qtimeout(9F), qunbufcall(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 17 Oct 2002 quntimeout(9F)

Check Out this Related Man Page

quntimeout(9F)						   Kernel Functions for Drivers 					    quntimeout(9F)

NAME
quntimeout - cancel previous qtimeout function call SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> clock_t quntimeout(queue_t *q, timeout_id_t id); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
q Pointer to a STREAMS queue structure. id Opaque timeout ID a previous qtimeout(9F) call. DESCRIPTION
quntimeout() cancels a pending qtimeout(9F) request. The quntimeout() function is tailored to be used with the enhanced STREAMS framework interface, which is based on the concept of perimeters. (See mt-streams(9F).) quntimeout() returns when the timeout has been cancelled or finished executing. The timeout will be cancelled even if it is blocked at the perimeters associated with the queue. quntimeout() should be executed for all outstanding timeouts before a driver or module close returns. All outstanding timeouts and bufcalls must be cancelled before a driver close routine can block and before the close routine calls qprocsoff(9F). RETURN VALUES
quntimeout() returns -1 if the id is not found. Otherwise, quntimeout() returns a 0 or positive value. CONTEXT
quntimeout() can be called from user or interrupt context. SEE ALSO
mt-streams(9F), qbufcall(9F), qtimeout(9F), qunbufcall(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 17 Oct 2002 quntimeout(9F)
Man Page

14 More Discussions You Might Find Interesting

1. Tips and Tutorials

Unix File Permissions

Introduction I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls: $ ls -ld /usr/bin /usr/bin/cat drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin -r-xr-xr-x 1 bin bin ... (6 Replies)
Discussion started by: Perderabo
6 Replies

2. HP-UX

How to list file size on HPUX?

I used to use ls -l cut to detrmine file size, and google searches didn't come up with anything else but 'stat' which doesn't appear on HPUX. I discovered the humble 'wc -c' which does this job very neatly, and thought I would share it. (7 Replies)
Discussion started by: tbochan
7 Replies

3. Fedora

Is UNIX an open source OS ?

Hi everyone, I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX. Ok onto business, my questions are-: Was/Is UNIX ever an open source operating system ? If UNIX was... (21 Replies)
Discussion started by: sreyan32
21 Replies

4. Shell Programming and Scripting

How to extract every repeated string between two specific string?

Hello guys, I have problem with hpux shell script. I have one big text file that contains like SOH bla bla bla bla bla bla ETX SOH bla bla bla ETX SOH bla bla bla ETX What I need to do is save first SOH*BLA into file1.txt, save second SOH*BLA into file2.txt and so on.... (17 Replies)
Discussion started by: sembii
17 Replies

5. HP-UX

SAN Migration question

Hi, I am very new to HP-UX, and we're going to be doing a SAN migration. We're going to take down the machine, and zone it to the new SAN. My question is, will the device names change and will that interfere with the LVM? If the new disks come in with different device names, how would I... (3 Replies)
Discussion started by: BG_JrAdmin
3 Replies

6. Shell Programming and Scripting

Sequence extraction

i want to extract specific region of interest from big file. i have only start position, end position and seq id, see my query is: I have file1 is this >GL3482.1 GAACTTGAGATCCGGGGA GCAGTGGATCTCCACCAG CGGCCAGAACTGGTGCAC CTCCAGGCCAGCCTCGTC CTGCGTGTC >GL3550.1... (14 Replies)
Discussion started by: harpreetmanku04
14 Replies

7. HP-UX

Hpux 11iV3 administration document

I require Hpux 11iv3 administration document if anyone could assist with the same it would be a great help. The Hp site does not have any consolidated document that could be referred to. I require something in line that could assist with network configuration and more. I require the same for Build... (3 Replies)
Discussion started by: kpatel786
3 Replies

8. What is on Your Mind?

Thank you members and admins

Got a raise and a formal position of 'unix system engineer' in 2016. I would like to thank you members and admins. This would not be possible without you. I will mention some.. Thank you Don, for making me learn and understand the importance of standards, which i try to apply as much as i... (3 Replies)
Discussion started by: Peasant
3 Replies

9. Shell Programming and Scripting

awk - Multi-line data to be stored in variable

Greetings Experts, As part of automating the sql generation, I have the source table name, target table name, join condition stored in a file join_conditions.txt which is a delimited file (I can edit the file if for any reason). The reason I needed to store is I have built SELECT list without... (5 Replies)
Discussion started by: chill3chee
5 Replies

10. Shell Programming and Scripting

Seeking Alternative for diff in hp

Hi , I have to use HP-unix OS to get difference between 2 files.while i tried a piece of code in other OS(linux/unix) as below, it worked fine & the output is desired one. diff --suppress-common-lines -y file_1 file_2 >d.txt The same doesn't works in HP -unix. Any help shall be... (6 Replies)
Discussion started by: vinil
6 Replies

11. UNIX for Advanced & Expert Users

Tar Command

hi folks, how to using tar with exclude directory and compress it using tar.Z i only know how to exclude dir only with this command below: tar -cvf /varios/restore/test.tar -X excludefile.txt /jfma/test1/ how to compress it using 1 command? Thanx Please use CODE tags as... (6 Replies)
Discussion started by: only
6 Replies

12. War Stories

Wrong Array...

Back in my early days, just starting at my first job where I was doing 100% UNIX... We had a mixture of Solaris, AIX, and HPUX systems. Our most critical systems (Logistics) was running on a bunch of large HP 9000 servers. I was tasked with decommisoning one of the servers. It was one... (5 Replies)
Discussion started by: xenix
5 Replies

13. What is on Your Mind?

PHP Man Pages Now Available (Over 10,000)

Hello! Yesterday we added over 10,000 PHP man pages to our man page section. I've not yet got our unique and special recursive search feature working; but you can still access the PHP man pages directly by selecting PHP in the man sets drop down menu (left side) and then section 3 (right... (3 Replies)
Discussion started by: Neo
3 Replies

14. UNIX for Advanced & Expert Users

Shopt -s histappend

What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file. # When the shell exits, append to the history file instead of overwriting it shopt -s histappend (3 Replies)
Discussion started by: cokedude
3 Replies