putctl1(9F) Kernel Functions for Drivers putctl1(9F)NAME
putctl1 - send a control message with a one-byte parameter to a queue
SYNOPSIS
#include <sys/stream.h>
int putctl1(queue_t *q, int type, int p);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Queue to which the message is to be sent.
type Type of message.
p One-byte parameter.
DESCRIPTION
putctl1(), like putctl(9F), tests the type argument to make sure a data type has not been specified, and attempts to allocate a message
block. The p parameter can be used, for example, to specify how long the delay will be when an M_DELAY message is being sent. putctl1()
fails if type is M_DATA, M_PROTO, or M_PCPROTO, or if a message block cannot be allocated. If successful, putctl1() calls the put(9E) rou-
tine of the queue pointed to by q with the newly allocated and initialized message.
RETURN VALUES
On success, 1 is returned. 0 is returned if type is a data type, or if a message block cannot be allocated.
CONTEXT
putctl1() can be called from user or interrupt context.
EXAMPLES
See the putctl(9F) function page for an example of putctl1().
SEE ALSO put(9E), allocb(9F), datamsg(9F), putctl(9F), putnextctl1(9F)
Writing Device Drivers
STREAMS Programming Guide
SunOS 5.10 11 Apr 1991 putctl1(9F)
Check Out this Related Man Page
putctl1(9F) Kernel Functions for Drivers putctl1(9F)NAME
putctl1 - send a control message with a one-byte parameter to a queue
SYNOPSIS
#include <sys/stream.h>
int putctl1(queue_t *q, int type, int p);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Queue to which the message is to be sent.
type Type of message.
p One-byte parameter.
DESCRIPTION
putctl1(), like putctl(9F), tests the type argument to make sure a data type has not been specified, and attempts to allocate a message
block. The p parameter can be used, for example, to specify how long the delay will be when an M_DELAY message is being sent. putctl1()
fails if type is M_DATA, M_PROTO, or M_PCPROTO, or if a message block cannot be allocated. If successful, putctl1() calls the put(9E) rou-
tine of the queue pointed to by q with the newly allocated and initialized message.
RETURN VALUES
On success, 1 is returned. 0 is returned if type is a data type, or if a message block cannot be allocated.
CONTEXT
putctl1() can be called from user or interrupt context.
EXAMPLES
See the putctl(9F) function page for an example of putctl1().
SEE ALSO put(9E), allocb(9F), datamsg(9F), putctl(9F), putnextctl1(9F)
Writing Device Drivers
STREAMS Programming Guide
SunOS 5.10 11 Apr 1991 putctl1(9F)
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)