Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

sysinit(9) [freebsd man page]

SYSINIT(9)						   BSD Kernel Developer's Manual						SYSINIT(9)

NAME
SYSINIT, SYSUNINIT -- a framework for dynamic kernel initialization SYNOPSIS
#include <sys/param.h> #include <sys/kernel.h> SYSINIT(uniquifier, enum sysinit_sub_id subsystem, enum sysinit_elem_order order, sysinit_cfunc_t func, const void *ident); SYSUNINIT(uniquifier, enum sysinit_sub_id subsystem, enum sysinit_elem_order order, sysinit_cfunc_t func, const void *ident); DESCRIPTION
SYSINIT is a mechanism for scheduling the execution of initialization and teardown routines. This is similar to init and fini routines with the addition of explicit ordering metadata. It allows runtime ordering of subsystem initialization in the kernel as well as kernel modules (KLDs). The SYSINIT() macro creates a struct sysinit and stores it in a startup linker set. The struct sysinit type as well as the subsystem identi- fier constants (SI_SUB_*) and initialization ordering constants (SI_ORDER_*) are defined in <sys/kernel.h>: struct sysinit { enum sysinit_sub_id subsystem; /* subsystem identifier*/ enum sysinit_elem_order order; /* init order within subsystem*/ sysinit_cfunc_t func; /* function */ const void *udata; /* multiplexer/argument */ }; The SYSINIT() macro takes a uniquifier argument to identify the particular function dispatch data, the subsystem type of startup interface, the subsystem element order of initialization within the subsystem, the func function to call, and the data specified in ident argument to pass the function. The SYSUNINIT() macro behaves similarly to the SYSINIT() macro except that it adds the data to a shutdown linker set. The startup linker set for the kernel is scanned during boot to build a sorted list of initialization routines. The initialization routines are then executed in the sorted order. The subsystem is used as the primary key and is sorted in ascending order. The order is used as the secondary key and is sorted in ascending order. The relative order of two routines that have the same subsystem and order is undefined. The startup linker sets for modules that are loaded together with the kernel by the boot loader are scanned during the SI_SUB_KLD subsystem initialization. These modules' initialization routines are sorted and merged into the kernel's list of startup routines and are executed during boot along with the kernel's initialization routines. Note that this has the effect that any initialization routines in a kernel mod- ule that are scheduled earlier than SI_SUB_KLD are not executed until after SI_SUB_KLD during boot. The startup linker set for a kernel module loaded at runtime via kldload(2) is scanned, sorted, and executed when the module is loaded. The shutdown linker set for a kernel module is scanned, sorted, and executed when a kernel module is unloaded. The teardown routines are sorted in the reverse order of the initialization routines. The teardown routines of the kernel and any loaded modules are not executed dur- ing shutdown. EXAMPLES
This example shows the SYSINIT which displays the copyright notice during boot: static void print_caddr_t(void *data) { printf("%s", (char *)data); } SYSINIT(announce, SI_SUB_COPYRIGHT, SI_ORDER_FIRST, print_caddr_t, copyright); SEE ALSO
kld(4), DECLARE_MODULE(9), DEV_MODULE(9), DRIVER_MODULE(9), MTX_SYSINIT(9), SYSCALL_MODULE(9) HISTORY
The SYSINIT framework first appeared in FreeBSD 2.2. AUTHORS
The SYSINIT framework was written by Terrence Lambert <terry@FreeBSD.org>. This manual page was written by Hiten Pandya <hmp@FreeBSD.org>. BSD
December 1, 2010 BSD

Check Out this Related Man Page

autosysconfig(8)					      System Manager's Manual						  autosysconfig(8)

NAME
autosysconfig - Maintains the list of dynamic kernel subsystems that are automatically configured SYNOPSIS
/sbin/init.d/autosysconfig add | delete | list [subsystem-name] DESCRIPTION
Use the autosysconfig program to maintain the kernel's list of dynamic subsystems that are automatically configured at each system startup. The following list describes the autosysconfig commands: Adds a dynamic subsystem to the list. At each system startup, the specified sub- system is automatically configured into the kernel. (The object module that contains the subsystem must exist in the /subsys or /var/subsys directory for automatic configuration to work correctly.) You must specify the subsystem-name parameter with the add command. Deletes a dynamic subsystem from the list. At each system startup, the specified subsystem is omitted from the kernel. You must specify the subsys- tem-name parameter with the delete command. Lists the dynamic subsystems that are automatically configured at system startup. The system issues the sysconfig -c command to configure dynamic subsystems at system startup. The subsystems are added to the kernel dur- ing the execution of the init program. No dynamic subsystems are automatically configured by default. You must add a subsystem name to the list to enable automatic configuration of that subsystem. EXAMPLES
The following are examples of using the autosysconfig command: To add a subsystem to the list of automatically configured subsystems, issue the following command: # /sbin/init.d/autosysconfig add lat This command adds the lat (Local Area Terminal) subsystem to the list. To see what subsystems are on the list, issue the following command: # /sbin/init.d/autosysconfig list Current automatic configuration list includes the following dynamic subsystems: lat SEE ALSO
Commands: sysconfig(8), sysconfigdb(8) System Administration autosysconfig(8)
Man Page