Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pmap_map(9) [freebsd man page]

PMAP_MAP(9)						   BSD Kernel Developer's Manual					       PMAP_MAP(9)

NAME
pmap_map -- map a physical memory range into kernel virtual address (KVA) space SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> vm_offset_t pmap_map(vm_offset_t *virt, vm_paddr_t start, vm_paddr_t end, int prot); DESCRIPTION
The pmap_map() function maps a range of physical addresses into kernel virtual address (KVA) space, from start to end, with protection bits prot. The value passed in *virt is treated as a hint for the virtual address of the beginning of the mapping. IMPLEMENTATION NOTES
The prot argument is currently ignored by machine-dependent implementations. Architectures which can support a direct mapped physical to virtual region can return the appropriate address within that region, leaving *virt unchanged. RETURN VALUES
The pmap_map() function returns the virtual address of the beginning of the mapping, if the mapping was successfully made; *virt will also be updated with the first usable address after the mapped region. If the function is unsuccessful, NULL is returned. SEE ALSO
pmap(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
July 21, 2003 BSD

Check Out this Related Man Page

VM_MAP_FINDSPACE(9)					   BSD Kernel Developer's Manual				       VM_MAP_FINDSPACE(9)

NAME
vm_map_findspace -- find a free region within a map SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> int vm_map_findspace(vm_map_t map, vm_offset_t start, vm_size_t length, vm_offset_t *addr); DESCRIPTION
The vm_map_findspace() function attempts to find a region with sufficient space in the map for an object of size length at the address addr. IMPLEMENTATION NOTES
It is the caller's responsibility to obtain a lock on the map using vm_map_lock(9) before calling this function. This routine may call pmap_growkernel(9) to grow the kernel's address space, if and only if the mapping is being made within the kernel address space, and if insufficient space remains in the kernel_map. RETURN VALUES
The vm_map_findspace() function returns the value 0 if successful, and *addr will contain the first virtual address in the found region; oth- erwise, the value 1 is returned. SEE ALSO
pmap_growkernel(9), vm_map(9), vm_map_entry_resize_free(9), vm_map_lock(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
July 19, 2003 BSD
Man Page

6 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

sendmail.... any help?

I am trying to configure sendmail (v 8.12.5-7 on Redhat Linux 8) on my server. I am unable to send or receive messages using mail command (or any command for that matter). My mailserver name: abc.com I have setup user1 to alias as user1@def.com so that all of his mails are relayed to... (5 Replies)
Discussion started by: skotapal
5 Replies

2. UNIX for Dummies Questions & Answers

mailx configuration

I would like to configure mailx on Solaris 8 in order to have the sender address shown at the receiver side in the form: 'user@host.domain' The sender address is currently displayed as 'user@host' Thanks in advance (2 Replies)
Discussion started by: ciccio
2 Replies

3. UNIX for Dummies Questions & Answers

Sending email

I have an Solaris 8 machine running a managment application. One of the features of this application is to configure alarm forwarding to an email undress. When i configured the application to do that, it asked me only about the recipient email address. Quesiton: how to configure my Solaris 8... (7 Replies)
Discussion started by: bcheaib
7 Replies

4. UNIX for Advanced & Expert Users

sendmail -q hangs

Hi, I have a system where sendmail deamon not running. (And I have lot of jobs under crontab). But I have whole lot of sendmail processes started-up by cron process, eating up its CPU resources. (for a sample - see below) $ ps -ef|grep 248 root 248 1 0 Aug 12 ? 0:56... (5 Replies)
Discussion started by: chaandana
5 Replies

5. UNIX for Dummies Questions & Answers

Does Mailx store the mails sent

Hi, I use mailx in a shell script to mail a message to the users. i wanted to know if mailx stores the mail that it sends? for eg in microsoft outlook all mails sent get stored in the outbox. is there such a facility with mailx? if not how i can do this so that for every mail sent, a backup... (6 Replies)
Discussion started by: munira_johar
6 Replies

6. HP-UX

Sendmail changes userid in Return-Path

Hi, sendmail on our hp-ux box is changing the userid of the from address. I have searched the web and read the man pages but can't stop this from happening. We have a process which creates a text file we pass into sendmail. In the text file we write for example: Return-Path:... (4 Replies)
Discussion started by: rsmitherscorp
4 Replies