pmap(9) [freebsd man page]
PMAP(9) BSD Kernel Developer's Manual PMAP(9) NAME
pmap -- machine-dependent portion of virtual memory subsystem SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> DESCRIPTION
The pmap module is the machine-dependent portion of the FreeBSD VM (Virtual Memory) sub-system. Each function documented herein must have its own architecture-dependent implementation. The pmap module is responsible for managing hardware-dependent objects such as page tables, address maps, TLBs, etc. Machine-dependent code must provide the header file <machine/pmap.h>. This file contains the definition of the pmap structure: struct pmap { /* Contents defined by pmap implementation. */ }; typedef struct pmap *pmap_t; This header file may also define other data structures used by the pmap implementation. The header file <vm/pmap.h> defines a structure for tracking pmap statistics (see below). This structure is defined as: struct pmap_statistics { long resident_count; /* number of mapped pages */ long wired_count; /* number of wired pages */ }; The implementation's struct pmap must contain an instance of this structure having the name pm_stats, and it must be updated by the implemen- tation after each relevant pmap operation. SEE ALSO
pmap(9), pmap_activate(9), pmap_clear_modify(9), pmap_copy(9), pmap_copy_page(9), pmap_enter(9), pmap_extract(9), pmap_extract_and_hold(9), pmap_growkernel(9), pmap_init(9), pmap_init2(9), pmap_is_modified(9), pmap_is_prefaultable(9), pmap_map(9), pmap_mincore(9), pmap_object_init_pt(9), pmap_page_exists_quick(9), pmap_page_init(9), pmap_pinit(9), pmap_pinit0(9), pmap_pinit2(9), pmap_protect(9), pmap_qenter(9), pmap_qremove(9), pmap_release(9), pmap_remove(9), pmap_remove_all(9), pmap_remove_pages(9), pmap_resident_count(9), pmap_ts_referenced(9), pmap_unwire(9), pmap_wired_count(9), pmap_zero_area(9), pmap_zero_idle(9), pmap_zero_page(9), vm_map(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
August 3, 2014 BSD
Check Out this Related Man Page
pmap(1) General Commands Manual pmap(1) NAME
pmap, pfiles - displays process address information and open file descriptors SYNOPSIS
options] pid1 [pid2...] pid1 [pid2...] DESCRIPTION
prints the address space information of a process. prints information about all open file descriptors of a process. If file descriptor corresponds to a file, then prints the fstat(2) and fcntl(2) information. If the file descriptor corresponds to a socket, then prints socket related info, such as the socket type, socket family, and protocol family. In the case of AF_INET and AF_INET6 family of sockets, information about the peer host is also printed. pmap Options The information printed by can be controlled by the option. The argument to can be a comma-separated set of arguments given below: Display the size data locked in memory for each mapped object. Display the map name. This field can contain the following data. if the object is mapped as if the object mapped is the stack segment of the process. The object mapped is the text segment of the program. The object mapped is the data segment of the program. The object is mapped from a file. If the file name cannot be resolved, then the inode number and the device ID of the file is displayed. Also see the sec- tion below. Other map names include: and Display the offset of each mapped object. Specify access permission for each mapped object. Display the resident size of each mapped object. Display the space ID of each mapped object. Display the swap allocated for each mapped object. Display the maximum size of a page that can be allocated for the object. Indicate the type of data managed by each mapped object. The values include, Shared code, with n indicating the number of processes sharing the mapped object. Private code. Shared data, with n indicating the number of processes sharing the mapped object. Private data. Display the virtual size of each mapped object. Since the name of the file can be of variable length, use the name argument as the last argument to the option to ensure proper indentation of other fields. If no option is specified, prints the following fields by default: and EXTERNAL INFLUENCES
Environment Variables If is not specified or is null, it defaults to (see lang(5)). EXAMPLES
This command prints the virtual address, the resident memory size, and the name of each object mapped for processes with process ID 100 and 200: This command prints information on open file descriptors of processes with process ID 100 and 200: WARNINGS
and depend on to resolve the file names. If the file name cannot be resolved, then these commands will only print the device ID and the inode number of the file. Users of must not rely on the exact field widths and spacing of its output, as these will vary depending on the system and the release of HP-UX. SEE ALSO
fuser(1), ps(1), vmstat(1). pmap(1)