Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

watchdog(9) [freebsd man page]

WATCHDOG(9)						   BSD Kernel Developer's Manual					       WATCHDOG(9)

NAME
watchdog -- software and hardware watchdog facility SYNOPSIS
#include <sys/watchdog.h> void watchdog_fn(void *private, u_int cmd, int *error); EVENTHANDLER_REGISTER(watchdog_list, watchdog_fn, private, 0); EVENTHANDLER_DEREGISTER(watchdog_list, eventhandler_tag); DESCRIPTION
To implement a watchdog in software or hardware, only a single function needs to be written and registered on the global watchdog_list. The function must examine the cmd argument and act on it as follows: If cmd is zero, the watchdog must be disabled and the error argument left untouched. If the watchdog cannot be disabled, the error argument must be set to EOPNOTSUPP. Else the watchdog should be reset and configured to a timeout of (1 << (cmd & WD_INTERVAL)) nanoseconds or larger and the error argument be set to zero to signal arming of a watchdog. If the watchdog cannot be configured to the proposed timeout, it must be disabled and the error argument left as is (to avoid hiding the arm- ing of another watchdog). There is no specification of what the watchdog should do when it times out, but a hardware reset or similar ``drastic but certain'' behaviour is recommended. SEE ALSO
watchdog(4) AUTHORS
The watchdog facility and this manual page was written Poul-Henning Kamp <phk@FreeBSD.org>. BSD
February 28, 2004 BSD

Check Out this Related Man Page

WATCHDOG(4)						   BSD Kernel Interfaces Manual 					       WATCHDOG(4)

NAME
watchdog -- hardware and software watchdog SYNOPSIS
#include <sys/watchdog.h> DESCRIPTION
The watchdog facility is used for controlling hardware and software watchdogs. /dev/fido responds to a single ioctl(2) call, WDIOCPATPAT. It takes a single argument which represents a timeout value specified as a power of two nanoseconds, or-ed with a flag selecting active or passive control of the watchdog. WD_ACTIVE indicates that the watchdog will be kept from timing out from userland, for instance by the watchdogd(8) daemon. WD_PASSIVE indi- cates that the watchdog will be kept from timing out from the kernel. The ioctl(2) call will return success if just one of the available watchdog(9) implementations supports setting the timeout to the specified timeout. This means that at least one watchdog is armed. If the call fails, for instance if none of watchdog(9) implementations support the timeout length, all watchdogs are disabled and must be explicitly re-enabled. To disable the watchdogs pass WD_TO_NEVER. If disarming the watchdog(s) failed an error is returned. The watchdog might still be armed! RETURN VALUES
The ioctl returns zero on success and non-zero on failure. [EOPNOTSUPP] No watchdog present in the kernel (timeout value other than 0). [EOPNOTSUPP] Watchdog could not be disabled (timeout value of 0). [EINVALID] Invalid flag combination passed. [EINVALID] None of the watchdogs supports the requested timeout value. EXAMPLES
#include <paths.h> #include <sys/watchdog.h> #define WDPATH "/dev/" _PATH_WATCHDOG int wdfd = -1; static void wd_init(void) { wdfd = open(WDPATH, O_RDWR); if (wdfd == -1) err(1, WDPATH); } static void wd_reset(u_int timeout) { if (ioctl(wdfd, WDIOCPATPAT, &timeout) == -1) err(1, "WDIOCPATPAT"); } /* in main() */ wd_init(); wd_reset(WD_ACTIVE|WD_TO_8SEC); /* potential freeze point */ wd_reset(WD_TO_NEVER); Enables a watchdog to recover from a potentially freezing piece of code. options SW_WATCHDOG in your kernel config adds a software watchdog in the kernel, dropping to KDB or panic-ing when firing. SEE ALSO
watchdogd(8), watchdog(9) HISTORY
The watchdog code first appeared in FreeBSD 5.1. BUGS
The WD_PASSIVE option has not yet been implemented. AUTHORS
The watchdog facility was written by Poul-Henning Kamp <phk@FreeBSD.org>. The software watchdog code and this manual page were written by Sean Kelly <smkelly@FreeBSD.org>. Some contributions were made by Jeff Roberson <jeff@FreeBSD.org>. BSD
June 25, 2003 BSD
Man Page