freebsd man page for vop_vptofh

Query: vop_vptofh

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_VPTOFH(9)						   BSD Kernel Developer's Manual					     VOP_VPTOFH(9)

NAME
VOP_VPTOFH -- turn a vnode into an NFS filehandle
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_VPTOFH(struct vnode *vp, struct fid *fhp);
DESCRIPTION
This is used by the NFS server to create an opaque filehandle which uniquely identifies the file and which can be used by an NFS client to access the file in the future. Its arguments are: vp The vnode to make a filehandle for. fhp Return parameter for the filehandle.
SEE ALSO
VFS(9), VFS_FHTOVP(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
February 16, 2007 BSD
Related Man Pages
vfs_vget(9) - debian
vrele(9) - debian
vfs(9) - freebsd
vfs_fhtovp(9) - opensolaris
vfs_fhtovp(9) - linux
Similar Topics in the Unix Linux Community
Unix File Permissions
Mac OS X: Based on UNIX - Solid As a Rock
The Whole Story on #! /usr/bin/ksh
A simple UNIXtime component in Vue.js
UNIX Environment Setup - (Just starting!)