freebsd man page for vop_revoke

Query: vop_revoke

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_REVOKE(9)						   BSD Kernel Developer's Manual					     VOP_REVOKE(9)

NAME
VOP_REVOKE -- revoke access to a device and its aliases
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_REVOKE(struct vnode *vp, int flags);
DESCRIPTION
VOP_REVOKE() will administratively revoke access to the device specified by vp, as well as any aliases created via make_dev_alias(9). Fur- ther file operations on any of these devices by processes which have them open will nominally fail. The flags must be set to REVOKEALL to signify that all access will be revoked; any other value is invalid.
LOCKS
The vp must be unlocked on entry, and will remain unlocked upon return.
SEE ALSO
make_dev_alias(9), vnode(9)
AUTHORS
This manual page was written by Brian Fundakowski Feldman.
BSD
February 5, 2002 BSD
Related Man Pages
vput(9) - debian
vrele(9) - debian
vunref(9) - freebsd
vput(9) - linux
vput(9) - centos
Similar Topics in the Unix Linux Community
Memory Leaks
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input