Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vop_allocate(9) [freebsd man page]

VOP_ALLOCATE(9) 					   BSD Kernel Developer's Manual					   VOP_ALLOCATE(9)

NAME
VOP_ALLOCATE -- allocate storage for a file SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_ALLOCATE(struct vnode *vp, off_t *offset, off_t *len); DESCRIPTION
This call allocates storage for a range of offsets in a file. It is used to implement the posix_fallocate system call. Its arguments are: vp The vnode of the file. offset The start of the range to allocate storage for in the file. len The length of the range to allocate storage for in the file. The offset and len arguments are updated to reflect the portion of the range that still needs to be allocated on return. A partial alloca- tion is considered a successful operation. The file's contents are not changed. LOCKS
The file should be exclusively locked on entry and will still be locked on exit. RETURN VALUES
Zero is returned if the call is successful, otherwise an appropriate error code is returned. ERRORS
[EFBIG] An attempt was made to write a file that exceeds the process's file size limit or the maximum file size. [ENOSPC] The file system is full. [EPERM] An append-only flag is set on the file, but the caller is attempting to write before the current end of file. SEE ALSO
vnode(9), VOP_READ(9), VOP_WRITE(9) BSD
October 3, 2013 BSD

Check Out this Related Man Page

VOP_RDWR(9)						   BSD Kernel Developer's Manual					       VOP_RDWR(9)

NAME
VOP_READ, VOP_WRITE -- read or write a file SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> #include <sys/uio.h> int VOP_READ(struct vnode *vp, struct uio *uio, int ioflag, struct ucred *cred); int VOP_WRITE(struct vnode *vp, struct uio *uio, int ioflag, struct ucred *cred); DESCRIPTION
These entry points read or write the contents of a file The arguments are: vp The vnode of the file. uio The location of the data to be read or written. ioflag Various flags. cnp The credentials of the caller. The ioflag argument is used to give directives and hints to the file system. When attempting a read, the high 16 bits are used to provide a read-ahead hint (in units of file system blocks) that the file system should attempt. The low 16 bits are a bit mask which can contain the following flags: IO_UNIT Do I/O as atomic unit. IO_APPEND Append write to end. IO_SYNC Do I/O synchronously. IO_NODELOCKED Underlying node already locked. IO_NDELAY FNDELAY flag set in file table. IO_VMIO Data already in VMIO space. LOCKS
The file should be locked on entry and will still be locked on exit. RETURN VALUES
Zero is returned on success, otherwise an error code is returned. ERRORS
[EFBIG] An attempt was made to write a file that exceeds the process's file size limit or the maximum file size. [ENOSPC] The file system is full. [EPERM] An append-only flag is set on the file, but the caller is attempting to write before the current end of file. SEE ALSO
uiomove(9), vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD
Man Page