Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vop_advise(9) [freebsd man page]

VOP_ADVISE(9)						   BSD Kernel Developer's Manual					     VOP_ADVISE(9)

NAME
VOP_ADVISE -- apply advice about use of file data SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_ADVISE(struct vnode *vp, off_t start, off_t end, int advice); DESCRIPTION
This call applies advice for a range of a file's data. It is used to implement the posix_fadvise system call. Its arguments are: vp The vnode of the file. start The start of the range of file data. end The end of the range of file data. advice The type of operation to apply to the file data. Possible values are: POSIX_FADV_WILLNEED Initiate an asynchronous read of the file data if it is not already resident. POSIX_FADV_DONTNEED Decrease the in-memory priority of clean file data or discard clean file data. If the start and end offsets are both zero, then the operation should be applied to the entire file. Note that this call is advisory only and may perform the requested operation on a subset of the requested range (including not performing it at all) and still return success. LOCKS
The file should be unlocked on entry. RETURN VALUES
Zero is returned if the call is successful, otherwise an appropriate error code is returned. ERRORS
[EINVAL] An invalid value was given for advice. SEE ALSO
vnode(9) BSD
October 3, 2013 BSD

Check Out this Related Man Page

POSIX_FADVISE(2)					      BSD System Calls Manual						  POSIX_FADVISE(2)

NAME
posix_fadvise -- give advice about use of file data LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <fcntl.h> int posix_fadvise(int fd, off_t offset, off_t len, int advice); DESCRIPTION
The posix_fadvise() system call allows a process to describe to the system its data access behavior for an open file descriptor fd. The advice covers the data starting at offset offset and continuing for len bytes. If len is zero, all data from offset to the end of the file is covered. The behavior is specified by the advice parameter and may be one of: POSIX_FADV_NORMAL Tells the system to revert to the default data access behavior. POSIX_FADV_RANDOM Is a hint that file data will be accessed randomly, and prefetching is likely not advantageous. POSIX_FADV_SEQUENTIAL Tells the system that file data will be accessed sequentially. This currently does nothing as the default behavior uses heuristics to detect sequential behavior. POSIX_FADV_WILLNEED Tells the system that the specified data will be accessed in the near future. The system may initiate an asynchronous read of the data if it is not already present in memory. POSIX_FADV_DONTNEED Tells the system that the specified data will not be accessed in the near future. The system may decrease the in-mem- ory priority of clean data within the specified range and future access to this data may require a read operation. POSIX_FADV_NOREUSE Tells the system that the specified data will only be accessed once and then not reused. The system may decrease the in-memory priority of data once it has been read or written. Future access to this data may require a read operation. RETURN VALUES
The posix_fadvise() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. ERRORS
The posix_fadvise() system call returns zero on success, and an error on failure: [EBADF] The fd argument is not a valid file descriptor. [EINVAL] The advice argument is not valid. [EINVAL] The offset or len arguments are negative, or offset + len is greater than the maximum file size. [ENODEV] The fd argument does not refer to a regular file. [ESPIPE] The fd argument is associated with a pipe or FIFO. SEE ALSO
madvise(2) STANDARDS
The posix_fadvise() interface conforms to IEEE Std 1003.1-2001 (``POSIX.1''). HISTORY
The posix_fadvise() system call first appeared in FreeBSD 9.1. BSD
January 30, 2014 BSD
Man Page