freebsd man page for vop_advise

Query: vop_advise

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_ADVISE(9)						   BSD Kernel Developer's Manual					     VOP_ADVISE(9)

NAME
VOP_ADVISE -- apply advice about use of file data
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_ADVISE(struct vnode *vp, off_t start, off_t end, int advice);
DESCRIPTION
This call applies advice for a range of a file's data. It is used to implement the posix_fadvise system call. Its arguments are: vp The vnode of the file. start The start of the range of file data. end The end of the range of file data. advice The type of operation to apply to the file data. Possible values are: POSIX_FADV_WILLNEED Initiate an asynchronous read of the file data if it is not already resident. POSIX_FADV_DONTNEED Decrease the in-memory priority of clean file data or discard clean file data. If the start and end offsets are both zero, then the operation should be applied to the entire file. Note that this call is advisory only and may perform the requested operation on a subset of the requested range (including not performing it at all) and still return success.
LOCKS
The file should be unlocked on entry.
RETURN VALUES
Zero is returned if the call is successful, otherwise an appropriate error code is returned.
ERRORS
[EINVAL] An invalid value was given for advice.
SEE ALSO
vnode(9)
BSD
October 3, 2013 BSD
Related Man Pages
arm_fadvise64_64(2) - linux
arm_fadvise(2) - linux
posix_fadvise(3c) - opensolaris
vput(9) - debian
fadvise64_64(2) - suse
Similar Topics in the Unix Linux Community
Need advice! Removing multiple entries in a single file!
Linux admin
System + Network Programming, your advice required???
Errors in if conditions with to many OR conditions
Hobbyist looking for AIX 5.3 licensing advice...