Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vm_map_stack(9) [freebsd man page]

VM_MAP_STACK(9) 					   BSD Kernel Developer's Manual					   VM_MAP_STACK(9)

NAME
vm_map_stack, vm_map_growstack -- manage process stacks SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> int vm_map_stack(vm_map_t map, vm_offset_t addrbos, vm_size_t max_ssize, vm_prot_t prot, vm_prot_t max, int cow); int vm_map_growstack(struct proc *p, vm_offset_t addr); DESCRIPTION
The vm_map_stack() function maps a process stack for a new process image. The stack is mapped addrbos in map, with a maximum size of max_ssize. Copy-on-write flags passed in cow are also applied to the new mapping. Protection bits are supplied by prot and max. It is typically called by execve(2). The vm_map_growstack() function is responsible for growing a stack for the process p to the desired address addr, similar to the legacy sbrk(2) call. IMPLEMENTATION NOTES
The vm_map_stack() function calls vm_map_insert(9) to create its mappings. The vm_map_stack() and vm_map_growstack() functions acquire the process lock on p for the duration of the call. RETURN VALUES
The vm_map_stack() function returns KERN_SUCCESS if the mapping was allocated successfully. Otherwise, if mapping the stack would exceed the process's VMEM resource limit, or if the specified bottom-of-stack address is out of range for the map, or if there is already a mapping at the address which would result, or if max_ssize could not be accommodated within the current mapping, KERN_NO_SPACE is returned. Other possible return values for this function are documented in vm_map_insert(9). The vm_map_growstack() function returns KERN_SUCCESS if addr is already mapped, or if the stack was grown successfully. It also returns KERN_SUCCESS if addr is outside the stack range; this is done in order to preserve compatibility with the deprecated grow() function previously located in the file vm_machdep.c. SEE ALSO
vm_map(9), vm_map_insert(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
January 11, 2013 BSD

Check Out this Related Man Page

VM_MAP_FIND(9)						   BSD Kernel Developer's Manual					    VM_MAP_FIND(9)

NAME
vm_map_find -- find a free region within a map, and optionally map a vm_object SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> int vm_map_find(vm_map_t map, vm_object_t object, vm_ooffset_t offset, vm_offset_t *addr, vm_size_t length, vm_offset_t max_addr, int find_space, vm_prot_t prot, vm_prot_t max, int cow); DESCRIPTION
The vm_map_find() function attempts to find a free region in the target map, with the given length. If a free region is found, vm_map_find() creates a mapping of object via a call to vm_map_insert(9). The arguments offset, prot, max, and cow are passed unchanged to vm_map_insert(9) when creating the mapping, if and only if a free region is found. If object is non-NULL, the reference count on the object must be incremented by the caller before calling this function to account for the new entry. If max_addr is non-zero, it specifies an upper bound on the mapping. The mapping will only succeed if a free region can be found that resides entirely below max_addr. The find_space argument specifies the strategy to use when searching for a free region of the requested length. For all values other than VMFS_NO_SPACE, vm_map_findspace(9) is called to locate a free region of the requested length with a starting address at or above *addr. The following strategies are supported: VMFS_NO_SPACE The mapping will only succeed if there is a free region of the requested length at the given address *addr. VMFS_ANY_SPACE The mapping will succeed as long as there is a free region. VMFS_SUPER_SPACE The mapping will succeed as long as there is a free region that begins on a superpage boundary. If object is non-NULL and is already backed by superpages, then the mapping will require a free region that aligns relative to the existing superpages rather than one beginning on a superpage boundary. VMFS_OPTIMAL_SPACE The mapping will succeed as long as there is a free region. However, if object is non-NULL and is already backed by superpages, this strategy will attempt to find a free region aligned relative to the existing superpages. VMFS_ALIGNED_SPACE(n) The mapping will succeed as long as there is a free region that aligns on a 2^n boundary. IMPLEMENTATION NOTES
This function acquires a lock on map by calling vm_map_lock(9), and holds it until the function returns. The search for a free region is defined to be first-fit, from the address addr onwards. RETURN VALUES
The vm_map_find() function returns KERN_SUCCESS if the mapping was successfully created. If space could not be found or find_space was VMFS_NO_SPACE and the given address, addr, was already mapped, KERN_NO_SPACE will be returned. If the discovered range turned out to be bogus, KERN_INVALID_ADDRESS will be returned. SEE ALSO
vm_map(9), vm_map_findspace(9), vm_map_insert(9), vm_map_lock(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
September 12, 2013 BSD
Man Page