freebsd man page for pseudofs

Query: pseudofs

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PSEUDOFS(9)						   BSD Kernel Developer's Manual					       PSEUDOFS(9)

NAME
pseudofs -- pseudo file system construction kit
SYNOPSIS
#include <fs/pseudofs/pseudofs.h>
DESCRIPTION
The pseudofs module offers an abstract API for pseudo-file systems such as procfs(5) and linprocfs(5). It takes care of all the hairy bits like interfacing with the VFS system, enforcing access control, keeping track of file numbers, and cloning files and directories that are process-specific. The consumer module, i.e., the module that implements the actual guts of the file system, needs only provide the directory structure (represented by a collection of structures declared and initialized by macros provided by pseudofs) and callbacks that report file attributes or write the actual file contents into sbufs.
SEE ALSO
linprocfs(5), linsysfs(5), procfs(5), sbuf(9), vnode(9)
HISTORY
The pseudofs module appeared in FreeBSD 5.0.
AUTHORS
The pseudofs module and this manual page were written by Dag-Erling Smorgrav <des@FreeBSD.org>.
BSD
April 20, 2007 BSD
Related Man Pages
ucycom(4) - debian
pseudofs(9) - debian
kld_load(3) - freebsd
openpam_get_option(3) - freebsd
ndisgen(8) - freebsd
Similar Topics in the Unix Linux Community
Problem with procfs.h file