LINSYSFS(5) BSD File Formats Manual LINSYSFS(5)NAME
linsysfs -- Linux system file system
linsys /compat/linux/sys linsysfs rw 0 0
The Linux system file system, or linsysfs, emulates a subset of the Linux sys file system and is required for the complete operation of some
The linsysfs provides a two-level view of devices. At the highest level, PCI devices themselves are named, according to their bus, slot and
function in the system hierarchy. PCI storage devices are listed in the scsi_host class with a device symlink to the PCI directories of the
Each device node is a directory containing some files and directories:
host A place holder for storage host information.
pci_id A directory for the pci_id that contains either the device information or another directory structure for a PCI bridge.
Each host node of scsi_host is a directory containing some files and directories:
proc_name The Linux registered driver name for these devices.
device A symlink to the PCI device directory.
/compat/linux/sys The normal mount point for linsysfs.
/compat/linux/sys/class/scsi_host The storage host node.
/compat/linux/sys/devices/pci0000:00 The PCI device hierarchy node.
The most common usage follows:
mount -t linsysfs linsys /compat/linux/sys
where /compat/linux/sys is a mount point.
SEE ALSO nmount(2), unmount(2), linprocfs(5), pseudofs(9)HISTORY
The linsysfs driver first appeared in FreeBSD 6.2.
The linsysfs driver was derived from linprocfs by Doug Ambrisko. This manual page was edited by Doug Ambrisko, based on the linprocfs(5)
manual page by Garrett Wollman.
BSD February 5, 2007 BSD
Check Out this Related Man Page
PSEUDOFS(9) BSD Kernel Developer's Manual PSEUDOFS(9)NAME
pseudofs -- pseudo file system construction kit
The pseudofs module offers an abstract API for pseudo-file systems such as procfs(5) and linprocfs(5). It takes care of all the hairy bits
like interfacing with the VFS system, enforcing access control, keeping track of file numbers, and cloning files and directories that are
process-specific. The consumer module, i.e., the module that implements the actual guts of the file system, needs only provide the directory
structure (represented by a collection of structures declared and initialized by macros provided by pseudofs) and callbacks that report file
attributes or write the actual file contents into sbufs.
SEE ALSO linprocfs(5), linsysfs(5), procfs(5), sbuf(9), vnode(9)HISTORY
The pseudofs module appeared in FreeBSD 5.0.
The pseudofs module and this manual page were written by Dag-Erling Smorgrav <des@FreeBSD.org>.
BSD April 20, 2007 BSD
Atm i have Windows 98. Can i install a Unix system like Redhat on my computer, and on boot choose which one to go to? Like i can with Win95 & 98...
Please help me. I dont know alot about unix so im still learning. I just know its better than Win for the internet and it doesnt crash.
:) (14 Replies)
Suppose I have thousand files in one directory and they can keep increasing ie
Then I want to create a batch of 100 files and then compress that batch file and ftp them somewhere else. And morever the files in the batch will be moved to somewhere else.
Can you please help... (21 Replies)
Sorry for sounding like an incredible n00b, but as I have been lurking and searching on the net, I have come across something that may be common sense to most, but to me is confusing. I constantly see the word GNU when I do searches for Linux, both on this web site and on search engines. I found... (18 Replies)
I'm quite interested in resusing an old bondi iMac i have as a unix box, and i was wondering what distro people would recomend.
I had thought of using BSD/FreeBSD cos thats what osx is based on. I'm doing this as a teaching excercise (for myself) so i'm looking for something achievable rather than... (9 Replies)
Hi,I am need setup mail system on the linux, but i am don't know , My linux system is Redhat Linux 9.0.However,What's kind mail system is fit my operation system? expect everyone give directionsme with superior . Thanks! (6 Replies)
How does one know that he/she has the skills and enough knowledge of Unix to start applying for unix sys admin jobs? I am learning by telneting into a free bsd system. Will this prepare me for a solaris job? (13 Replies)
Ok, here's the thing... I have a computer that has both Fedora Core 3 Linux and Windows XP Pro. I have it so the MBR loads in the Windows style (black screen with a 30 second pause to choose either Fedora Core or Windows) Now if I select Fedora Core, it starts its own OS selector (I believe it's... (11 Replies)
My class "UNIX using Linux" started today. The software that came with my text book will not download. I am running XP pro .. When I load the "guide to UNIX using Linux" disk the only thing that comes up is E:/ showing some files that are on the disk and then it stops and does nothing. Can anyone... (13 Replies)
i'm dummy for unix but i want to learn something.
i want to search the working directory and its subdirectories( all ) to find the files which are more than 1024 bytes.
So which commands must i learn?
Thanks to all. (13 Replies)
I have some files in my Linux machine that are very old and occupy a HUGe amount of space. I am trying to delete these files from the system so that it will be easy for me to add some files. I would like to know if this can done through a Perl or a shell script.
What i want to do is i... (6 Replies)
I am working on a linux install to a desktop pc and will configure this onto our main server once happy with the functions etc.
I am actually a HP and AIX sys admin and was looking for the best ways to:
create a bootable file that can be copied to dvd-rw / cd-rw or to dds
be able to... (8 Replies)
Calling all Linux GURU's.
The purpose of this thread is to try an recreate what we already have stood up in my environment, however the steps i am having to produce my own.
I have got multiple applications that dump the data to various LUNs, the LUNs are managed by an Enterprise SAN... (11 Replies)
I am using win7 on my PC and installed VMware on it on which i am running linux
I am unable to ping my linux guest from my win machine,
but i can ping my windows host from linux guest :
Below is my system configuration
root@localhost ~]# ifconfig
eth0 Link... (9 Replies)