VERSION.4TH(8) BSD System Manager's Manual VERSION.4TH(8)
version.4th -- FreeBSD version string boot module
The file that goes by the name of version.4th is a set of commands designed to draw the boot loader version at the bottom-right of the
screen. The commands of version.4th by themselves are not enough for most uses. Please refer to the examples below for the most common sit-
uations, and to loader(8) for additional commands.
Before using any of the commands provided in version.4th, it must be included through the command:
This line is present in the default /boot/menu.rc file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
print_version Prints the contents of the loader_version environment variable right-justified at the column loader_version_x
and row loader_version_y.
The environment variables that effect its behavior are:
Set automatically by loader(8), but you can override it by setting in loader.conf(5). This should be the version of boot
Sets the desired ending column position of loader_version. Default is 80.
Sets the desired ending row position of loader_version. Default is 24.
If set to ``NO'' (case-insensitive) or ``0'', causes the version to be printed without color (default is ANSI Cyan).
/boot/loader The loader(8).
/boot/version.4th version.4th itself.
/boot/loader.rc loader(8) bootstrapping script.
Override loader(8) version in loader.conf(5):
loader.conf(5), color.4th(8), loader(8)
The version.4th set of commands first appeared in FreeBSD 9.0.
The version.4th set of commands was written by Devin Teske <dteske@FreeBSD.org>.
August 6, 2013 BSD