SYNC(8) BSD System Manager's Manual SYNC(8)NAME
sync -- force completion of pending disk writes (flush cache)
The sync utility can be called to ensure that all disk writes have been completed before the processor is halted in a way not suitably done
by reboot(8) or halt(8). Generally, it is preferable to use reboot(8) or halt(8) to shut down the system, as they may perform additional
actions such as resynchronizing the hardware clock and flushing internal caches before performing a final sync.
The sync utility utilizes the sync(2) function call.
SEE ALSO fsync(2), sync(2), syncer(4), halt(8), reboot(8)HISTORY
A sync utility appeared in Version 4 AT&T UNIX.
BSD May 31, 1993 BSD
Check Out this Related Man Page
SYNC(8) System Manager's Manual SYNC(8)NAME
sync - synchronize data on disk with memory
sync [--help] [--version]
sync writes any data buffered in memory out to disk. This can include (but is not limited to) modified superblocks, modified inodes, and
delayed reads and writes. This must be implemented by the kernel; The sync program does nothing but exercise the sync(2) system call.
The kernel keeps data in memory to avoid doing (relatively slow) disk reads and writes. This improves performance, but if the computer
crashes, data may be lost or the filesystem corrupted as a result. sync ensures that everything in memory is written to disk.
sync should be called before the processor is halted in an unusual manner (e.g., before causing a kernel panic when debugging new kernel
code). In general, the processor should be halted using the shutdown(8) or reboot(8) or halt(8) commands, which will attempt to put the
system in a quiescent state before calling sync(2). (Various implementations of these commands exist; consult your documentation; on some
systems one should not call reboot(8) and halt(8) directly.)
GNU STANDARD OPTIONS --help Print a usage message on standard output and exit successfully.
Print version information on standard output, then exit successfully.
-- Terminate option list.
The variables LANG, LC_ALL, LC_CTYPE, and LC_MESSAGES have the usual meaning.
On Linux, sync is only guaranteed to schedule the dirty blocks for writing; it can actually take a short time before all the blocks are
finally written. The reboot(8) and halt(8) commands take this into account by sleeping for a few seconds after calling sync(2).
This page describes sync as found in the fileutils-4.0 package; other versions may differ slightly. Mail corrections and additions to
email@example.com. Report bugs in the program to firstname.lastname@example.org.
SEE ALSO sync(2), halt(8), reboot(8), update(8)GNU fileutils 4.0 1998-11 SYNC(8)
I have a directory called sync and the directory path is ftp/exports/sync. What I would like to do is place some documents in sync for external users to view and would like to have access restriction for the sync directory. i.e. login and password. How do I go about doing this in a Unix enviorment.... (3 Replies)
Can anyone could tell me what is the meaning of this problem:
Last successful check resync is greater than min sync interval (1195785433 > 7200)
And what can do to solve this problem.
Thank you..Please HElp me! (4 Replies)
I need to sync 2 remote folders so i setup with rsync which is working very fine. But, there comes another requirement to maintain multiple versions of files on destination (NOT to overwrite the destination file).
If there is difference between source file and destination file, it must... (2 Replies)
I am trying to observe system behavior on our RHEL 5.2 machines. I notice that, it appears to me, based on random iterations of
dd if=/dev/zero of=/var/tmp/bigfile bs=1024 count=20000
...that if the pdflush is flushing buffers at the time of my write, my write will take... (4 Replies)
Could someone please help me.
Users were unable to access SCO Server. Attempted to reboot the machine and following error was reported:
UX: vxfs mount: ERROR: /dev/dsk/c1b0t3d0s1 is corrupted, needs checking
UX: vxfs mount: ERROR: /dev/dsk/c1b0t3d0s2 is corrupted, needs checking
... (4 Replies)
I want to remove a directory recursively except the inside directories calles .SYNC (designsync dirs) I am looking for something like:
\rm -rf < find . * | grep -v .SYNC
The find works ok but I do not know how to redirect it.
Ziv (3 Replies)
want to sync. two servers , both are having solaris os.
If am updating any thing in one server , it will automatically sync. with the other server .
Is it possible , if so den how ? (3 Replies)
I have constant trouble with XCOPY/s for multi-gigabyte transfers.
I need a utility like XCOPY/S that remembers where it left off if I reboot. Is there such a utility? How about a free utility (free as in free beer)?
How about an md5sum sanity check too?
I posted the above query in another... (3 Replies)
I wanted to know which should be the best way to sync time for a linux machine. We have an application server and a database server, both using RHEL 5.8 as the OS. It is important that the time on both these servers match together and also sync with a common time source. As per my knowledge, these... (11 Replies)
I would like to achieve below requirement,
I have a directory "/mydir" and I want to automatically sync/copy all the content of /mydir directory to "/yourdir" directory all the time.
meaning, if some application creates a file in /mydir, it supposed to be copied/available in "/yourdir"... (4 Replies)
I deployed the rhel7 server in the bare metal hardware. I want to configure the rhel7 server to sync time with bios. I tired the below commands. Still it did not sync the time with bios.
Kalai (3 Replies)
Part of our security audit we found that following system account's had shells configured;
I believe this can be achieved by following commands:
chsh -s /sbin/nologin (user)
usermod -s /sbin/nologin (user)
However, I would like simple script to... (5 Replies)