Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pmcannotate(8) [freebsd man page]

PMCANNOTATE(8)						    BSD System Manager's Manual 					    PMCANNOTATE(8)

NAME
pmcannotate -- sources printout with inlined profiling SYNOPSIS
pmcannotate [-a] [-h] [-k pathname] [-l level] pmcout.out binaryobj DESCRIPTION
The pmcannotate utility can produce both C sources or assembly sources of a program with a line-by-line based profiling. The profiling information is retrieved through a pmcstat(8) raw output while the program operations are retrieved through the objdump(1) tool. When calling pmcannotate the raw output is passed through the pmcout.out argument, while the program is passed through the binaryobj argu- ment. As long as pmcannotate relies on objdump(1) and pmcstat(8) to work, it will fail if one of them is not available. OPTIONS
The following options are available: -a Shows the program profiling inlined in the assembly code only. No C information involving C sources is provided. -h Prints out information about the usage of the tool. -l level Changes the lower bound (expressed in percentage) for traced functions that will be printed out in the report. The default value is 0.5%. -k kerneldir Set the pathname of the kernel directory to argument kerneldir. This directory specifies where pmcannotate should look for the ker- nel and its modules. The default is /boot/kernel. LIMITATIONS
As long as pmcannotate relies on the objdump(1) utility to retrieve the C code, the program needs to be compiled with debugging options. Sometimes, in particular with heavy optimization levels, the objdump(1) utility embeds the code of inlining functions directly in the call- ers, making an output difficult to read. The x86 version reports the sampling from pmcstat collecting the following instruction in regard of the interrupted one. This means that the samples may be attributed to the line below the one of interest. SEE ALSO
objdump(1), pmcstat(8) AUTHORS
Attilio Rao <attilio@FreeBSD.org> BSD
November 20, 2008 BSD

Check Out this Related Man Page

PROFIL(2)						      BSD System Calls Manual							 PROFIL(2)

NAME
profil -- control process profiling LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <unistd.h> int profil(char *samples, size_t size, vm_offset_t offset, int scale); DESCRIPTION
The profil() system call enables or disables program counter profiling of the current process. If profiling is enabled, then at every pro- filing clock tick, the kernel updates an appropriate count in the samples buffer. The frequency of the profiling clock is recorded in the header in the profiling output file. The buffer samples contains size bytes and is divided into a series of 16-bit bins. Each bin counts the number of times the program counter was in a particular address range in the process when a profiling clock tick occurred while profiling was enabled. For a given program counter address, the number of the corresponding bin is given by the relation: [(pc - offset) / 2] * scale / 65536 The offset argument is the lowest address at which the kernel takes program counter samples. The scale argument ranges from 1 to 65536 and can be used to change the span of the bins. A scale of 65536 maps each bin to 2 bytes of address range; a scale of 32768 gives 4 bytes, 16384 gives 8 bytes and so on. Intermediate values provide approximate intermediate ranges. A scale value of 0 disables profiling. RETURN VALUES
The profil() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. FILES
/usr/lib/gcrt0.o profiling C run-time startup file gmon.out conventional name for profiling output file ERRORS
The following error may be reported: [EFAULT] The buffer samples contains an invalid address. SEE ALSO
gprof(1) HISTORY
The profil() function appeared in Version 7 AT&T UNIX. BUGS
This routine should be named profile(). The samples argument should really be a vector of type unsigned short. The format of the gmon.out file is undocumented. BSD
June 4, 1993 BSD
Man Page