DELAY.4TH(8) BSD System Manager's Manual DELAY.4TH(8)NAME
delay.4th -- FreeBSD debugging boot module
The file that goes by the name of delay.4th is a set of commands designed to add debugging capabilities to loader(8). The commands of
delay.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8)
for additional commands.
Before using any of the commands provided in delay.4th, it must be included through the command:
This line is present in /boot/beastie.4th file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
delay_execute Executes the [string] procedure stored in the delay_command environment variable after loader_delay seconds.
If the optional delay_showdots environment variable is set, a continuous series of dots is printed.
During the duration, the user can either press Ctrl-C (or Esc) to abort or ENTER to proceed immediately.
The environment variables that effect its behavior are:
The command to be executed by delay_execute.
The duration (in seconds) to delay before executing delay_command.
If set, will cause delay_execute to print a continuous series of dots during the delay duration.
/boot/loader The loader(8).
/boot/delay.4th delay.4th itself.
/boot/loader.rc loader(8) bootstrapping script.
Introducing a 5-second delay before including another file from /boot/loader.rc:
set delay_command="include /boot/other.4th"
SEE ALSO loader.conf(5), beastie.4th(8), loader(8), loader.4th(8)HISTORY
The delay.4th set of commands first appeared in FreeBSD 9.0.
The delay.4th set of commands was written by Devin Teske <dteske@FreeBSD.org>.
BSD May 18, 2011 BSD
Check Out this Related Man Page
LOADER.CONF(5) BSD File Formats Manual LOADER.CONF(5)NAME
loader.conf -- system bootstrap configuration information
The file loader.conf contains descriptive information on bootstrapping the system. Through it you can specify the kernel to be booted,
parameters to be passed to it, and additional modules to be loaded; and generally set all variables described in loader(8).
The file /boot/loader.rc must contain the following two lines for loader.conf to be automatically processed:
If no /boot/loader.rc exists at installworld time, one with the above lines will be installed.
Though loader.conf's format was defined explicitly to resemble rc.conf(5), and can be sourced by sh(1), some settings are treated in a spe-
cial fashion. Also, the behavior of some settings is defined by the setting's suffix; the prefix identifies which module the setting con-
The general parsing rules are:
o Spaces and empty lines are ignored.
o A # sign will mark the remainder of the line as a comment.
o Only one setting can be present on each line.
All settings have the following format:
Unless it belongs to one of the classes of settings that receive special treatment, a setting will set the value of a loader(8) environment
variable. The settings that receive special treatment are listed below. Settings beginning with "*" below define the modules to be loaded
and may have any prefix; the prefix identifies a module. All such settings sharing a common prefix refer to the same module.
exec Immediately executes a loader(8) command. This type of setting cannot be processed by programs other than loader(8), so its
use should be avoided. Multiple instances of it will be processed independently.
Defines additional configuration files to be processed right after the present file.
kernel Name of the kernel to be loaded. If no kernel name is set, no additional modules will be loaded. The name must be a subdirec-
tory of /boot that contains a kernel.
Flags to be passed to the kernel.
password Protect boot menu with a password without interrupting autoboot process. The password should be in clear text format. If a
password is set, boot menu will not appear until any key is pressed during countdown period specified by autoboot_delay vari-
able or autoboot process fails. In both cases user should provide specified password to be able to access boot menu.
Provides a password to be required by check-password before execution is allowed to continue. The password should be in clear
text format. If a password is set, the user must provide specified password to boot.
If set to ``YES'', module names will be displayed as they are loaded.
*_load If set to ``YES'', that module will be loaded. If no name is defined (see below), the module's name is taken to be the same as
*_name Defines the name of the module.
*_type Defines the module's type. If none is given, it defaults to a kld module.
*_flags Flags and parameters to be passed to the module.
*_before Commands to be executed before the module is loaded. Use of this setting should be avoided.
*_after Commands to be executed after the module is loaded. Use of this setting should be avoided.
*_error Commands to be executed if the loading of a module fails. Except for the special value ``abort'', which aborts the bootstrap
process, use of this setting should be avoided.
WARNING: developers should never use these suffixes for any kernel environment variables (tunables) or conflicts will result.
Most of loader.conf's default settings can be ignored. The few of them which are important or useful are:
(``NO'') If set to ``YES'', a bitmap will be loaded to be displayed on screen while booting.
(``/boot/splash.bmp'') Name of the bitmap to be loaded. Any other name can be used.
(``9600'' or the value of the BOOT_COMCONSOLE_SPEED variable when loader(8) was compiled). Sets the speed of the serial con-
sole. If the previous boot loader stage specified that a serial console is in use then the default speed is determined from
the current serial port speed setting.
console (``vidconsole'') ``comconsole'' selects serial console, ``vidconsole'' selects the video console, ``nullconsole'' selects a
mute console (useful for systems with neither a video console nor a serial port), and ``spinconsole'' selects the video con-
sole which prevents any input and hides all output replacing it with ``spinning'' character (useful for embedded products and
kernels (``kernel kernel.old'') Space or comma separated list of kernels to present in the boot menu.
(``NO'') If set to ``YES'', will load the splash screen module, making it possible to display a bmp image on the screen while
(``NO'') If set to ``YES'', will load the splash screen module, making it possible to display a pcx image on the screen while
(``NO'') If set to ``YES'', the vesa module will be loaded, enabling bitmaps above VGA resolution to be displayed.
If set to ``YES'', the beastie boot menu will be skipped. The beastie boot menu is always skipped if booting UEFI or running
Selects a desired logo in the beastie boot menu. Possible values are: ``orbbw'', ``orb'', ``fbsdbw'', ``beastiebw'',
``beastie'', and ``none''.
If set to ``NO'', the beastie boot menu will be displayed without ANSI coloring.
/boot/defaults/loader.conf default settings -- do not change this file.
/boot/loader.4th defines the commands used by loader to read and process loader.conf.
/boot/loader.conf user defined settings.
/boot/loader.conf.local machine-specific settings for sites with a common loader.conf.
/boot/loader.rc contains the instructions to automatically process loader.conf.
SEE ALSO boot(8), loader(8), loader.4th(8)HISTORY
The file loader.conf first appeared in FreeBSD 3.2.
This manual page was written by Daniel C. Sobral <dcs@FreeBSD.org>.
The loader(8) stops reading loader.conf when it encounters a syntax error, so any options which are vital for booting a particular system
(i.e. ``hw.ata.ata_dma=0'') should precede any experimental additions to loader.conf.
BSD April 27, 2014 BSD