MAKEWHATIS.LOCAL(8) BSD System Manager's Manual MAKEWHATIS.LOCAL(8)NAME
makewhatis.local, catman.local -- start makewhatis or catman for local file systems
/usr/libexec/makewhatis.local [options] directories ...
/usr/libexec/catman.local [options] directories ...
The makewhatis.local utility starts makewhatis(1) only for file systems physically mounted on the system where the makewhatis.local is being
executed. Running makewhatis by periodic weekly for rw nfs-mounted /usr may kill your NFS server -- all NFS clients start makewhatis at the
same time! So use this wrapper for cron(8) instead of calling makewhatis directly. The catman.local utility is using for same purposes as
makewhatis.local but for catman(1).
/etc/periodic/weekly/320.whatis run makewhatis.local every week
/etc/periodic/weekly/330.catman run catman.local every week
SEE ALSO catman(1), find(1), makewhatis(1), cron(8), periodic(8)HISTORY
The makewhatis.local utility appeared in FreeBSD 2.2.
BSD April 26, 1996 BSD
Check Out this Related Man Page
CATMAN(1) BSD General Commands Manual CATMAN(1)NAME
catman -- preformat man pages
catman [-fLnrv] [directories ...]
The catman utility preformats all the man pages in directories using the nroff -man command. Directories may be separated by colons instead
of spaces. If no directories are specified, the contents of the MANPATH environment variable is used, or if that is not set, the default
directory /usr/share/man is processed.
The options are as follows:
-f Force all man pages to be reformatted even if the corresponding cat page is newer.
-L Process only localized subdirectories corresponding to the locale specified in the standard environment variables.
-n Print out what would be done instead of performing any formatting.
-r Scan for and remove ``junk'' files that are neither man pages nor their corresponding formatted cat pages.
-v Cause catman to be more verbose about what it is doing.
LC_ALL, LC_CTYPE, LANG
These variables control what subdirectories will be processed if the -L option is used.
MACHINE If set, overrides the current machine type when searching for machine specific man page subdirectories.
If set, overrides the current architecture when searching for architecture specific man page subdirectories.
MANPATH Determines the set of directories to be processed if none are given on the command line.
/usr/share/man Default directory to process if the MANPATH environment variable is not set.
The catman utility exits 0 on success, and >0 if an error occurs.
SEE ALSO makewhatis(1), man(1), nroff(1)HISTORY
A previous version of the catman command appeared in FreeBSD 2.1.
BSD December 3, 2005 BSD
Hi everybody! I'm new to this forums, and am a university student (Computer Engineering) from México.
In my new Unix school subject, we need to deliver a weekly report, that includes a complement section in which we have to write about UNIX news and up-to-date info on UNIX.
So this is the... (1 Reply)
I need help:
I need to process number of flat files on weekly basis. My source dir will receive flat files regulary at mid night
between 1:00am and 6:00am. When I run my weekly file process it should get only the files which are until last friday
(including friday)and move them in... (1 Reply)
Is there a way in AIX to schedule a script to run bi-weekly through cron?
I have a script that needs to run every other Wednesday, and this is what I thought I had to enter in the crontab file:
00 08 * * 3/2 /home/user/user.script
It didn't like that. It reports a syntax error. I'm almost... (5 Replies)
I am trying to use find within an if statement.
Problem is, even though my find returns nothing, the RC is 0 and continues.
Intent - check the log of a weekly job for successful completion. If complete, carry on. If not, tell me and exit. Suggestions?
I have tried the following:
if find... (6 Replies)
I have problem in writing the UNIX scripts,I have one SAP server and my local server .I want to take one file from SAP server to my local server weekly bases I want to write one UNIX scripts which will automatically takes that file from SAP server to my server.so I need not need to pull the... (1 Reply)
I am due to start receiving a weekly csv containing around 6 million rows. I need to do some processing on this file and then send it on elsewhere.
My problem is that after week 1 the files that I will receive are likely to contain data already received in previous files and I need... (8 Replies)
I have a list of directories looking something like;
Is there a way I can filter the out and archive directories so I... (5 Replies)
Is it possible to get all the files modified in the last week (Not before or after that week) . I have tried with date range it works for me for the period of seven days , not exactly for weekly basis .
Fetching records for seven day by
find -mtime +6 -a -mtime -13As today date is 3rd... (5 Replies)
I have a months worth of data that I need to separate into weekly files. There is a date column with dates in the following format: YYYYMMDD.
I'm thinking I can create the weekly files by using a grep command combined with an IF command and specify each day of the specific week I'm... (1 Reply)
Since a few weeks I am playing with debian and now I have 2 questions.
The first one:
I want to create weekly a file to all user directories.
I know that you have a cronjob to schedule it weekly. In this cronjob I have written the following line:
df >> /home/%users/diskspace.txt
I've... (1 Reply)
I've got two separate logrotates I'd like to run, one for Tomcat and one for Apache, but I'd like to run the Tomcat one daily and the Apache one weekly. Now, the logrotate itself is working fine, but although I have 'daily' in Tomcat, and 'weekly' in the Apache one, the latter is... (2 Replies)
This is my first post, so bear with me.
I have this script, vpm, which make use of the libexec directory for commands intended to be run by the bin/vpm binary. I want to add the libexec directory to $PATH when running the vpm binary. I don't want the script itself to try figure... (2 Replies)
Was working on Vue.js and stumbled upon this beautiful Vue project by Kadin Zhang
Periodicity is a dynamic periodic table built with Vue.js that animates and graphs data to aid the visualization of chemical concepts.
The code is available on GitHub (2 Replies)