Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddb(8) [freebsd man page]

DDB(8)							    BSD System Manager's Manual 						    DDB(8)

NAME
ddb -- configure DDB kernel debugger properties SYNOPSIS
ddb capture [-M -core] [-N -system] print ddb capture [-M -core] [-N -system] status ddb script scriptname ddb script scriptname=script ddb scripts ddb unscript scriptname ddb pathname DESCRIPTION
The ddb utility configures certain aspects of the ddb(4) kernel debugger from user space that are not configured at compile-time or easily via sysctl(8) MIB entries. To ease configuration, commands can be put in a file which is processed using ddb as shown in the last synopsis line. An absolute pathname must be used. The file will be read line by line and applied as arguments to the ddb utility. Whitespace at the beginning of lines will be ignored as will lines where the first non-whitespace character is '#'. OUTPUT CAPTURE
The ddb utility can be used to extract the contents of the ddb(4) output capture buffer of the current live kernel, or from the crash dump of a kernel on disk. The following debugger commands are available from the command line: capture [-M core] [-N system] print Print the current contents of the ddb(4) output capture buffer. capture [-M core] [-N system] status Print the current status of the ddb(4) output capture buffer. SCRIPTING
The ddb utility can be used to configure aspects of ddb(4) scripting from user space; scripting support is described in more detail in ddb(4). Each of the debugger commands is available from the command line: script scriptname Print the script named scriptname. script scriptname=script Define a script named scriptname. As many scripts contain characters interpreted in special ways by the shell, it is advisable to enclose script in quotes. scripts List currently defined scripts. unscript scriptname Delete the script named scriptname. EXIT STATUS
The ddb utility exits 0 on success, and >0 if an error occurs. EXAMPLES
The following example defines a script that will execute when the kernel debugger is entered as a result of a break signal: ddb script kdb.enter.break="show pcpu; bt" The following example will delete the script: ddb unscript kdb.enter.break For further examples, see the ddb(4) and textdump(4) manual pages. SEE ALSO
ddb(4), textdump(4), sysctl(8) HISTORY
The ddb utility first appeared in FreeBSD 7.1. AUTHORS
Robert N M Watson BUGS
Ideally, ddb would not exist, as all pertinent aspects of ddb(4) could be configured directly via sysctl(8). BSD
December 24, 2008 BSD

Check Out this Related Man Page

TEXTDUMP(4)						   BSD Kernel Interfaces Manual 					       TEXTDUMP(4)

NAME
textdump -- textdump kernel dumping facility SYNOPSIS
options KDB options DDB DESCRIPTION
The textdump facility allows the capture of kernel debugging information to disk in a human-readable rather than the machine-readable form normally used with kernel memory dumps and minidumps. This representation, while less complete in that it does not capture full kernel state, can provide debugging information in a more compact, portable, and persistent form than a traditional dump. By combining textdump with other ddb(4) facilities, such as scripting and output capture, detailed bug information can be captured in a fully automated manner. FORMAT
textdump data is stored in a dump partition in the same style as a regular memory dump, and will be automatically extracted by savecore(8) if present on boot. textdump files are stored in the tar(5) format, and consist of one or more text files, each storing a particular type of debugging output. The following parts may be present: ddb.txt Captured ddb(4) output, if the capture facility has been used. May be disabled by clearing the debug.ddb.textdump.do_ddb sysctl. config.txt Kernel configuration, if has been compiled into the kernel. May be disabled by clearing the debug.ddb.textdump.do_config sysctl. msgbuf.txt Kernel message buffer, including recent console output if the capture facility has been used. May be disabled by clearing the debug.ddb.textdump.do_msgbuf sysctl. panic.txt Kernel panic string, if the kernel panicked before the dump was generated. May be disabled by clearing the debug.ddb.textdump.do_panic sysctl. version.txt Kernel version string. My be disabled by clearing the debug.ddb.textdump.do_version sysctl. Kernel textdumps may be extracted using tar(1). CONFIGURATION
The textdump facility is enabled as part of the kernel debugger using options KDB and options DDB. By default, kernel dumps generated on panic or via explicit requests for a dump will be regular memory dumps; however, by using the textdump set command in ddb(4), or by setting the debug.ddb.textdump.pending sysctl to 1 using sysctl(8), it is possible to request that the next dump be a textdump. If at the ddb(4) command line, the commands textdump set, textdump status, and textdump unset may be used to set, query, and clear the textdump pending flag. As with regular kernel dumps, a dump partition must be automatically or manually configured using dumpon(8). EXAMPLES
In the following example, the script kdb.enter.panic will run when the kernel debugger is entered as a result of a panic, enable output cap- ture, dump several useful pieces of debugging information, and then invoke panic in order to force a kernel dump to be written out followed by a reboot: script kdb.enter.panic=textdump set; capture on; show allpcpu; bt; ps; alltrace; show alllock; call doadump; reset In the following example, the script kdb.enter.witness will run when the kernel debugger is entered as a result of a witness violation, printing lock-related information for the user: script kdb.enter.witness=show locks These scripts may also be configured using the ddb(8) utility. SEE ALSO
tar(1), ddb(4), tar(5), ddb(8), dumpon(8), savecore(8), sysctl(8) HISTORY
The textdump facility first appeared in FreeBSD 7.1. AUTHORS
The textdump facility was created by Robert N. M. Watson. BSD
December 24, 2008 BSD
Man Page