NOLOGIN(5) BSD File Formats Manual NOLOGIN(5)NAME
nologin -- disallow logins
Programs such as login(1) disallow logins if the nologin file exists. The programs display the contents of nologin to the user if possible
and interrupt the login sequence. This makes it simple to temporarily prevent incoming logins systemwide.
To disable logins on a per-account basis, investigate nologin(8).
The nologin file is ignored for user root by default.
The nologin feature is implemented through login.conf(5), which allows to change the pathname of the file and to extend the list of users
exempt from temporary login restriction.
PAM-aware programs can be selectively configured to respect nologin using the pam_nologin(8) module via pam.conf(5).
The nologin file will be removed at system boot if it resides in /var/run and cleanvar_enable is set to ``YES'' in rc.conf(5), which is
default. Therefore system reboot can effectively re-enable logins.
/var/run/nologin default location of nologin
SEE ALSO login(1), login.conf(5), pam.conf(5), rc.conf(5), nologin(8), pam_nologin(8), shutdown(8)BSD May 10, 2007 BSD
Check Out this Related Man Page
PAM_NOLOGIN(8) BSD System Manager's Manual PAM_NOLOGIN(8)NAME
pam_nologin -- NoLogin PAM module
[service-name] module-type control-flag pam_nologin [options]
The NoLogin service module for PAM, pam_nologin provides functionality for only one PAM category: account management. In terms of the
module-type parameter, this is the ``account'' feature.
NoLogin Account Management Module
The NoLogin account management component, pam_sm_acct_mgmt(), verifies whether logins are administratively disabled via nologin(5). It
returns success if the user's login class has an "ignorenologin" capability specified in login.conf(5) or the nologin(5) file does not exist.
If neither condition is met, then the contents of nologin(5) are echoed before failure is returned. The location of nologin(5) is specified
by a "nologin" capability in login.conf(5), which defaults to /var/run/nologin.
The following options may be passed to the module:
debug syslog(3) debugging information at LOG_DEBUG level.
no_warn suppress warning messages to the user. These messages include reasons why the user's login attempt was declined.
SEE ALSO syslog(3), login.conf(5), nologin(5), pam.conf(5), pam(8)BSD June 10, 2007 BSD
I am looking for an alternative. I am not wanting to try and run it using one of those fancy programs that can run windows programs. I am trying to cut the chord from MS so I am looking for good similar programs.
If there are none, then I guess I try to run it under Linux. ... (6 Replies)
I notice in my Sun Solaris 8 sparc workstatin, I am able to login concurrently using a same user ID.
Is there a way to disallow this? That is, at anyone time, the user can have only 1 login session.
How can it be done?
Thanks (10 Replies)
is the nologin shell available in AIX 5.2? I am familiar with the nologin shell in linux and restricting shell access but still allowing ftp etc. Can this be done in AIX? I have not been able to locate any documentation. Thanks in advance (5 Replies)
I have a list of people in a usage log and need to print the names and phone numbers of people with over 500 logins. I'd also like to display these names alphabetically.
I have their total logins set to a variable named total.
So far, I have very little in my awk script to do this:
FS=":"... (4 Replies)
I have to limit the root logins on my aix box (aix 5.3)
I change the value on the /etc/security/user
default (login and rlogin) change to false
and add to root (rlogin and login = false)
I tried in different ways but I got the same.
Root still can login
I try algo... (6 Replies)
I want to apply patches in multiuser mode but stop logins of other users while I do it?
What is the best way to do this?
I will be connected to the system via a putty session over a serial cable from another system (console is messed up)...
Should I put in a dummy passwd and shadow file... (7 Replies)
I am using Red Hat Enterprise Linux ES release 4 (Nahant Update 5). Here I have created one user with /sbin/nologin shll such that login is not possible only ftp is possible. But I want to do another thing that the user can not roam around after ftp.
I had tried one way.
in... (4 Replies)
cannot login to a HP unix server using root as well as other logins.
Even root also cannot enter. It seems that they have changed some permissions in /
Any way of recovering the system or getting logged in .
Thanks in advance
Rj (8 Replies)
Hopefully my question makes sense, but I was wondering if the telnet service has anything to do with console logins or if they are completely unrelated. So for example, does the /etc/default/login file in UNIX have anything to do with Telnet? So if I want to verify that the root user can't login... (8 Replies)
how can I disable direct login to a Solaris system not only for root user but also for other accounts?
Looking in google I came to the following:
For telnet (/etc/default/login):
disable root access> CONSOLE=/dev/console
disable generic user> ?
For ssh... (5 Replies)
I tried to modify the /etc/security/limits.conf file to limit the root user for more one login. I added the line in limits.conf file like:
@root hard maxlogins 1
I also tried to modify /etc/ssh/sshd_config to limit the root userlogin by adding this:
... (10 Replies)
Ok got a strange one here. None of my user accounts are able to login into the system. When trying to ssh to the server i get the following.
Could not chdir to home directory /home/<homedir>: Permission denied
/bin/sh: Permission denied
I checked the permissions on the home directory and even... (7 Replies)
Yes, it's that minefield again. I'm building an AJAX database interface which uses maria/mysql logins instead of keeping a bunch of its own private logins, to try and keep it simple.
The thorny bit is, of course, the passwords. Doing this requires it to remember passwords between sessions, not... (4 Replies)