NOLOGIN(8) BSD System Manager's Manual NOLOGIN(8)NAME
nologin -- politely refuse a login
The nologin utility displays a message that an account is not available and exits non-zero. It is intended as a replacement shell field for
accounts that have been disabled.
To disable all logins, investigate nologin(5).
SEE ALSO login(1), nologin(5)HISTORY
The nologin utility appeared in 4.4BSD.
BSD June 19, 1993 BSD
Check Out this Related Man Page
PAM_NOLOGIN(8) BSD System Manager's Manual PAM_NOLOGIN(8)NAME
pam_nologin -- NoLogin PAM module
[service-name] module-type control-flag pam_nologin [options]
The NoLogin authentication service module for PAM provides functionality for only one PAM category: authentication. In terms of the
module-type parameter, this is the ``auth'' feature. It also provides a null function for session management.
NoLogin Authentication Module
The NoLogin authentication component (pam_sm_authenticate()), always returns success for the superuser, and returns success for all other
users if the file /etc/nologin does not exist. If /etc/nologin does exist, then its contents are echoed to non-superusers before failure is
returned. If a "nologin" capability is specified in login.conf(5), then the file thus specified is used instead. This usually defaults to
The following options may be passed to the authentication module:
debug syslog(3) debugging information at LOG_DEBUG level.
no_warn suppress warning messages to the user. These messages include reasons why the user's authentication attempt was declined.
SEE ALSO syslog(3), login.conf(5), pam.conf(5), nologin(8), pam(8)BSD July 8, 2001 BSD
I'm setting up a Solaris 10 box to run Lawson application, which needs users to have Unix acounts, but the users will not be using interactive shell. To make it more secure, I'd rather not give them a valid shell. I know there's a trick by putting /noshell in the /etc/passwd file, but the problem... (2 Replies)
is the nologin shell available in AIX 5.2? I am familiar with the nologin shell in linux and restricting shell access but still allowing ftp etc. Can this be done in AIX? I have not been able to locate any documentation. Thanks in advance (5 Replies)
Need one clarification..
If suppose, I have disabled the login to a particular user XXX, but not deleted the user.
So the scripts which must be executed using the user XXX can still be executed using that user or is it not possible..?
In our tasks, we are disabling the user XXX, and after... (1 Reply)
Is it possible to SSH with an account that has its shell set to /sbin/nologin?
The reason I ask is because I am running an instance of nagios where I need to use SSH keys to run a check, but I am getting connect errors in Nagios. Also, what is the risk I run into if I just simply change my... (2 Replies)
Trying to figure out the best method of security for oracle user accounts. In Solaris 10 they are set as regular users but have nologin set forcing the dev's to login as themselves and then su to the oracle users.
In Solaris11 we have the option of making it a role because RBAC is enabled but... (1 Reply)
Part of our security audit we found that following system account's had shells configured;
I believe this can be achieved by following commands:
chsh -s /sbin/nologin (user)
usermod -s /sbin/nologin (user)
However, I would like simple script to... (5 Replies)