MAN.CONF(5) BSD File Formats Manual MAN.CONF(5)NAME
man.conf --man(1) and manpath(1) configuration files
The man.conf file is used to configure the manual search path, locales, and utility set for man(1) and its related utilities. During ini-
tialization, man(1) reads the configuration files located at /usr/local/etc/man.d/*.conf and /etc/man.conf.
The files contained in /usr/local/etc/man.d/*.conf are intended to be used by the ports(7) system for extending the manual set to support
additional paths and locales. /etc/man.conf is intended to be used by the local administrator to set additional policy.
Currently supported configuration variables include:
MANCONFIG Overrides the default location to import additional manual configuration files. Defaults to /usr/local/etc/man.d/*.conf.
MANPATH Adds the specified directory to the manual search path.
MANLOCALE Indicates support is available for the given locale.
For pages in a given language, overriding the default toolset for display is supported via the following definitions:
See the EXAMPLES section for how to use these variables.
The parser used for this utility is very basic and only supports comment characters (#) at the beginning of a line.
/etc/man.conf System configuration file.
/usr/local/etc/man.d/*.conf Local configuration files.
A perl port that needs to install additional manual pages outside of the default location could install a file in
/usr/local/etc/man.d/perl.conf with the following contents:
# Add perl man pages to search path
A Japanese localization port could install a custom toolset and include a file in /usr/local/etc/man.d/ja-man-doc.conf with the following
# Setup Japanese toolset
NROFF_JA /usr/local/bin/groff -man -dlang=ja_JP.eucJP
TROFF_JA /usr/local/bin/groff -man -dlang=ja_JP.euc.jp
If the system administrator decides to override the LOCALBASE make(1) variable causing all ports(7) to be installed into /opt instead of
/usr/local, specifying the following in /etc/man.conf will accommodate this change:
# Look for additional configuration files
SEE ALSO apropos(1), man(1), manpath(1), whatis(1)BSD June 3, 2011 BSD
Check Out this Related Man Page
MAN(1) General Commands Manual MAN(1)NAME
man - print out the manual
man [ - ] [ -a ] [ -M path ] [ section ] title ...
Man is the program which provides on-line access to the UNIX manual. If a section specifier is given, man looks in that section of the
manual for the given title(s). Section is either an Arabic section number (``3'' for example), or one of the words ``local'', ``new,'' or
``old''. (The abbreviations ``l'', ``n'', and ``o'' are also allowed.) If section is omitted, man searches all sections of the manual,
giving preference to commands over library subroutines, and displays the first manual page it finds, if any. If the -a option is supplied,
man displays all applicable manual pages.
Normally man checks in standard locations (/usr/man and /usr/local/man) for manual information. This can be changed by supplying a search
path (a la the Bourne shell) with the -M flag. The search path is a colon (``:'') separated list of directories in which man expects to
find the standard manual subdirectories. This search path can also be set with the environmental variable MANPATH.
Since some manual pages are intended for use only on certain machines, man only searches those directories applicable to the current
machine. Man's determination of the current machine type can be overridden by setting the environmental variable MACHINE.
If the standard output is a teletype, and the - flag is not provided, man uses more(1), or the pager provided by the environmental variable
PAGER, to display the manual page.
The FORTRAN version of section 3 of the manual may be specified by supplying man with the section ``3f''. Also, a specific section of the
local manual may be specified by appending a number to the section, i.e. ``l5'' would indicate section 5 of the local manual.
/usr/man standard manual area
/usr/man/cat?/* directories containing standard manual pages
/usr/local/man/cat?/* directories containing local manual pages
/usr/src/man directories containing unformatted manual pages
SEE ALSO apropos(1), more(1), whatis(1), whereis(1)BUGS
The manual is supposed to be reproducible either on the phototypesetter or on a typewriter, however, on a typewriter, some information is
4th Berkeley Distribution April 19, 1988 MAN(1)