HCSECD.CONF(5) BSD File Formats Manual HCSECD.CONF(5)NAME
hcsecd.conf --hcsecd(8) configuration file
DESCRIPTION
The hcsecd.conf file is the configuration file for the hcsecd(8) Bluetooth link keys/PIN codes management daemon.
The hcsecd.conf file is a free-form ASCII text file. It is parsed by the recursive-descent parser built into hcsecd(8). The file may con-
tain extra tabs and newlines for formatting purposes. Keywords in the file are case-sensitive. Comments may be placed anywhere within the
file (except within quotes). Comments begin with the '#' character and end at the end of the line.
FILE FORMAT
The hcsecd.conf file consists of a list of device entries. Each device entry defines a link key or PIN code for a remote Bluetooth device.
Each remote Bluetooth device is identified by its unique BD_ADDR.
The device entry
device { option argument; [option argument;] }
The following section describes all supported options and arguments.
bdaddr BD_ADDR
Specify remote device BD_ADDR for the entry.
name device_name
Specify user friendly name for the entry. Name is a string in straight double quotes.
key link_key
Specify link key for the entry. Link key is hexadecimal string up to 32 characters in length starting with '0x'.
key nokey
Specify no link key for the entry.
pin PIN_code
Specify PIN code for the entry. PIN code is a string up to 16 characters in length in straight double quotes.
pin nopin
Specify no PIN code for the entry.
EXAMPLES
A sample hcsecd.conf file:
# Default entry is applied if no better match found
# It MUST have 00:00:00:00:00:00 as bdaddr
device {
bdaddr 00:00:00:00:00:00;
name "Default entry";
key nokey;
pin nopin;
}
# Ericsson T68 phone
device {
bdaddr 00:80:37:5e:4d:d4;
name "Ericsson T68 phone";
key nokey;
pin "0000"; # PIN code
}
# Dummy device
device {
bdaddr 00:11:22:33:44:55;
name "Dummy";
key 0x00112233445566778899aabbccddeeff; # 16 bytes key
pin nopin;
}
SEE ALSO hcsecd(8)AUTHORS
Maksim Yevmenkin <m_evmenkin@yahoo.com>
BSD May 26, 2003 BSD
Check Out this Related Man Page
WESTCOS-TOOL(1) OpenSC Tools WESTCOS-TOOL(1)NAME
westcos-tool - utility for manipulating data structures on westcos smart cards
SYNOPSIS
westcos-tool [OPTIONS]
DESCRIPTION
The westcos-tool utility is used to manipulate the westcos data structures on 2 Ko smart cards / tokens. Users can create PINs, keys and
certificates stored on the card / token. User PIN authentication is performed for those operations that require it.
OPTIONS --change-pin, -n
Changes a PIN stored on the card. User authentication is required for this operation.
--certificate file, -t file
Write certificate file file in PEM format to the card. User authentication is required for this operation.
--finalize, -f
Finalize the card. Once finalized the default key is invalidated, so PIN and PUK cannot be changed anymore without user authentication.
Warning, un-finalized are insecure because PIN can be changed without user authentication (knowledge of default key is enough).
--generate-key, -g
Generate a private key on the card. The card must not have been finalized and a PIN must be installed (ie. the file for ithe PIN must
havei been created, see option -i). By default the key length is 1536 bits. User authentication is required for this operation.
--help, -h
Print help message on screen.
--install-pin, -i
Install PIN file in on the card. You must provide a PIN value with -x.
--key-length length, -l length
Change the length of private key. Use with -g.
--overwrite-key, -o
Overwrite the key if there is already a key on the card.
--pin-value value, -x value
Set value of PIN.
--puk-value value, -y value
set value of PUK (or value of new PIN for change PIN command see -n).
--read-file path, -j path
Read the file path from the card. The file is written on disk with name path. User authentication is required for this operation.
--reader num, -r num
Use the given reader. The default is the first reader with a card.
--unblock-pin, -u
Unblocks a PIN stored on the card. Knowledge of the PIN Unblock Key (PUK) is required for this operation.
-v
Causes westcos-tool to be more verbose. Specify this flag several times to enable debug output in the OpenSC library.
--wait, -w
Wait for a card to be inserted.
--write-file path, -k path
Put the file with name path from disk to card. On the card the file is written in path. User authentication is required for this
operation.
AUTHORS
westcos-tool was written by Francois Leblanc <francois.leblanc@cev-sa.com>.
opensc 06/17/2014 WESTCOS-TOOL(1)