Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

smb(4) [freebsd man page]

SMB(4)							   BSD Kernel Interfaces Manual 						    SMB(4)

NAME
smb -- SMB generic I/O device driver SYNOPSIS
device smb DESCRIPTION
The smb character device driver provides generic i/o to any smbus(4) instance. In order to control SMB devices, use /dev/smb? with the ioctls described below. Any of these ioctl commands takes a pointer to struct smbcmd as its argument. #include <sys/types.h> struct smbcmd { char cmd; int count; u_char slave; union { char byte; short word; char *byte_ptr; short *word_ptr; struct { short sdata; short *rdata; } process; } data; }; The slave field is always used, and provides the address of the SMBus slave device to talk to. The slave address is specified in the seven most significant bits (i.e. ``left-justified''). The least significant bit of the slave address must be zero. Ioctl Description SMB_QUICK_WRITE The QuickWrite command just issues the device address with write intent to the bus, without transferring any data. SMB_QUICK_READ The QuickRead command just issues the device address with read intent to the bus, without transferring any data. SMB_SENDB The SendByte command sends the byte provided in the cmd field to the device. SMB_RECVB The ReceiveByte command reads a single byte from the device which will be returned in the cmd field. SMB_WRITEB The WriteByte command first sends the byte from the cmd field to the device, followed by the byte given in data.byte. SMB_WRITEW The WriteWord command first sends the byte from the cmd field to the device, followed by the word given in data.word. Note that the SMBus byte-order is little-endian by definition. SMB_READB The ReadByte command first sends the byte from the cmd field to the device, and then reads one byte of data from the device. The returned data will be stored in the location pointed to by data.byte_ptr. SMB_READW The ReadWord command first sends the byte from the cmd field to the device, and then reads one word of data from the device. The returned data will be stored in the location pointed to by data.word_ptr. SMB_PCALL The ProcedureCall command first sends the byte from the cmd field to the device, followed by the word provided in data.process.sdata. It then reads one word of data from the device, and returns it in the location pointed to by data.process.rdata. SMB_BWRITE The BlockWrite command first sends the byte from the cmd field to the device, followed by count bytes of data that are taken from the buffer pointed to by data.byte_ptr. The SMBus specification mandates that no more than 32 bytes of data can be transferred in a single block read or write command. This value is available in the constant SMB_MAXBLOCKSIZE. SMB_BREAD The BlockRead command first sends the byte from the cmd field to the device, and then reads count bytes of data that from the device. These data will be returned in the buffer pointed to by data.byte_ptr. The read(2) and write(2) system calls are not implemented by this driver. ERRORS
The ioctl(2) commands can cause the following driver-specific errors: [ENXIO] Device did not respond to selection. [EBUSY] Device still in use. [ENODEV] Operation not supported by device (not supposed to happen). [EINVAL] General argument error. [EWOULDBLOCK] SMBus transaction timed out. SEE ALSO
ioctl(2), smbus(4) HISTORY
The smb manual page first appeared in FreeBSD 3.0. AUTHORS
This manual page was written by Nicolas Souchu. BSD
February 6, 2009 BSD

Check Out this Related Man Page

IIC(4)							   BSD Kernel Interfaces Manual 						    IIC(4)

NAME
iic -- I2C generic I/O device driver SYNOPSIS
device iic #include <dev/iicbus/iic.h> DESCRIPTION
The iic device driver provides generic I/O to any iicbus(4) instance. In order to control I2C devices, use /dev/iic? with the following ioctls: I2CSTART (struct iiccmd) Sends the start condition to the slave specified by the slave element to the bus. The slave element consists of a 7-bit address and a read/write bit (i.e., 7-bit address << 1 | r/w). If the read/write bit is set a read operation is initi- ated, if the read/write bit is cleared a write operation is initiated. All other elements are ignored. I2CRPTSTART (struct iiccmd) Sends the repeated start condition to the slave specified by the slave element to the bus. The slave address should be specified as in I2CSTART. All other elements are ignored. I2CSTOP No argument is passed. Sends the stop condition to the bus. This terminates the current transaction. I2CRSTCARD (struct iiccmd) Resets the bus. The argument is completely ignored. I2CWRITE (struct iiccmd) Writes data to the iicbus(4). The bus should already be started. The slave element is ignored. The count ele- ment is the number of bytes to write. The last element is a boolean flag. It is non-zero when additional write commands will follow. The buf element is a pointer to the data to write to the bus. I2CREAD (struct iiccmd) Reads data from the iicbus(4). The bus should already be started. The slave element is ignored. The count element is the number of bytes to write. The last element is a boolean flag. It is non-zero when additional write commands will follow. The buf element is a pointer to where to store the data read from the bus. Short reads on the bus produce unde- fined results. I2CRDWR (struct iic_rdwr_data) Generic read/write interface. Allows for an arbitrary number of commands to be sent to an arbitrary num- ber of devices on the bus. A read transfer is specified if IIC_M_RD is set in flags. Otherwise the transfer is a write trans- fer. The slave element specifies the 7-bit address with the read/write bit for the transfer. The read/write bit will be han- dled by the iicbus stack based on the specified transfer operation. The len element is the number of (struct iic_msg) messages encoded on (struct iic_rdwr_data). The buf element is a buffer for that data. This ioctl is intended to be Linux compatible. The following data structures are defined in <dev/iicbus/iic.h> and referenced above: struct iiccmd { u_char slave; int count; int last; char *buf; }; /* Designed to be compatible with linux's struct i2c_msg */ struct iic_msg { uint16_t slave; uint16_t flags; #define IIC_M_RD 0x0001 /* read vs write */ uint16_t len; /* msg length */ uint8_t * buf; }; struct iic_rdwr_data { struct iic_msg *msgs; uint32_t nmsgs; }; It is also possible to use read/write routines, then I2C start/stop handshake is managed by the iicbus(4) system. However, the address used for the read/write routines is the one passed to last I2CSTART ioctl(2) to this device. SEE ALSO
ioctl(2), read(2), write(2), iicbus(4) HISTORY
The iic manual page first appeared in FreeBSD 3.0. AUTHORS
This manual page was written by Nicolas Souchu and M. Warner Losh. BUGS
Only the I2CRDWR ioctl(2) is thread safe. All other interfaces suffer from some kind of race. BSD
June 24, 2014 BSD
Man Page