ZYD(4) BSD Kernel Interfaces Manual ZYD(4)
zyd -- ZyDAS ZD1211/ZD1211B USB IEEE 802.11b/g wireless network device
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The zyd driver provides support for wireless network adapters based around the ZyDAS ZD1211 and ZD1211B USB chips.
zyd supports station and monitor mode operation. Only one virtual interface may be configured at any time. For more information on config-
uring this device, see ifconfig(8).
The following devices are known to be supported by the zyd driver:
Airlink 101 AWLL3026
AOpen 802.11g WL54
Asus A9T integrated wireless
Belkin F5D7050 v.4000
Billion BiPAC 3011G
DrayTek Vigor 550
Fiberline Networks WL-43OU
MyTek MWU-201 USB adapter
Sagem XG 760A
Sagem XG 76NA
Sandberg Wireless G54 USB
Sweex wireless USB 54 Mbps
Tekram/Siemens USB adapter
Trendnet TEW-424UB rev A
US Robotics 5423
Yakumo QuickWLAN USB
ZyXEL ZyAIR G-202
ZyXEL ZyAIR G-220
The following example configures zyd0 to join any BSS network using WEP key ``0x1deadbeef1'', channel 11:
ifconfig wlan create wlandev zyd0 channel 11
wepmode on wepkey 0x1deadbeef1 weptxkey 1
inet 192.168.1.1 netmask 255.255.255.0
Join an existing BSS network, ``my_net'':
ifconfig wlan create wlandev zyd0 192.168.0.2
netmask 0xffffff00 ssid my_net
zyd%d: could not load firmware (error=%d) An error occurred while attempting to upload the firmware to the onboard microcontroller unit.
zyd%d: could not send command (error=%s) An attempt to send a command to the firmware failed.
zyd%d: sorry, radio %s is not supported yet Support for the specified radio chip is not yet implemented in the driver. The device will not
zyd%d: device version mismatch: 0x%x (only >= 43.30 supported) Early revisions of the ZD1211 chipset are not supported by this driver. The
device will not attach.
zyd%d: device timeout A frame dispatched to the hardware for transmission did not complete in time. The driver will reset the hardware.
This should not happen.
intro(4), netintro(4), usb(4), wlan(4), wlan_amrr(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
The original zyd driver was written by Florian Stoehr <firstname.lastname@example.org>, Damien Bergamini <email@example.com>, and Jonathan Gray
The zyd driver does not support a lot of the functionality available in the hardware. More work is required to properly support the IBSS and
power management features.
March 7, 2013 BSD