Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

targ(4) [freebsd man page]

TARG(4) 						   BSD Kernel Interfaces Manual 						   TARG(4)

NAME
targ -- SCSI target emulator driver SYNOPSIS
To compile this driver into the kernel, place the following line in your kernel configuration file: device targ DESCRIPTION
The targ driver provides an interface for usermode programs to emulate SCSI target devices. A sample program that emulates a disk drive (similar to da(4)) can be found in /usr/share/examples/scsi_target. The targ driver supplies the control device /dev/targ. After opening the device, the file descriptor must be bound to a specific bus/tar- get/LUN and enabled to process CCBs using the TARGIOCENABLE ioctl. The process then uses write(2) to send CCBs to the SIM and poll(2) or kqueue(2) to see if responses are ready. Pointers to completed CCBs are returned via read(2). Any data transfers requested by the user CCBs are done via zero-copy IO. IOCTLS
The following ioctl(2) calls are defined in the header file <cam/scsi/scsi_targetio.h>. TARGIOCENABLE (struct ioc_enable_lun) Enable target mode on the LUN specified by the following structure: struct ioc_enable_lun { path_id_t path_id; target_id_t target_id; lun_id_t lun_id; int grp6_len; int grp7_len; }; The selected path (bus), target, and LUN must not already be in use or EADDRINUSE is returned. If grp6_len or grp7_len are non-zero, reception of vendor-specific commands is enabled. TARGIOCDISABLE Disable target mode and abort all pending CCBs. The CCBs may optionally be read as they complete. TARGIOCENABLE can then be called to activate a different LUN. Multiple disable calls have no effect. The close(2) system call automatically disables target mode if enabled. TARGIOCDEBUG (int) Enables CAM_PERIPH debugging if the argument is non-zero, otherwise disables it. FILES
<cam/scsi/scsi_targetio.h> describes the usermode interface. /sys/cam/scsi/scsi_target.c is the driver source file. /dev/targ is the control device. SEE ALSO
/usr/share/examples/scsi_target, ahc(4), isp(4), scsi(4) FreeBSD Target Information, http://www.root.org/~nate/freebsd/. AUTHORS
The targ driver first appeared in FreeBSD 3.0 and was written by Justin T. Gibbs. It was rewritten for FreeBSD 5.0 by Nate Lawson <nate@root.org>. BUGS
Currently, only the ahc(4) and isp(4) drivers fully support target mode. The ahc(4) driver does not support tagged queuing in target mode. BSD
December 13, 2011 BSD

Check Out this Related Man Page

PASS(4) 						   BSD Kernel Interfaces Manual 						   PASS(4)

NAME
pass -- CAM application passthrough driver SYNOPSIS
device pass DESCRIPTION
The pass driver provides a way for userland applications to issue CAM CCBs to the kernel. Since the pass driver allows direct access to the CAM subsystem, system administrators should exercise caution when granting access to this driver. If used improperly, this driver can allow userland applications to crash a machine or cause data loss. The pass driver attaches to every SCSI device found in the system. Since it attaches to every device, it provides a generic means of access- ing SCSI devices, and allows the user to access devices which have no "standard" peripheral driver associated with them. KERNEL CONFIGURATION
It is only necessary to configure one pass device in the kernel; pass devices are automatically allocated as SCSI devices are found. IOCTLS
CAMIOCOMMAND This ioctl takes most kinds of CAM CCBs and passes them through to the CAM transport layer for action. Note that some CCB types are not allowed through the passthrough device, and must be sent through the xpt(4) device instead. Some examples of xpt-only CCBs are XPT_SCAN_BUS, XPT_DEV_MATCH, XPT_RESET_BUS, XPT_SCAN_LUN, XPT_ENG_INQ, and XPT_ENG_EXEC. These CCB types have various attributes that make it illogical or impossible to service them through the passthrough interface. CAMGETPASSTHRU This ioctl takes an XPT_GDEVLIST CCB, and returns the passthrough device corresponding to the device in question. Although this ioctl is available through the pass driver, it is of limited use, since the caller must already know that the device in question is a passthrough device if they are issuing this ioctl. It is probably more useful to issue this ioctl through the xpt(4) device. FILES
/dev/passn Character device nodes for the pass driver. There should be one of these for each device accessed through the CAM subsystem. DIAGNOSTICS
None. SEE ALSO
cam(3), cam_cdbparse(3), cam(4), xpt(4), camcontrol(8) HISTORY
The CAM passthrough driver first appeared in FreeBSD 3.0. AUTHORS
Kenneth Merry <ken@FreeBSD.org> BUGS
It might be nice to have a way to asynchronously send CCBs through the passthrough driver. This would probably require some sort of read/write interface or an asynchronous ioctl interface. BSD
October 10, 1998 BSD
Man Page