SIMPLEBUS(4) BSD Kernel Interfaces Manual SIMPLEBUS(4)
simplebus -- ePAPR simple-bus driver
This bus driver is dedicated for the simple-bus node of a flattened device tree compliant with the ePAPR specification.
The simplebus entity does not represent any physical element by itself, it is rather an umbrella node grouping integrated on-chip peripherals
like interrupt controller, connectivity controllers, accelerating engines and so on.
The driver is generic and common for all flattened device tree nodes claiming simple-bus compatibility. It iterates over direct descendants
of the simple-bus node, instantiates newbus children and assigns resources to them, based on the configuration data retrieved from the nodes
properties in fdt(4).
Note the simplebus does not manage device resources and passes through any requests to the fdtbus(4) layer.
fdt(4), fdtbus(4), openfirm(4)
Power.org Standard for Embedded Power Architecture Platform Requirements (ePAPR).
The simplebus support first appeared in FreeBSD 9.0.
The simplebus support was developed by Semihalf under sponsorship from the FreeBSD Foundation. This manual page was written by Rafal
July 12, 2010 BSD