SWAPON(8) System Manager's Manual SWAPON(8)NAME
swapon - specify additional device for paging and swapping
SYNOPSIS
swapon -a
swapon name ...
DESCRIPTION
Swapon is used to specify additional devices on which paging and swapping are to take place. The system begins by swapping and paging on
only a single device so that only one disk is required at bootstrap time. Calls to swapon normally occur in the system multi-user initial-
ization file /etc/rc making all swap devices available, so that the paging and swapping activity is interleaved across several devices.
Normally, the -a argument is given, causing all devices marked as ``sw'' swap devices in /etc/fstab to be made available.
The second form gives individual block devices as given in the system swap configuration table. The call makes only this space available
to the system for swap allocation.
SEE ALSO swapon(2), init(8)FILES
/dev/[ru][pk]?b normal paging devices
BUGS
There is no way to stop paging and swapping on a device. It is therefore not possible to make use of devices which may be dismounted dur-
ing system operation.
swapon is not implemented in 2.11BSD.
4th Berkeley Distribution November 17, 1996 SWAPON(8)
Check Out this Related Man Page
SWAPON(2) BSD System Calls Manual SWAPON(2)NAME
swapon, swapoff -- control devices for interleaved paging/swapping
LIBRARY
Standard C Library (libc, -lc)
SYNOPSIS
#include <unistd.h>
int
swapon(const char *special);
int
swapoff(const char *special);
DESCRIPTION
The swapon() system call makes the block device special available to the system for allocation for paging and swapping. The names of poten-
tially available devices are known to the system and defined at system configuration time. The size of the swap area on special is calcu-
lated at the time the device is first made available for swapping.
The swapoff() system call disables paging and swapping on the given device. All associated swap metadata are deallocated, and the device is
made available for other purposes.
RETURN VALUES
If an error has occurred, a value of -1 is returned and errno is set to indicate the error.
ERRORS
Both swapon() and swapoff() can fail if:
[ENOTDIR] A component of the path prefix is not a directory.
[ENAMETOOLONG] A component of a pathname exceeded 255 characters, or an entire path name exceeded 1023 characters.
[ENOENT] The named device does not exist.
[EACCES] Search permission is denied for a component of the path prefix.
[ELOOP] Too many symbolic links were encountered in translating the pathname.
[EPERM] The caller is not the super-user.
[EFAULT] The special argument points outside the process's allocated address space.
Additionally, swapon() can fail for the following reasons:
[EINVAL] The system has reached the boot-time limit on the number of swap devices, vm.nswapdev.
[ENOTBLK] The special argument is not a block device.
[EBUSY] The device specified by special has already been made available for swapping
[ENXIO] The major device number of special is out of range (this indicates no device driver exists for the associated hardware).
[EIO] An I/O error occurred while opening the swap device.
Lastly, swapoff() can fail if:
[EINVAL] The system is not currently swapping to special.
[ENOMEM] Not enough virtual memory is available to safely disable paging and swapping to the given device.
SEE ALSO config(8), swapon(8), sysctl(8)HISTORY
The swapon() system call appeared in 4.0BSD. The swapoff() system call appeared in FreeBSD 5.0.
BSD June 4, 1993 BSD
Hi all!
Working on Oracle v8i/9i on Unix Sun Solaris v8.0.
I am experiencing excessive paging & Swapping.Would like to know the cause.
I guess:could be due to inappropriate setting of Unix Kernel Parameters...
Please correct me if I am wrong!
Thanks&Regards,
Amit. (5 Replies)
We are trying to tune a server which phsycially is maxed out on cpu.
We are maxing out on memory and swapping at a rate of 20-43% of our swap space which is approx 45% of total ram.
We "can" upgrade to twice the memory that we currently have but it will be costly as there are no more seats... (5 Replies)
Hi,
Trying to add a swap file to my server as below:
dd if=/dev/zero of=/swapfile1 bs=1M count=2048
2048+0 records in
2048+0 records out
2147483648 bytes (2.1 GB) copied, 27.4514 seconds, 78.2 MB/s
# mkswap -c /swapfile1
Setting up swapspace version 1, size = 2147479 kB
# swapon... (6 Replies)
Hi,
I have paging size 2048M showed from topas and 10240M showed from "lsps -a", can anyone tell what is the difference? and how to change the PAGING SIZE (showed in topas) to 8192M?
Can you please tell in detail step?
Thanks!
Victor
#topas
Topas Monitor for host: egsprc01dev ... (10 Replies)
hello all,
I'm newbie on AIX. Can any one tell why this happen ? I have expectation this error came because paging memory.
This is my error : ( I cann;t read this log and need your help)
---------------------------------------------------------------------------
LABEL: ... (7 Replies)
Hello people
i see that our system is paging and paging space usage grows, a the same time i see that usage of Comp memory grows and Client memory decreases.
# lsps -s
Total Paging Space Percent Used
65792MB 33%
MEMORY
Real,MB 81920
% Comp 69
% Noncomp 30... (14 Replies)
Hi Everyone,
I have some misunderstanding about swapping.
Is it true that swap
a) required always (I mean I cannot set size 0 bytes)
and
b) some pages are saved on disk in idle time even free memory is enough
?
Could you please advise some good reading about it? (10 Replies)
Hi!
Im trying to swap 2 columns in a file.The file format is:
'ColumnA','ColumnB'
'A1','A2'
'B1','B2'
'C1','C2'
I tried to solve this using AWK, when I run this command:
awk 'BEGIN {FS=OFS=","} {temp=$1; $1=$2; $2=temp} {print}' InFile.csv >> Outfile.csv
What I get is this:
... (5 Replies)
I was hoping to test a bug posted by oracle, which indicates that the system may crash when using a zfs volume as a swap device. We moved swap away from zfs and over to raw disk devices in order to stop the crashes we've been experiencing.
What I wanted to do was to re-create the crash in a... (8 Replies)
Hello
On one of our systems (AIX 5) I am seeing (vmstat) paging intermittently
I want to know which process is causing the paging?
I understand that first I would need to find out which process is consuming most memory
1) Is that right?
2) How to find it out?
3) By googling I found... (8 Replies)
Hi All,
I have some questions regarding the performance, MEMORY/ Virtual Memory (paging /swap space)
Please see the nmon-MEMORY stats from my AIX LPAR.
24 GB --> RAM
3456 MB --> Paging Space
│ Memory ───────────────────────────────────────────────────────────────────────
│... (8 Replies)
Can anyone help me the detailed procedure and commands to follow to add additional swap on aix server .
My system shows following as of now ,
#lsattr -E -l sys0 -a realmem
realmem 13893632 Amount of usable physical memory in Kbytes False
#pstat -s
PAGE SPACE:
USED PAGES FREE... (7 Replies)
Hi all,
This might sound silly but i am trying to determine if i have sufficient memory or not.
My definition of sufficient memory = no swapping + no paging to physical swap file.
I know i can use vmstat to monitor swapping and paging and using the SR column as well.
But wouldn't it be... (28 Replies)
I have an old p5 570 ibm server that consists of two enclosure and make by FC1847 cable, single 8 processors server.
So, after one part of it, accidentally was turned off, I lost all devices from it.
Now they all in defined mode, for example:
dodo:/# lsdev -Cc processor
proc0 Available 00-00... (8 Replies)