NEWFS(8) System Manager's Manual NEWFS(8)NAME
newfs - construct a new file system
SYNOPSIS
/sbin/newfs [ -N ] [ -m free-gap ] [ -n free-modulus ] [ -i bytes ] [ -s size ] [ -T disk-type ] special
DESCRIPTION
Newfs is a ``friendly'' front-end to the mkfs(8) program. Newfs(8) will normally read the disklabel from the drive to determine the parti-
tion sizes. If the driver for the disk does not support disklabels the -T option must be used to force a search of /etc/disktab for parti-
tion information about drive-type. Newfs calculates the appropriate parameters to use in calling mkfs, then builds the file system by
forking mkfs.
-N causes the mkfs command which would be executed to be printed out without actually creating the file system. The disk specified by spe-
cial must be online though so that newfs can read the disklabel.
-m allows the specification of the block interleaving of the free list. If not specified or outside the range 1 thru 32 then a value of 2
is used.
-n parameter is the freelist modulus (when the -m pattern repeats) and is calculated by newfs to be 1 cylinder in size by default.
-i specifies how many bytes per inode to assume when calculating how many inodes to allocate. The default is 4096 bytes per inode. If
this results in too few inodes being allocated (there is an absolute maximum of 65500) then decrease the bytes number (which must lie
between 512 and 65536).
-T must be used if the disk specified by special has not been labeled with the disklabel(8) program. In this case disk-type is used by
getdisklabel(3) when searching /etc/disktab. This option is used when the underlying device driver does not support disklabels. Care must
be taken that the contents of /etc/disktab match the partition tables in the kernel.
-s specifies how many sectors the file system is to contain. There are two sectors per file system block, therefore size should be even.
This parameter must be less than or equal to the partition size (as determined from the disklabel or /etc/disktab). An error is printed
and no action is taken if the partition size is 0 or too large.
NOTE: Mkfs deals in units of filesystem blocks not sectors. Newfs uses sectors.
FILES
/etc/disktab disk geometry and partition information
mkfs to actually build the file system
SEE ALSO getdisklabel(3), disklabel(8), disktab(5), diskpart(8), fs(5), fsck(8), mkfs(8)BUGS newfs(8) no longer places boot blocks on the filesystem. That duty has been moved to the disklabel(8) program. If you must place a boot
block on a disk whose driver does not support disklabels use dd(1).
4.2 Berkeley Distribution April 12, 1996 NEWFS(8)
Check Out this Related Man Page
NEWFS(8) BSD System Manager's Manual NEWFS(8)NAME
newfs -- construct a new file system
SYNOPSIS
newfs [-NO] [-S sector-size] [-T disktype] [-a maxcontig] [-b block-size] [-c cylinders] [-d rotdelay] [-e maxbpg] [-f frag-size] [-i bytes]
[-k skew] [-l interleave] [-m free space] [-n rotational positions] [-o optimization] [-p sectors] [-r revolutions] [-s size]
[-t tracks] [-u sectors] [-x sectors] special
DESCRIPTION
Newfs replaces the more obtuse mkfs(8) program. Before running newfs the disk must be labeled using disklabel(8). Newfs builds a file sys-
tem on the specified special device basing its defaults on the information in the disk label. Typically the defaults are reasonable, however
newfs has numerous options to allow the defaults to be selectively overridden.
The following options define the general layout policies.
-N Causes the file system parameters to be printed out without really creating the file system.
-O Creates a 4.3BSD format filesystem. This options is primarily used to build root filesystems that can be understood by older
boot ROMs.
-T Uses information for the specified disk from /etc/disktab instead of trying to get the information from a disklabel.
-a maxcontig
This specifies the maximum number of contiguous blocks that will be laid out before forcing a rotational delay (see the -d
option). The default value is one. See tunefs(8) for more details on how to set this option.
-b block-size
The block size of the file system, in bytes.
-c #cylinders/group
The number of cylinders per cylinder group in a file system. The default value is 16.
-d rotdelay
This specifies the expected time (in milliseconds) to service a transfer completion interrupt and initiate a new transfer on the
same disk. The default is 4 milliseconds. See tunefs(8) for more details on how to set this option.
-e maxbpg This indicates the maximum number of blocks any single file can allocate out of a cylinder group before it is forced to begin
allocating blocks from another cylinder group. The default is about one quarter of the total blocks in a cylinder group. See
tunefs(8) for more details on how to set this option.
-f frag-size
The fragment size of the file system in bytes.
-i number of bytes per inode
This specifies the density of inodes in the file system. The default is to create an inode for each 2048 bytes of data space.
If fewer inodes are desired, a larger number should be used; to create more inodes a smaller number should be given.
-m free space %
The percentage of space reserved from normal users; the minimum free space threshold. The default value used is 10%. See
tunefs(8) for more details on how to set this option.
-n rotational positions
Determines how many rotational time slots there are in one revolution of the disk.
-o optimization preference
(``space'' or ``time'') The file system can either be instructed to try to minimize the time spent allocating blocks, or to try
to minimize the space fragmentation on the disk. If the value of minfree (see above) is less than 10%, the default is to opti-
mize for space; if the value of minfree is greater than or equal to 10%, the default is to optimize for time. See tunefs(8) for
more details on how to set this option.
-s size The size of the file system in sectors.
The following options override the standard sizes for the disk geometry. Their default values are taken from the disk label. Changing these
defaults is useful only when using newfs to build a file system whose raw image will eventually be used on a different type of disk than the
one on which it is initially created (for example on a write-once disk). Note that changing any of these values from their defaults will
make it impossible for fsck to find the alternate superblocks if the standard superblock is lost.
-S sector-size
The size of a sector in bytes (almost never anything but 512).
-k sector 0 skew, per track
Used to describe perturbations in the media format to compensate for a slow controller. Track skew is the offset of sector 0 on
track N relative to sector 0 on track N-1 on the same cylinder.
-l hardware sector interleave
Used to describe perturbations in the media format to compensate for a slow controller. Interleave is physical sector interleave
on each track, specified as the denominator of the ratio:
sectors read/sectors passed over
Thus an interleave of 1/1 implies contiguous layout, while 1/2 implies logical sector 0 is separated by one sector from logical
sector 1.
-p spare sectors per track
Spare sectors (bad sector replacements) are physical sectors that occupy space at the end of each track. They are not counted as
part of the sectors/track (-u) since they are not available to the file system for data allocation.
-r revolutions/minute
The speed of the disk in revolutions per minute.
-t #tracks/cylinder
The number of tracks/cylinder available for data allocation by the file system.
-u sectors/track
The number of sectors per track available for data allocation by the file system. This does not include sectors reserved at the
end of each track for bad block replacement (see the -p option.)
-x spare sectors per cylinder
Spare sectors (bad sector replacements) are physical sectors that occupy space at the end of the last track in the cylinder.
They are deducted from the sectors/track (-u) of the last track of each cylinder since they are not available to the file system
for data allocation.
SEE ALSO fs(5), dumpfs(8), fdisk(8), fsck(8), mount(8), pdisk(8), tunefs(8)
M. McKusick, W. Joy, S. Leffler, and R. Fabry, "A Fast File System for UNIX,", ACM Transactions on Computer Systems 2, 3, pp 181-197, August
1984, (reprinted in the BSD System Manager's Manual).
HISTORY
The newfs command appeared in 4.2BSD.
4.2 Berkeley Distribution May 3, 1995 4.2 Berkeley Distribution