Why eth1 with auto dhcp disturbs pppoe over eth0?


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Why eth1 with auto dhcp disturbs pppoe over eth0?

Hi, I use ubuntu 16.04 desktop with ufw (default setup + 22, 80, 443 ports open).

I connect directly to ISP using pppoe over eth0. I also have eth1 which when disabled the websites are accessible in browser. When starting eth1 with auto dhcp the websites are no longer accessible in browser (give a timeout while trying to load). eth1 is plugged in a LAN port of a router with its WAN port unplugged (yeah, don't ask why). When setting a manual ip on eth1 while gateway and dns are left blank the websites are accessible in browser again.

Why this happens?
# 2  
Quote:
Originally Posted by adrhc
eth1 is plugged in a LAN port of a router with its WAN port unplugged (yeah, don't ask why). When setting a manual ip on eth1 while gateway and dns are left blank the websites are accessible in browser again.
You have already said it: DHCP (dynamic host configuration protocol) is a method of not only setting an IP address but to configure the whole IP stack of a system: this includes (but is not limited to:

- IP adresses
- subnet masks
- static routes
- name resolution

What exactly you get from the DHCP-server is configured there, not your system and chances are the DHCP-server is just configured badly.

So, if you connect to your first DHCP-server on eth0 you get everything configured right and your browsing is working. The second DHCP-server is perhaps configured the same way but because there is no outside connection you cannot use what it configures on your system and therefore the configuration is wrong and if you use that your working config is overwritten by a not-working config. Actually, you can use the IP-address you get, but not the DNS server and/or static routes that come along with it.

Configure the DHCP for your second interface for "DHCP (addresses only)" so that it doesn't overwrite the content of your file /etc/resolv.conf when configuring an IP address. Otherwise get the DHCP-server configured correctly so that it doesn't send certain "option fields" (DHCP-terminology) or fill them with values which work.

I hope this helps.

bakunin
This User Gave Thanks to bakunin For This Post:
# 3  
Thank you and I consider this thread SOLVED.
# 4  
Hi adrhc,
I'm glad that you got the help you needed.

To mark a thread solved, hit the "Edit Tags" button in the upper right corner of the Tags box at the top of every page of this thread and add the tag "solved". I have done that for you for this thread.
This User Gave Thanks to Don Cragun For This Post:
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #166
Difficulty: Easy
The Internet is a packet-switched network.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Ssh disturbs while loop

Hi all, I have observed that ssh exits while loop. #!/bin/ksh typeset -i i typeset -i size set -A server = " " "SERVER1" "SERVER2" i=2 while ] do while read in_module do print $in_module size=`ssh ${server} ls -l $in_module 2>/dev/null | awk '{print $5}'` ... (3 Replies)
Discussion started by: Soham
3 Replies

2. IP Networking

Get DHCP relay interfaces IP address using DHCP

Hi All , please view the set up below: ------------------------------------------------------------------- | DHCP Server |-----------| ROUTER & |-----------| Clients | | 192.168.99.1 | - -<eth1>| DHCP-RELAY|<eth2>-- | 192.168.88.X | ... (2 Replies)
Discussion started by: gdangoor
2 Replies

3. Red Hat

Dual NICs - When I 'ifup eth1' it replaces eth0

I've got an issue with a VMWare server running RHEL 6.3 that has dual E1000 NICs. I have configured the cards as I would normally do in /etc/sysconfig/network-scripts as ifcfg-eth0 and ifcfg-eth1. I can execute ifup eth0 and bring the interface up quite happily, however when I execute ifup eth1 it... (2 Replies)
Discussion started by: phaedrus
2 Replies

4. Red Hat

Wan on eth1 and Lan on eth0

I have a local network on dev eth0 Server has static IP of 10.0.0.1 Gateway is 10.0.0.1 and Dns is 10.0.0.1 I am using this network for imaging 500 plus computer... Now, Issue that I am having is that I need to update packages and I dont want to change the configuration on eth0 because I... (0 Replies)
Discussion started by: golpemortal
0 Replies

5. IP Networking

Problem in eth0 and eth1 sharing internet with other computers

hellow everbody. iam using 32 bit centos 6.2 on my desktop and iam new to linux. i have eth0 and eth1 on my desktop. so i have some problems i have menson here: i have edited: etc/sysctl.conf net.ipv4.ip_forward = 1 and i have edited iptables too # iptables -t nat -A... (2 Replies)
Discussion started by: paruhang
2 Replies

6. Ubuntu

Ubunut iptable not routing trafic between eth1 and eth0

hello, first of all i am new to unix so maybe my problem is very easy for many of you but is very important to me. So the idea is that i want to use a ubuntu 10.4 machine as a router from eth0 to eth1. but the traffic routing is nor working properly i configured the 2 interfaces to be... (2 Replies)
Discussion started by: florin.bv
2 Replies

7. UNIX for Dummies Questions & Answers

DHCP problem and eth1 problem

At work I am trying to get this one Linux machine (let's call it ctesgm07) to behave like another Linux machine that we have (let's call it test007). test007 returns the following version info: cat /etc/debian_version: lenny/sid uname -a: Linux test007 2.6.27-7-generic #1 SMP Tue Nov 4... (0 Replies)
Discussion started by: sllinux
0 Replies

8. Solaris

Reg- eth0,eth1 (ethernet card)

Hi Guys, I am working as a L-1 support and i want to know that are the precaution need to take on eth0(Ethernet card) i heard on production server it is very much important, what are the steps need to observe on this tickets. (1 Reply)
Discussion started by: kurva
1 Replies

9. UNIX for Dummies Questions & Answers

controlling traffic source from NIC eth0, eth1 in Linux

Hi Guys, is there a way to send traffic coming from the source iface (eth0, eth1)? i need to test traffic that will come from both eth0 and eth1 from a Linux box. Thanks, Martin (0 Replies)
Discussion started by: mdap
0 Replies

10. Red Hat

ifcfg-eth0 and eth1 is N/A

when i finish installed rhel 4.4 to my hp dl585 box, ifcfg-eth0 and ifcfg-eth1 is not available.when i ifconfig -a,i can not see the eth0 and eth1, only lo0 and si0. Unlike to the other server i found eth0 and eth1 files in /etc/sysconfig/network-scripts/. what will i do? (2 Replies)
Discussion started by: kenshinhimura
2 Replies

Featured Tech Videos