Visit Our UNIX and Linux User Community


Problem with HPUX as NIS-Client


 
Thread Tools Search this Thread
Operating Systems HP-UX Problem with HPUX as NIS-Client
# 1  
Old 06-18-2007
Question Problem with HPUX as NIS-Client

Hi all!

I am running an NIS Server with Linux. Now I want to configure a HPUX-Server to use this NIS Server. I have don all the configuration stuff exactly as described in the documentation.

When I run YPWHICH, it shows me the right server and domain. If I run YPCAT passwd, I'll get the correct passwd entries from the server. And if I am doing an su - NISUSER, it works very well.

But if I want to log in as NISUSER directly via ssh or telnet, I'll get an login incorrect.
I assume that there is something wrong with the password encryption. As far as I could find out the linux server is runnig on MD5 while HPUX runs on DES.
How can I get HPUX to do MD5 as well or is there any other way to resolve this problem?

Thanks
Peter
# 2  
Old 06-18-2007
Is your HP-UX trusted System? If yes, NIS is not compatible with Trusted System, you have to use NIS+.
# 3  
Old 06-19-2007
Quote:
Originally Posted by qfwfq
Is your HP-UX trusted System? If yes, NIS is not compatible with Trusted System, you have to use NIS+.
I don't think so. When I try to run e.g. the system security policies from the sam area Auditing and security, i'll get an error message that this system can't be converted to a trusted system. And if have done a cold installation of th os with the default settings especially the security settings i have left on default.

Or is there any other way to find out if my system is a trusted system?
# 4  
Old 06-19-2007
The fact that you have a /tcb directory structures usually indicates that this system is trusted. Also look at the password file, if there is no password and you see a * sign, then the system is trusted system or the shadow password depot is installed and activated.
# 5  
Old 06-19-2007
then i don't have a trusted system, because ther is no tcb tree.

But nevertheless i have solved my problem. It was caused by different encryption methods on the client and on the server. The server used the blowfish method. After i changed to DES everything works fine. The only thing i had to do was to reencrypt the passwords.

But if you know how i can change the encrytion method on HPUX.

Thanks,
Peter

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. HP-UX

NIS Master and Client problem

I have a NIS Master server and NIS Clients. But when I started the service all the process and files that should be owne by root apper by the owner 0 This is an example 0 1709 1708 0 10:06:10 ? 0:00 /usr/sbin/nfsd 4 0 1710 1709 0 10:06:10 ? 0:00 /usr/sbin/nfsd 4 0 1708 1 0 10:06:10 ? 0:00... (2 Replies)
Discussion started by: GCSG
2 Replies

2. UNIX for Dummies Questions & Answers

Help with NIS client

Hi All, I have a new server on the network, I did configure the NIS. ypwhich is working and ypcat all are working. But when I log in as me, home directory is not coming up. I looked at other servers we have at work to see what's under /etc/fstab. I don't see anything for home directory. ... (3 Replies)
Discussion started by: samnyc
3 Replies

3. Solaris

Problem with NIS client

Hi All, In my network infra, there is a NIS master server and many more NIS slave servers. Now, I want every client to set with master server and one possible slave server so that if master goes down, client could still get info from slave server. The servers will be listed on... (0 Replies)
Discussion started by: naw_deepak
0 Replies

4. Solaris

Solaris 10 NIS Client

Hi all, Recently i have implemented NIS functionality in solaris 10 and i have created server and client with user in server side by giving useradd -d /export/home/user1 -m -s /bin/sh user1 after that I went to /var/yp dir and give /usr/ccs/bin/make so that it will refelect to client... (2 Replies)
Discussion started by: esungoe
2 Replies

5. Solaris

NIS Client issues

Hey All! Today I am getting an error with my NIS client From what I understand, my server is running properly... on my client side.. online 2:01:12 svc:/network/nis/client:default # ps -ef |grep ypbind root 2745 1 0 02:01:12 ? 0:00... (12 Replies)
Discussion started by: Keepcase
12 Replies

6. Solaris

NIS - Client Not loggin in

Friends n Gurus I am creating an NIS farm(Solaris only) in my office. I have successfully configured the NIS master and slave servers and a few NIS clients. However i am not able to log into a few of my NIS clients. The commands "ypcat passwd" is displaying the NIS user. However when i try to... (5 Replies)
Discussion started by: Renjesh
5 Replies

7. Solaris

How to configure a NIS client bound to the NIS server in another subnet?

Hi, all. I have a Solaris client here needs to bind to NIS server in another subnet. Following is the configuration i made on the client, 1) edit /etc/inet/hosts to add an entry of the NIS server -- nserver01 2) execute `domainname` to set local NIS domain to the domain of the NIS server.... (1 Reply)
Discussion started by: sn_wukong
1 Replies

8. AIX

AIX NIS client

All, I have just started using AIX (Solaris admin here) and I need to setup my new AIX box as an NIS client. Where would I do this? Thanks for the help! -Kevin (2 Replies)
Discussion started by: kjbaumann
2 Replies

9. AIX

Use AIX as NIS client

Hi everyone. Has anyone here used AIX as a NIS client to a Linux server? If have configured this setup and cant get it to work. I have verifyed that the NIS server is working since other machines are able to connect to it and users to log in on other clients. On the AIX machine the users are... (0 Replies)
Discussion started by: sprellari
0 Replies

10. Solaris

Unregietred a nis+ client

Hi, How can I unregistered a nis+ client. I want it works without nis+. Bests regards (2 Replies)
Discussion started by: omainfroy
2 Replies

Featured Tech Videos