How to open the core dump file in linux?

 
Thread Tools Search this Thread
Homework and Emergencies Emergency UNIX and Linux Support How to open the core dump file in linux?
# 8  
Old 12-08-2011
From man core(5):

You can send a process (via the kill command) any of the signals whose corresponding action is "core" listed in that man page. This includes:
SIGQUIT, SIGILL, SIGABRT, SIGFPE, SIGSEGV, SIGBUS, SIGSYS, SIGTRAP, SIGXCPU, SIGXFSZ, SIGIOT,

The catch is that (1) a process can choose to ignore these signals or handle them without doing a core dump, and (2) the parent shell can limit the core dump through ulimit or other commands.


Quote:
Up to and including Linux 2.2, the default behaviour for SIGSYS, SIGXCPU, SIGXFSZ, and (on architectures other than SPARC and MIPS) SIGBUS was to terminate the process (without a core dump). (On some other Unices the default action for SIGXCPU and SIGXFSZ is to terminate the process without a core dump.) Linux 2.4 conforms to the POSIX.1-2001 requirements for these signals, terminating the process with a core dump.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Core Dump of a process in Red Hat Linux 5.9

Hello All, I am new joiner of this forum.I am new to Linux shell scripting. At present I have identified 1 application which stalls very frequently (PID is say xyz) and I am not having much information in its application log to identify the root cause of stalling. I need to take the core dump... (19 Replies)
Discussion started by: Anjan Ganguly
19 Replies

2. UNIX for Dummies Questions & Answers

Learn Linux Core Dump Analysis

Can any body provide me some good link to learn to create and analyze linux user mode application / kernel module core dumps? (1 Reply)
Discussion started by: rupeshkp728
1 Replies

3. Solaris

Problems in reading CORE DUMP file with dbx

I am new to UNIX. My Application is using c (.so files) and Java code. My application crashes and CORE DUMP file is generated ,which is huge. Now I want to view the CORE DUMP file to debug the application using dbx without starting process again. By only using the CORE DUMP file and dbx ,can i... (1 Reply)
Discussion started by: satde
1 Replies

4. Linux

Thread specific data from linux core dump

How do i get pointer to thread's local storage or thread specific data while analyzing core dump for linux ? i use pthread_setspecific to store some data in the pthread's local stoare. my multi threaded program on linux crashed, and i want to see what is stored in current running thread's... (2 Replies)
Discussion started by: vishwasungal
2 Replies

5. Shell Programming and Scripting

Cannot generate core dump file

Segmentation fault(core dumped) but I cant find core file any where. how to make it out? I try the command:ulimit -c unlimited, I even added it to the .bashrc file.And I removed ulimit setting in /etc/init.d/function. And there's no ulimit setting in /etc/profile. And I tried sudo find /... (8 Replies)
Discussion started by: vistastar
8 Replies

6. Programming

How to use a core dump file

Hi All, May be it is a stupid question, but, I would like to know what is the advantage using a core dump file at the moment of debugging using gdb. I know a core dump has information about the state of the application when it crashed, but, what is the difference between debugging using the... (2 Replies)
Discussion started by: lagigliaivan
2 Replies

7. Programming

how to view a core dump file

by what name does a core dump file stored??? like i wrote a test code: //dump.c main() { char *p=NULL; printf("%s",p); } of course the above code will produce a segmentation fault. but i cant see any file named core in my CWD. am using SUN0S 5.9 (6 Replies)
Discussion started by: vikashtulsiyan
6 Replies

8. UNIX for Dummies Questions & Answers

core dump file size

Hi All, is there any way to find out the optimal/would be size of the cor dump file generated by the system while a process got terminated abnormally? Basically we have been asked to provide the size of the core dump file being generated by the administrators who maintained the UNIX boxes.... (4 Replies)
Discussion started by: pushp.gahlot
4 Replies

9. UNIX for Dummies Questions & Answers

core dump

I've got a core dump in my weblogic home directory, which i have tried to debug by initiating savecore from /etc/init.d/savecore start but savecore failed to create the two files, that is vmcore.n and vmunix.n. savecore is enable on my server to save vmcore and vmunix in /var/crash/hostname 1)... (4 Replies)
Discussion started by: hassan2
4 Replies

10. UNIX for Dummies Questions & Answers

help, what is the difference between core dump and panic dump?

help, what is the difference between core dump and panic dump? (1 Reply)
Discussion started by: aileen
1 Replies
Login or Register to Ask a Question
crashutil(1M)															     crashutil(1M)

NAME
crashutil - manipulate crash dump data SYNOPSIS
version] source [destination] DESCRIPTION
copies and preserves crash dump data, and performs format conversions on it. Common uses of include: o Copying portions of a dump that still reside on a raw dump device into a crash dump directory. o Converting between different formats of crash dumps. o Copying crash dumps from one directory, or medium, to another. will write to its destination the crash dump it reads from its source. The crash dump format used to write the destination is specified with if is not specified, the destination will have the same format as the source. If no destination is specified, source is used; the format conversion will be done in place in the source, without copying. When completes successfully, the entire contents of the crash dump will exist at destination; any portions that had still been on raw dump devices will have been copied to destination. There are three known dump formats: (Version 0) This format, used up through HP-UX 10.01, consists of a single file containing the physical memory image, with a 1-to-1 cor- respondence between file offset and memory address. Normally there is an associated file containing the kernel image. sources or destinations of this type must be specified as two pathnames to plain files, separated by whitespace; the first is the core image file and the second is the kernel image file. (Version 1) This format, used in HP-UX 10.10, 10.20, and 10.30, consists of a directory containing an file, the kernel file, and numerous files, which contain portions of the physical memory image. sources or destinations of this type should be specified as the pathname to a core directory. (Version 2) This format, used in HP-UX 11.00 and later, consists of a directory containing an file, the kernel and all dynamically loaded kernel module files, and numerous files, each of which contain portions of the physical memory image and metadata describing which memory pages were dumped and which were not. sources or destinations of this type should be specified as the pathname to a crash directory. (Version 3) This format is used in HP-UX Release 11i Version 1.0 and later. It is very similar in structure to the format in that it consists of a directory containing an file, the kernel and all dynamically loaded kernel module files, and numerous files, each of which contain portions of the physical memory image and metadata describing which memory pages were dumped and which were not. In addition to the primary file, there are auxiliary index files, that contain metadata describing the image files containing the memory pages. This format will be used when the dump is compressed. See crashconf(1M). Other formats, for example tape archival formats, may be added in the future. When the source and destination are different types of files -- for example, when source is a directory and destination is a pair of plain files -- both must be specified. Options (Quiet) Disables the printing of progress messages. Warning and error messages are still printed. Specifies the version of the destination format. Allowed values are 0, 1, 2 or 3. Also allowed is the keyword which specifies that the destination format should be the same as the current source format. is the default if is not specified. If the destination format is then the source format should also be Conversion to from older formats is not supported. RETURN VALUE
Upon exit, returns the following values: 0 The operation was successful. 1 The operation failed, and an appropriate error message was printed. EXAMPLES
An HP-UX 11.00 crash dump was saved by savecrash(1M) to The flag was specified to savecrash, specifying that only those portions of the dump which were endangered by swap activity should be saved; the rest are still resident in the raw dump devices. To save the remainder of the dump into the crash dump directory, use: If preferred, the completed crash dump directory could be in a different location -- perhaps on another machine via NFS: To debug this crash dump using tools which do not understand the most current crash dump format, convert it to the older core directory format: or the even older "core file and kernel" format: AUTHOR
was developed by HP. SEE ALSO
savecrash(1M), crashconf(1M). crashutil(1M)