Visit Our UNIX and Linux User Community


AIX 6.1 TL8 update : bos.aso doesn't install.


 
Thread Tools Search this Thread
Operating Systems AIX AIX 6.1 TL8 update : bos.aso doesn't install.
# 1  
Old 07-29-2013
AIX 6.1 TL8 update : bos.aso doesn't install.

Hello.

An update of TL from TL7 to TL8 is ending with errors :
Code:
Requisite Failures
  ------------------
  SELECTED FILESETS:  The following is a list of filesets that you asked to
  install.  They cannot be installed until all of their requisite filesets
  are also installed.  See subsequent lists for details of requisites.

    X11.base.lib 6.1.8.0                      # AIXwindows Runtime Libraries
    X11.compat.lib.X11R6 6.1.8.0              # AIXwindows X11R6 Compatibili...
    bos.64bit 6.1.8.0                         # Base Operating System 64 bit...
    bos.acct 6.1.8.0                          # Accounting Services
    bos.adt.base 6.1.8.0                      # Base Application Development...
    bos.adt.debug 6.1.8.0                     # Base Application Development...
    bos.adt.include 6.1.8.1                   # Base Application Development...
    bos.adt.prof 6.1.8.0                      # Base Profiling Support
    bos.adt.syscalls 6.1.8.0                  # System Calls Application Dev...
    bos.aixpert.cmds 6.1.8.1                  # AIX Security Hardening
    bos.diag.com 6.1.8.0                      # Common Hardware Diagnostics
    bos.diag.rte 6.1.8.1                      # Hardware Diagnostics
[...]
    devices.vdevice.hvterm1.rte 6.1.8.0       # Virtual Terminal Devices
    mcr.rte 6.1.8.0                           # Metacluster Checkpoint and R...
    perfagent.tools 6.1.8.0                   # Local Performance Analysis &...

  MISSING REQUISITES:  The following filesets are required by one or more
  of the selected filesets listed above.  They are not currently installed
  and could not be found on the installation media.

    bos.aso 6.1.0.0                           # Base Level Fileset

  AVAILABLE REQUISITES:  You specified that requisite software should be
  automatically installed.  Additional filesets (1) would have been
  installed automatically had the selected filesets passed all requisite
  checks.

bos.aso 6.1..0.0 doesn't exists (IBM Fileset information for: bos.aso - United States)
I tried to manually install bos.aso 6.1.8.0 and 6.1.8.1 but it says this :

Code:
SELECTED FILESETS:  The following is a list of filesets that you asked to
  install.  They cannot be installed until all of their requisite filesets
  are also installed.  See subsequent lists for details of requisites.

    bos.aso 6.1.8.0                           # Active System Optimizer

  MISSING REQUISITES:  The following filesets are required by one or more
  of the selected filesets listed above.  They are not currently installed
  and could not be found on the installation media.

    bos.mp64 6.1.8.0                          # Base Level Fileset
    bos.net.tcp.client 6.1.8.0                # Base Level Fileset
    bos.perf.tune 6.1.8.0                     # Base Level Fileset

I tried to manually install bos.mp64 6.1.8.0, but it also require bos.aso 6.1.0.0.

I'm stuck ... Could you help ?

Thx
# 2  
Old 07-29-2013
The reason is in the output with quite a detailed explanation:
Code:
MISSING REQUISITES:
...
bos.aso 6.1.0.0                           # Base Level Fileset

The updates for this fileset can't be applied since the base level fileset is not installed.
Either leave them away or get a base level fileset for it. If you need it, look on your installation media for AIX.

No base level fileset = no updates.

If you don't need ASO and just want to get pass the errors, try a installp -C for a clean up.

To check if your patches have been applied succesfully, you can issue
Code:
$ instfix -i | grep ML
    All filesets for 6.1.0.0_AIX_ML were found.
    All filesets for 6100-00_AIX_ML were found.
    All filesets for 6100-01_AIX_ML were found.
    All filesets for 6100-02_AIX_ML were found.
    All filesets for 6100-03_AIX_ML were found.
    All filesets for 6100-04_AIX_ML were found.
    All filesets for 6100-05_AIX_ML were found.
    All filesets for 6100-06_AIX_ML were found.
    All filesets for 6100-07_AIX_ML were found.
    All filesets for 6100-08_AIX_ML were found.

# 3  
Old 07-29-2013
as I said, bos.aso is a "new" fileset/functionality for Power7, automatically installed ant it's a requisite for others.

In this link : IBM Fileset information for: bos.aso - United States , you'll see that it doesn't exist before 6.1 TL8.

It's not already installed.
# 4  
Old 07-29-2013
Quote:
as I said ...
You did not write that - that's new info; check your 1st post.

Anyway, check your update media or whatever you have downloaded if there is a fileset bos.aso 6.1.8.0. Also try to check the link you posted, if you can download bos.aso 6.1.8.0 from there.
If you find it, try to install it 1st before you go for the update.

That it is not installed says the error message in your 1st post already...
# 5  
Old 07-30-2013
Yes, I said it Smilie :
Quote:
Originally Posted by stephnane

I resolve my issue through a strange way :
I had 2 times the same fileset 6.1.8.0.
- I tried to install from the SP2 & requisite I downloaded (bos.aso.6.1.8.0.I) : it doesn't works.
- I downloaded TL8 (SP0) then I install the same fileset from this download : it works ...

Thx for your help.

Previous Thread | Next Thread
Test Your Knowledge in Computers #455
Difficulty: Medium
Java was originally developed at Oracle starting in December 1990.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

How to install bos.net.NFS.server 7.1.x.x ??

Hello Everyone, I am in quite a deliema, where do I get bos.net.nfs.server 7.1.0.0 from?? I am running AIX 7.1.3.3 & PowerHA 7.1.3 on this server. #lslpp -l |grep nfs bos.net.nfs.client 7.1.3.15 COMMITTED Network File System Client cluster.es.nfs.rte ... (0 Replies)
Discussion started by: gorkhali
0 Replies

2. AIX

Upgrade to TL8 failed: bos.net.NFS.client 6.1.8.1 (usr: COMMITTED, root:

dears i am trying to upgrade the TL from TL7 to TL8 and i facing this issue AIX6.1 << End of Success Section >> +-----------------------------------------------------------------------------+ BUILDDATE Verification ...... (2 Replies)
Discussion started by: thecobra151
2 Replies

3. AIX

Downgrade bos.rte.install ?

Hello, Running AIX 6.1 TL2 SP4. bos.rte.install was upgraded to 6.1.4.1 by accident(commited). I'm trying to downgrade it. On my install DVD I found bos.rte.install_6.1.2.1.bff. So I'm trying to downgrade: # installp -acF -d/soft1 bos.rte.install 6.1.2.1... (6 Replies)
Discussion started by: vilius
6 Replies

4. AIX

AIX 5.3 BOS Overwrite Installation problem

Hi list, I am trying to perform an AIX 5.3 new installation on a p505 machine. After plugging the machine on the power and connecting using Hyperterminal through COM1 I get the following screen: Welcome Machine type-model: 9115-505 Serial number: 102765A Date: 2010-1-12 ... (1 Reply)
Discussion started by: mariobehring
1 Replies

5. AIX

Need AIX 5.3 bos.adt.libm

We have an older AIX RS 6000 and had the hard drive die on us. I was able to get the hard drive replaced and it came with AIX 5.3 installed on it but is missing a component that we need. I am trying to install our C+ and Fortran compilers but they require the bos.adt.libm module and I do not have... (3 Replies)
Discussion started by: fredn
3 Replies

6. AIX

Where do I get bos.adt.debug fot AIX 6.1 ?

Hello, Can't find this package anywhere: Searched all AIX 6.1 CD's - nothing Serched expansion pack - nothing Where do I get it ? thanks Vilius ---------- Post updated at 01:39 PM ---------- Previous update was at 10:58 AM ---------- Ok this was my mistake. bos.adt.debug was... (1 Reply)
Discussion started by: vilius
1 Replies

7. AIX

bos.rte.5.2.0.10 - Failure to Install (/usr/lib/methods/cfgsf bad permissions)

I have a RS/6000 B80 which just had a disk failure; I've added a new drive and am in the process of rebuilding. I have reinstalled AIX 5.2 and am now looking to begin updating. (fyi this will be the second time I have attempted to rebuild this machine, the first time i installed ML 5200-10 and... (1 Reply)
Discussion started by: wesiman
1 Replies

8. AIX

How to apply aix 5.3 TL8 properly on ML5 aix system ?

Is it necessary to put system into single user mode for applying aix 5.3 TL8 on a aix 5.3.5.0 system ? Is the TL8 installation not totally safe ? thank you. (6 Replies)
Discussion started by: astjen
6 Replies

9. AIX

AIX 5.1 install bos.sysmgt.nim.master failed

I was trying to install bos.sysmgt.nim.master on AIX 5.1 with a mounted NFS source, but it failed: # installp -agXd /nfs/aix51cd1 bos.sysmgt.nim.master installp: APPLYING software for: bos.sysmgt.nim.master 5.1.0.50 restore: 0511-123 The volume on... (0 Replies)
Discussion started by: ezlee
0 Replies

10. AIX

How do I install bos.loc.iso.en_GB?

Hi, I need to install the package bos.loc.iso.en_GB on an AIX 5.3 server but try as I might I cannot find the file which contains this package. I have all the AIX 5.3 CDs and also the majority of the packages installed locally on the server. If I create a .toc file from the local packages I... (3 Replies)
Discussion started by: m223464
3 Replies

Featured Tech Videos