Sponsored Content
Operating Systems BSD A question about BSD kernel and driver Post 302897359 by alister on Sunday 13th of April 2014 03:14:06 PM
Old 04-13-2014
You can always try to build a kernel with it, but I doubt it will work. If it did, it'd be part of the GENERIC config.

Also, note that the bktr driver appears to be an i2c master. You'd need iic(4) on hppa (I'm not familiar with the architecture, just mentioning it).

Regards,
Alister
 

8 More Discussions You Might Find Interesting

1. News, Links, Events and Announcements

BSD Accelerated NVIDIA Driver Petition

hello ppl, me and a friend, tired of waiting for nvidia to help the community creating a nvidia driver for bsd, decided to make yet another petition to deliver nvidia as a way of protest. didn't we buy a nvidia card just like a common windows or linux user? didn't we pay for it? so, why... (0 Replies)
Discussion started by: crashnburn
0 Replies

2. UNIX for Advanced & Expert Users

Kernel and Device Driver Programming

I am looking for a guide on how to program for either the Linux or FreeBSD (includes 4.4BSD, NetBSD or OpenBSD) kernel. I would prefer to learn how to write device drivers, but anything would help. If you know, please email me at *removed* or leave a post here Regards, Farhan (0 Replies)
Discussion started by: Farhan
0 Replies

3. Linux

Linux Device Driver: avoid mem copy from/to user/kernel space

I recently started working with Linux and wrote my first device driver for a hardware chip controlled by a host CPU running Linux 2.6.x kernel. 1. The user space process makes an IOCTL call with pointer to a user memory buffer. 2. The kernel device driver in the big switch-case of IOCTL,... (1 Reply)
Discussion started by: agaurav
1 Replies

4. BSD

BSD Kernel Source Code

Hi I need the BSD core (kernel) operating system Please let me download link I'm from Iran Please help me Thank you very much (1 Reply)
Discussion started by: sepadl71
1 Replies

5. BSD

BSD kernel

Hi. I am thinking to create an OS. I don't want to use linux kernel. I want to use BSD Kernel and this also means that because will be on UFS, I cannot use Gparted. This are my 2 questions. 1) Where can I download BSD Kernel. 2) Witch is the tool to create the partitions. (I think is gpart but I... (1 Reply)
Discussion started by: snuffell
1 Replies

6. Fedora

Is Kernel module is the same as a device driver?

I have been reading prep questions for my second unix academy exam, and there's a nuance, I'm not sure I understand it correctly. I've been under impression from my readings of book by Evi Nemeth and from unix academy DVDs I've been watching, that kernel's modules are drivers. I think of it, as... (25 Replies)
Discussion started by: newlinuxuser1
25 Replies

7. Hardware

Difference between platform driver,codec driver and Machine driver

In general terms what are the differences platform driver,codec driver and Machine driver? (1 Reply)
Discussion started by: rupeshkp728
1 Replies

8. Ubuntu

Kernel panics : trying to write / read on tiny tty driver

I'm a beginner to the Linux programming and trying my hands on some device driver examples while practising. The below code (a trimmed down version of tiny_tty.c from ldd3 book) loads perfectly using insmod and I'm able to see it in /proc/tty/drivers , /proc/modules and device nodes are getting... (1 Reply)
Discussion started by: diwsdiwa
1 Replies
LM75(4) 						   BSD Kernel Interfaces Manual 						   LM75(4)

NAME
lm75 -- lm75 i2c digital temperature sensor driver SYNOPSIS
device iic device iicbus device lm75 DESCRIPTION
The lm75 driver provides access to sensor data and configuration over the iicbus(4). It provides an easy and simple way to check the functionality of an i2c bus as it provides read and write access to the lm75 configuration register. The access to lm75 data is made via the sysctl(8) interface: dev.lm75.0.%desc: LM75 temperature sensor dev.lm75.0.%driver: lm75 dev.lm75.0.%location: addr=0x49 dev.lm75.0.%pnpinfo: name=lm750 compat=national,lm75 dev.lm75.0.%parent: iicbus3 dev.lm75.0.temperature: 27.1C dev.lm75.0.thyst: 75.0C dev.lm75.0.tos: 80.0C dev.lm75.0.faults: 1 dev.lm75.0.mode: comparator dev.lm75.0.polarity: active-low dev.lm75.0.shutdown: 0 dev.lm75.%d.temperature Is the read-only value of the current temperature read by the sensor. dev.lm75.%d.thyst Sets the hysteresis temperature. Once the temperature gets over the overtemperature shutdown value (tos) it needs to drop below the hysteresis temperature to disable the output (interrupt) pin again. dev.lm75.%d.tos Sets the overtemperature shutdown value. Once the temperature gets over this value the output pin will be enabled. The way the output (interrupt) pin works, depends on the mode configuration. dev.lm75.%d.faults Is the number of faults that must occur consecutively to activate the interrupt (output) pin. It can be set to 1, 2, 4, and 6. dev.lm75.%d.mode Sets the operation mode for the sensor interrupt pin. It can be set to 'comparator' (default) or 'interrupt'. dev.lm75.%d.polarity Sets the polarity of the sensor interrupt pin. It can be set to 'active-low' (default) or 'active-high'. Please note that the output pin is an open-drain output and it needs a proper pull-up resistor to work. dev.lm75.%d.shutdown When set to '1' it shuts down the sensor. The temperature conversion stops but the sensor remains with its i2c bus active, i.e., it can be woken up by setting this option to '0' again. Please check the lm75 datasheet for more details. When used together with snmp_lm75(3) it allows the monitoring of lm75 temperature data over SNMP. The lm75 driver supports both the low and the high resolution models. The low resolution model (lm75) provides a 9 bit output with the LSB representing 0.5C. The high resolution model (lm75a) provides an 11 bit output with the LSB representing 0.125C. The driver tries to auto-detect the lm75 model, but the detection of some lm75 clones may not work reliably. On a device.hints(5) based system, like MIPS, these values are configurable for lm75: hint.lm75.%d.at Is the iicbus(4) you are attaching to. hint.lm75.%d.addr Is the lm75 i2c address on the iicbus(4). On a FDT(4) based system, like ARM, the DTS part for a lm75 device usually looks like: i2c { ... lm750 { compatible = "national,lm75"; i2c-address = <0x49>; }; }; Where: compatible Should always be set to "national,lm75". i2c-address The i2c-address property indicates which i2c address the lm75 is wired at. lm75 temperature sensors can be wired to 8 different addresses, allowing up to 8 sensors on the same iicbus(4). SEE ALSO
snmp_lm75(3), fdt(4), iic(4), iicbus(4), sysctl(8) HISTORY
The lm75 driver first appeared in FreeBSD 11.0. AUTHORS
The lm75 driver and this manual page were written by Luiz Otavio O Souza <loos@FreeBSD.org>. BSD
May 11, 2014 BSD
All times are GMT -4. The time now is 12:58 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy