Sponsored Content
Full Discussion: Solaris: email to user
Operating Systems Solaris Solaris: email to user Post 302384027 by TonyFullerMalv on Sunday 3rd of January 2010 09:47:23 AM
Old 01-03-2010
Do you have entries in /etc/resolv.conf(4) and is dns listed in the hosts line in /etc/nsswitch.conf(4)?

Can you look up any DNS address, e.g.:
Code:
$ nslookup news.bbc.co.uk

Code:
$ nslookup <ip address from above>

and then if sendmail is using DNS to find the mail exchanger then:
Code:
$ nslookup
> servertype=MX

and then
Code:
> mailhost

and then to exit from nslookup:
Code:
> exit

On my system the above looks like:
Code:
$ nslookup news.bbc.co.uk
Server:        10.0.0.2
Address:    10.0.0.2#53

Non-authoritative answer:
news.bbc.co.uk    canonical name = newswww.bbc.net.uk.
Name:    newswww.bbc.net.uk
Address: 212.58.226.73

$ nslookup 212.58.226.73
Server:        10.0.0.2
Address:    10.0.0.2#53

Non-authoritative answer:
73.226.58.212.in-addr.arpa    name = newslb305.telhc.bbc.co.uk.

Authoritative answers can be found from:

$ nslookup
> servertype=MX
Server:        10.0.0.2
Address:    10.0.0.2#53

Non-authoritative answer:
Name:    servertype=MX.FullerDomain
Address: 67.215.65.132
> mailhost
Server:        10.0.0.2
Address:    10.0.0.2#53

Non-authoritative answer:
Name:    mailhost.FullerDomain
Address: 67.215.65.132
> exit
$

 

7 More Discussions You Might Find Interesting

1. Programming

Sending email to a User from C++

How do i send a mail to User from c++? (1 Reply)
Discussion started by: debu
1 Replies

2. UNIX for Advanced & Expert Users

Send email as a different user than the user logged in

Hi I am using mailx to send email and am wondering if there is a way I can send the email from a different user than the user logged in. something like do-not-reply@xyz.com Thank you. (1 Reply)
Discussion started by: rakeshou
1 Replies

3. Solaris

Send an email from Solaris using Linux email server

Hello everyone I have a problem and I need your help: I have a Solaris 10 and Solaris 8 UNIX Servers, and Linux Centos4 as email server. I need send an email from Solaris servers preferably using Centos4 email server. I have no mail service configured in my Solaris computers (1 Reply)
Discussion started by: aflores
1 Replies

4. Shell Programming and Scripting

Email sent to multiple user address?

hi all, This is user that i want sent the email: Email = allan@gmail.com bruce8899@gmail.com Chris@gmail.com echo "$dir : $filecount is over the limit $limit " | mailx -s "${SUBJECT}" "${email}" However it cannot sent to 3 user..only sent to 1 user email address. Any 1 can help me... (15 Replies)
Discussion started by: proghack
15 Replies

5. Shell Programming and Scripting

Write a scripts to kill idle user for 60 min. & email user list to admin in text file

Folks, I have written one script for following condition by referring some of online post in this forum. Please correct it if I'm missing something in it. (OS: AIX 5.3) List the idle user. (I used whoidle command to list first 15 user and get username, idle time, pid and login time).... (4 Replies)
Discussion started by: sumit30
4 Replies

6. Shell Programming and Scripting

Send one email per user

I created a bash script that gets a file formats it, sends an email to the user(s), however, for whatever reason, it will send an email per line with all of the lines in it, so essentially the user will get 10 duplicate emails with the same 10 results. I've modified the script to put the results of... (2 Replies)
Discussion started by: hotdang
2 Replies

7. Forum Support Area for Unregistered Users & Account Problems

Regarding registration email for new user

Hello Moderators, Greetings !! This is regarding my friend to whom I refered this forum to learn UNIX. User didn't receieved any registration email yet, could you please help user. Will be grateful to you on same. Login name: Gurvinder_Kaur NOTE: User doesn't have enough bits for... (0 Replies)
Discussion started by: RavinderSingh13
0 Replies
rpc.nisd_resolv(1M)					  System Administration Commands				       rpc.nisd_resolv(1M)

NAME
rpc.nisd_resolv, nisd_resolv - NIS+ service daemon SYNOPSIS
rpc.nisd_resolv [-v | -V] [ -F [-C fd]] [-t xx] [-p yy] DESCRIPTION
rpc.nisd_resolv is an auxiliary process which provides DNS forwarding service for NIS hosts requests to both ypserv and rpc.nisd that are running in the NIS compatibility mode. It is generally started by invoking rpc.nisd(1M) with the -B option or ypserv(1M) with the -d option. Although it is not recommended, rpc.nisd_resolv can also be started independently with the following options. This command requires that the /etc/resolv.conf file be setup for communication with a DNS nameserver. The nslookup utility can be used to verify communication with a DNS nameserver. See resolv.conf(4) and nslookup(1M). OPTIONS
-F Run in foreground. -C fd Use fd for service xprt (from nisd). -v Verbose. Send output to the syslog daemon. -V Verbose. Send output to stdout. -t xx Use transport xx. -p yy Use transient program# yy. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWnisu | +-----------------------------+-----------------------------+ SEE ALSO
nslookup(1M), rpc.nisd(1M), resolv.conf(4), attributes(5) NOTES
NIS+ might not be supported in future releases of the SolarisTM Operating Environment. Tools to aid the migration from NIS+ to LDAP are available in the Solaris 9 operating environment. For more information, visit http://www.sun.com/directory/nisplus/transition.html. SunOS 5.10 12 Dec 2001 rpc.nisd_resolv(1M)
All times are GMT -4. The time now is 06:38 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy