Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

msgb(9s) [sunos man page]

msgb(9S)						    Data Structures for Drivers 						  msgb(9S)

NAME
msgb, mblk - STREAMS message block structure SYNOPSIS
#include <sys/stream.h> INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI) DESCRIPTION
A STREAMS message is made up of one or more message blocks, referenced by a pointer to a msgb structure. The b_next and b_prev pointers are used to link messages together on a QUEUE. The b_cont pointer links message blocks together when a message consists of more than one block. Each msgb structure also includes a pointer to a datab(9S) structure, the data block (which contains pointers to the actual data of the message), and the type of the message. STRUCTURE MEMBERS
struct msgb *b_next; /* next message on queue */ struct msgb *b_prev; /* previous message on queue */ struct msgb *b_cont; /* next message block */ unsigned char *b_rptr; /* 1st unread data byte of buffer */ unsigned char *b_wptr; /* 1st unwritten data byte of buffer */ struct datab *b_datap; /* pointer to data block */ unsigned char b_band; /* message priority */ unsigned short b_flag; /* used by stream head */ Valid flags are as follows: MSGMARK Last byte of message is marked. MSGDELIM Message is delimited. The msgb structure is defined as type mblk_t. SEE ALSO
datab(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 msgb(9S)

Check Out this Related Man Page

msgb(9S)						    Data Structures for Drivers 						  msgb(9S)

NAME
msgb, mblk - STREAMS message block structure SYNOPSIS
#include <sys/stream.h> INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI) DESCRIPTION
A STREAMS message is made up of one or more message blocks, referenced by a pointer to a msgb structure. The b_next and b_prev pointers are used to link messages together on a QUEUE. The b_cont pointer links message blocks together when a message consists of more than one block. Each msgb structure also includes a pointer to a datab(9S) structure, the data block (which contains pointers to the actual data of the message), and the type of the message. STRUCTURE MEMBERS
struct msgb *b_next; /* next message on queue */ struct msgb *b_prev; /* previous message on queue */ struct msgb *b_cont; /* next message block */ unsigned char *b_rptr; /* 1st unread data byte of buffer */ unsigned char *b_wptr; /* 1st unwritten data byte of buffer */ struct datab *b_datap; /* pointer to data block */ unsigned char b_band; /* message priority */ unsigned short b_flag; /* used by stream head */ Valid flags are as follows: MSGMARK Last byte of message is marked. MSGDELIM Message is delimited. The msgb structure is defined as type mblk_t. SEE ALSO
datab(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 msgb(9S)
Man Page

4 More Discussions You Might Find Interesting

1. Programming

Socket Programming

Hi , I'm facing the following problem in socket programming. My structure is struct { int i; char *str; }samp; I'm creating the pointer to this structure and assigning the value to the structure members and send via the socket to the another process. The receiver process when... (7 Replies)
Discussion started by: arunviswanath
7 Replies

2. Shell Programming and Scripting

Sort, Uniq, Duplicates

Input File is : ------------- 25060008,0040,03, 25136437,0030,03, 25069457,0040,02, 80303438,0014,03,1st 80321837,0009,03,1st 80321977,0009,03,1st 80341345,0007,03,1st 84176527,0047,03,1st 84176527,0047,03, 20000735,0018,03,1st 25060008,0040,03, I am using the following in the script... (5 Replies)
Discussion started by: Amruta Pitkar
5 Replies

3. Programming

C Programming.. Typecasting of structure pointers..

Hi, I need to pass a typecasted structure pointer of one structure to another structure pointer.. The parameters of both structures are different say if first structure has int, char datatypes and second structure has float, double,char.. Please help.. I need to get the values of one... (3 Replies)
Discussion started by: Priya Amaresh
3 Replies

4. UNIX for Dummies Questions & Answers

Finding difference in 1st field for rows of data

I have a file that has multiple lines, of grouped data, that typically all have the same values in the 1st field, however, I would like to search the 1st field for any differences and set a flag to use in an "if" statement to run some other routine. An example of the typical file is below,... (2 Replies)
Discussion started by: co21ss
2 Replies