Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kstat_named_init(9f) [sunos man page]

kstat_named_init(9F)					   Kernel Functions for Drivers 				      kstat_named_init(9F)

NAME
kstat_named_init, kstat_named_setstr - initialize a named kstat SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> void kstat_named_init(kstat_named_t *knp, char *name, uchar_t data_type); void kstat_named_setstr(kstat_named_t *knp, const char *str); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
knp Pointer to a kstat_named(9S) structure. name The name of the statistic. data_type The type of value. This indicates which field of the kstat_named(9S) structure should be used. Valid values are: KSTAT_DATA_CHAR The "char" field. KSTAT_DATA_LONG The "long" field. KSTAT_DATA_ULONG The "unsigned long" field. KSTAT_DATA_LONGLONG Obsolete. Use KSTAT_DATA_INT64. KSTAT_DATA_ULONGLONG Obsolete. Use KSTAT_DATA_UINT64. KSTAT_DATA_STRING Arbitrary length "long string" field. str Pointer to a NULL-terminated string. DESCRIPTION
kstat_named_init() associates a name and a type with a kstat_named(9S) structure. kstat_named_setstr() associates str with the named kstat knp. It is an error for knp to be of type other than KSTAT_DATA_STRING. This is the only supported method of changing the value of long strings. RETURN VALUES
None. CONTEXT
kstat_named_init() and kstat_named_setstr() can be called from user or kernel context. SEE ALSO
kstat_create(9F), kstat_install(9F), kstat(9S), kstat_named(9S) Writing Device Drivers SunOS 5.10 8 Mar 2004 kstat_named_init(9F)

Check Out this Related Man Page

net_kstat_create(9F)					   Kernel Functions for Drivers 				      net_kstat_create(9F)

NAME
net_kstat_create - create and initialize a new kstat for a specific instance of IP SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/neti.h> kstat_t *net_kstat_create(netid_t netid, char *module, int instance, char *name, char *class, uchar_type type, ulong_t ndata, uchar_t ks_flag); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
netid IP instance identifier. module The name of the provider's module (such as "sd", "esp", ...). The "core" kernel uses the name "unix". instance The provider's instance number, as from ddi_get_instance(9F). Modules which do not have a meaningful instance number should use 0. name A pointer to a string that uniquely identifies this structure. Only KSTAT_STRLEN - 1 characters are significant. class The general class that this kstat belongs to. The following classes are currently in use: disk, tape, net, controller, vm, kvm, hat, streams, kstat, and misc. type The type of kstat to allocate. Valid types are: KSTAT_TYPE_NAMED Allows more than one data record per kstat. KSTAT_TYPE_INTR Interrupt; only one data record per kstat. KSTAT_TYPE_IO I/O; only one data record per kstat ndata The number of type-specific data records to allocate. ks_flag A bit-field of various flags for this kstat. ks_flag is some combination of: KSTAT_FLAG_VIRTUAL Tells kstat_create() not to allocate memory for the kstat data section; instead, the driver will set the ks_data field to point to the data it wishes to export. This provides a convenient way to export existing data structures. KSTAT_FLAG_WRITABLE Makes the kstat data section writable by root. KSTAT_FLAG_PERSISTENT Indicates that this kstat is to be persistent over time. For persistent kstats, kstat_delete(9F) simply marks the kstat as dormant; a subsequent kstat_create() reactivates the kstat. This feature is provided so that statistics are not lost across driver close/open (such as raw disk I/O on a disk with no mounted partitions.) Note: Persistent kstats cannot be virtual, since ks_data points to garbage as soon as the driver goes away. DESCRIPTION
The net_kstat_create() function allocates and initializes a kstat(9S) structure. See kstat_create(9F) for a complete discussion of this function. RETURN VALUES
If successful, net_kstat_create() returns a pointer to the allocated kstat. NULL is returned upon failure. CONTEXT
The net_kstat_create() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
ddi_get_instance(9F), kstat_create(9F), kstat_delete(9F), net_kstat_delete(9F), hook_t(9S), kstat_named(9S) SunOS 5.11 1 May 2008 net_kstat_create(9F)
Man Page