Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_get_eventcookie(9f) [sunos man page]

ddi_get_eventcookie(9F) 				   Kernel Functions for Drivers 				   ddi_get_eventcookie(9F)

NAME
ddi_get_eventcookie - retrieve a NDI event service cookie handle SYNOPSIS
#include <sys/dditypes.h> #include <sys/sunddi.h> int ddi_get_eventcookie(dev_info_t *dip, char *name, ddi_eventcookie_t *event_cookiep); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dev_info_t *dip Child device node requesting the cookie. char *name NULL-terminated string containing the name of the event. ddi_eventcookie_t *event_cookiep Pointer to cookie where event cookie will be returned. DESCRIPTION
The ddi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that cookie. The search is performed by a calling up the device tree hierarchy until the request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached. The cookie returned by this function can be used to register a callback handler, unregister a callback handler, or post an event. RETURN VALUES
DDI_SUCCESS Cookie handle is returned. DDI_FAILURE Request was not serviceable by any nexus driver in the driver's ancestral device tree hierarchy. CONTEXT
The ddi_get_eventcookie() function can be called from user and kernel contexts only. ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ddi_add_event_handler(9F), ddi_remove_event_handler(9F) Writing Device Drivers SunOS 5.10 6 Nov 2003 ddi_get_eventcookie(9F)

Check Out this Related Man Page

usb_register_hotplug_cbs(9F)				   Kernel Functions for Drivers 			      usb_register_hotplug_cbs(9F)

NAME
usb_register_hotplug_cbs, usb_unregister_hotplug_cbs - Register/unregister for notification of device hotplug events SYNOPSIS
#include <sys/usb/usba.h> int usb_register_hotplug_cbs(dev_info_t *dip, int (*disconnection_event_handler)(dev_info_t *dip, int (*reconnection_event_han- dler)(dev_info_t *dip); void usb_unregister_hotplug_cbs(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
For usb_register_hotplug_cbs() dip Pointer to the device's dev_info structure. disconnection_event_handler Called when device is disconnected. This handler takes a dev_info_t as an argument (representing the device being disconnected) and always returns USB_SUCCESS. reconnection_event_handler Called when device is reconnected. This handler takes a dev_info_t as an argument (representing the device being reconnected) and always returns USB_SUCCESS. For usb_unregister_hotplug_cbs(): dip Pointer to the device's dev_info structure. DESCRIPTION
The usb_register_hotplug_cbs() function registers callbacks to be executed when the USB device represented by dip is hotplugged or removed. The usb_unregister_hotplug_cbs() function unregisters or disengages callbacks from executing when the USB device represented by dip is hot- plugged or removed. RETURN VALUES
For usb_register_hotplug_cbs(): USB_SUCCESS Callbacks were successfully registered. USB_FAILURE One or more arguments were NULL. Callbacks could not be successfully registered. For usb_unregister_hotplug_cbs(): None CONTEXT
The usb_register_hotplug_cbs() function may be called only from attach(9E). The usb_unregister_hotplug_cbs() function may be called only from detach(9E). Registered callback handlers requiring the use of any DDI (section 9F) function (except ddi_taskq_* functions), should launch a separate thread using ddi_taskq_* routines for processing their event, to avoid deadlocks. The new thread can then safely call any DDI function it needs to handle the event. The registered callback handlers execute in kernel context. EXAMPLES
int remove_device(dev_info_t *) { ... ... return (USB_SUCCESS); } int accommodate_device(dev_info_t *) { ... ... return (USB_SUCCESS); } if (usb_register_hotplug_cbs( dip, remove_device, accommodate_device) == USB_FAILURE) { cmn_err (CE_WARN, "%s%d: Could not register hotplug handlers.", ddi_driver_name(dip), ddi_get_instance(dip)); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), attach(9E), detach(9E), usb_get_status(9F) SunOS 5.10 17 Aug 2004 usb_register_hotplug_cbs(9F)
Man Page