Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

bzero(9f) [sunos man page]

bzero(9F)						   Kernel Functions for Drivers 						 bzero(9F)

NAME
bzero - clear memory for a given number of bytes SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> void bzero(void *addr, size_t bytes); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
addr Starting virtual address of memory to be cleared. bytes The number of bytes to clear starting at addr. DESCRIPTION
bzero() clears a contiguous portion of memory by filling it with zeros. CONTEXT
bzero() can be called from user or interrupt context. SEE ALSO
bcopy(9F), clrbuf(9F), kmem_zalloc(9F) Writing Device Drivers WARNINGS
The address range specified must be within the kernel space. No range checking is done. If an address outside of the kernel space is selected, the driver may corrupt the system in an unpredictable way. SunOS 5.10 1 May 1996 bzero(9F)

Check Out this Related Man Page

bstring(3C)						   Standard C Library Functions 					       bstring(3C)

NAME
bstring, bcopy, bcmp, bzero - memory operations SYNOPSIS
#include <strings.h> void bcopy(const void *s1, void *s2, size_t n); int bcmp(const void *s1, const void *s2, size_t n); void bzero(void *s, size_t n); DESCRIPTION
The bcopy(), bcmp(), and bzero() functions operate as efficiently as possible on memory areas (arrays of bytes bounded by a count, not terminated by a null character). They do not check for the overflow of any receiving memory area. These functions are similar to the memcpy(), memcmp(), and memset() functions described on the memory(3C) manual page. The bcopy() function copies n bytes from memory area s1 to s2. Copying between objects that overlap will take place correctly. The bcmp() function compares the first n bytes of its arguments, returning 0 if they are identical and 1 otherwise. The bcmp() function always returns 0 when n is 0. The bzero() function sets the first n bytes in memory area s to 0. WARNINGS
The bcopy() function takes parameters backwards from memcmp(). See memory(3C). ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Standard | +-----------------------------+-----------------------------+ |MT-Level |MT-Safe | +-----------------------------+-----------------------------+ SEE ALSO
memory(3C), attributes(5), standards(5) SunOS 5.10 15 Apr 2002 bstring(3C)
Man Page