Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

smartcard(5) [sunos man page]

smartcard(5)						Standards, Environments, and Macros					      smartcard(5)

NAME
smartcard - overview of smart card features on Solaris DESCRIPTION
The smart card framework provides a mechanism to abstract the details of interacting with smart cards and smart cardreaders (called card terminals). The framework is based on the OpenCard Framework V1.1 (OCF) with Sun extensions to allow OCF to operate in a multi-user envi- ronment. The core OCF software protocol stack is implemented as a system service daemon. This implementation allows smart cards and card terminals to be shared cooperatively among many different clients on the system while providing access control to the smart card and card terminal resources on a per-UID basis. An event dispatcher is provided to inform clients of events occuring on the card and at the card terminal, such as card insertion and card removal. A high-level authentication mechanism is provided to allow clients to perform smart card-based authentications without requiring knowledge of specific card or reader authentication features. A set of applet administration tools is provided for JavaCards that support downloading Java applets (although applet build tools are not provided). Administration of the smart card framework is provided with the smartcard(1M) command line administration utility and the smartcardguiad- min(1) GUI administration tool. Support the following card terminal is provided: o Dallas iButton Serial Reader (see ocf_ibutton(7D)) Additional card terminals can be supported by implementing smart card terminal interfaces in a shared library. Support for several smart cards is provided: o Schlumberger Cyberflex Access JavaCard o Schlumberger MicroPayflex o Dallas Semiconductor Java iButton JavaCard Each of the supported cards has a complete set of OCF card services that implement the necessary functionality for authentication and secure storage of data. For the two supported JavaCards, an authentication and secure data storage applet is provided that can be loaded into these cards with the supplied applet administration tools. See smartcard(1M). A PAM smart card module is provided to allow PAM clients to use smart card-based authentication. See pam_smartcard(5) CDE is able to use the PAM smart card module for dtlogin and dtsession authentication. CDE also uses the smart card framework event dis- patcher to listen for events on the card terminal and provide corresponding visual feedback to the user. SEE ALSO
ocfserv(1M), smartcard(1M), libsmartcard(3LIB), pam_start(3PAM), pam_smartcard(5), ocf_ibutton(7D), scmi2c(7D) SunOS 5.10 16 Oct 2002 smartcard(5)

Check Out this Related Man Page

SCF_Card_reset(3SMARTCARD)				    Smartcard Library Functions 				SCF_Card_reset(3SMARTCARD)

NAME
SCF_Card_reset - perform a reset of a smartcard SYNOPSIS
cc [ flag... ] file... -lsmartcard [ library...] #include <smartcard/scf.h> SCF_Status_t SCF_Card_reset(SCF_Card_t card); PARAMETERS
card The card (from SCF_Terminal_getCard(3SMARTCARD)) to be reset DESCRIPTION
The SCF_Card_reset() function causes the specified smartcard to be reset by the terminal. A card can be reset only if it has not been locked (with SCF_Card_lock(3SMARTCARD)) by another client. A client wishing to reset a card should either first call SCF_Card_lock() to obtain the card lock, or be prepared to retry the reset operation if it fails because another client holds the card lock. When the card is reset, any SCF_Card_t object representing the card will continue to remain valid after the reset. When the reset occurs, an SCF_EVENT_CARDRESET event will be sent to all registered event listeners for the terminal (assuming they registered for this event). This is the only notification of a reset provided to SCF clients. When a client receives this event, it should be prepared to reinitialize any state on the card that might have been interrupted by the reset. New information about the card (for example, ATR, if it changed) can also be available from SCF_Card_getInfo(3SMARTCARD). RETURN VALUES
If the card is successfully reset, SCF_STATUS_SUCCESS is returned. Otherwise, the status of the card remains unchanged and an error value is returned. ERRORS
The SCF_Card_reset() function will fail if: SCF_STATUS_BADHANDLE The specified card has been closed or is invalid. SCF_STATUS_CARDLOCKED The card cannot be reset because another client holds a lock on the card. SCF_STATUS_CARDREMOVED The card cannot be reset because the card represented by the SCF_Card_t has been removed. SCF_STATUS_COMMERROR The connection to the server was lost. SCF_STATUS_FAILED An internal error occured. EXAMPLES
Example 1: Reset a card. SCF_Status_t status; SCF_Card_t myCard; /* (...call SCF_Terminal_getCard to open myCard...) */ status = SCF_Card_lock(myCard, SCF_TIMEOUT_MAX); if (status != SCF_STATUS_SUCCESS) exit(1); status = SCF_Card_reset(myCard); if (status != SCF_STATUS_SUCCESS) exit(1); status = SCF_Card_unlock(myCard); if (status != SCF_STATUS_SUCCESS) exit(1); /* ... */ ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ |MT-Level |MT-Safe | +-----------------------------+-----------------------------+ SEE ALSO
libsmartcard(3LIB), SCF_Card_getInfo(3SMARTCARD), SCF_Card_lock(3SMARTCARD), SCF_Terminal_addEventListener(3SMARTCARD), SCF_Terminal_get- Card(3SMARTCARD), attributes(5) SunOS 5.10 28 Feb 2001 SCF_Card_reset(3SMARTCARD)
Man Page