Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

dlb(7) [osf1 man page]

dlb(7)							 Miscellaneous Information Manual						    dlb(7)

NAME
dlb, dlpi - STREAMS pseudodevice driver for bridging BSD Drivers to STREAMS SYNOPSIS
#include <sys/dlpihdr.h> #include <fcntl.h> fd = open ("/dev/streams/dlb", O_RDWR, 0); DESCRIPTION
The dlb STREAMS pseudodevice driver provides a communication path between BSD-style device drivers and STREAMS protocol stacks. The dlb STREAMS pseudodevice driver is the Stream end in a Stream that communicates with BSD-based device drivers. When the /dev/streams/dlb character device is open, a Stream is constructed between a Stream head and the dlb pseudodevice driver. After the Stream that is intended to communicate with the BSD-based driver or drivers is created, the protocol module or modules can be pushed onto it. Tru64 UNIX supports a subset of the Data Link Provider Interface (DLPI) connectionless mode of communication. The attach DLPI primitive is required to associate a particular physical point of attachment (PPA) with a Stream in Tru64 UNIX's implementation of the style 2 provider. On the write side, the dlb pseudodevice driver translates connectionless style 2 DLPI messages to the appropriate BSD ifnet interface mes- sages. On the read side, the user-bound Service Access Point (SAP) messages received from a selected PPA over BSD based driver or drivers are sent upstream. RELATED INFORMATION
Network Programmer's Guide specification in /usr/share/doclib/dlpi/dlpi.ps delim off dlb(7)

Check Out this Related Man Page

qassociate(9F)						   Kernel Functions for Drivers 					    qassociate(9F)

NAME
qassociate - associate STREAMS queue with driver instance SYNOPSIS
#include <sys/types.h> #include <sys/stream.h> #include <sys/stropts.h> #include <sys/ddi.h> #include <sys/sunddi.h> int qassociate(queue_t *q, int instance INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
queue_t *q Pointer to a queue(9S) structure. Either the read or write queue can be used. int instance Driver instance number or -1. DESCRIPTION
The qassociate() function must be used by DLPI style 2 device drivers to manage the association between STREAMS queues and device instances. The gld(7D) does this automatically on behalf of drivers based on it. It is recommended that the gld(7D) be used for network device drivers whenever possible. The qassociate() function associates the specified STREAMS queue with the specified instance of the bottom driver in the queue. Upon suc- cessful return, the stream is associated with the instance with any prior association dissolved. A DLPI style 2 driver calls qassociate() while processing the DL_ATTACH_REQ message. The driver is also expected to call this interface while performing stream associations through other means, such as ndd(1M) ioctl commands. If instance is -1, the stream is left unassociated with any hardware instance. If the interface returns failure, the stream is not associated with the specified instance. Any prior association is left untouched. The interface typically fails because of failure to locate and attach the device instance. The interface never fails if the specified instance is -1. CONTEXT
The qassociate() function can be called from the stream's put(9E) entry point. RETURN VALUES
0 Success. -1 Failure. EXAMPLES
DLPI style 2 network driver DL_ATTACH_REQ code specifies: if (qassociate(q, instance) != 0) goto fail; The association prevents Dynamic Reconfiguration (DR) from detaching the instance. DLPI style 2 network driver DL_DETACH code specifies: (void) qassociate(q, -1); This dissolves the queue's association with any device instance. DLPI style 2 network driver open(9E) code must call: qassociate(q, -1); This informs the framework that this driver has been modified to be DDI-compliant. SEE ALSO
dlpi(7P), gld(7D), open(9E), put(9E), ddi_no_info(9F), queue(9S) SunOS 5.11 01 Feb 2007 qassociate(9F)
Man Page